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About This Manual

About This Manual
Thank you for purchasing a Teledyne LeCroy oscilloscope. We're certain you'll be pleased with the detailed features
unique to our instruments.

This manual covers the operation and maintenance of all instruments in the WaveMaster 8000HD series, including
SDA models with the exception of the Serial Data Analysis software.

Documentation for implementing COM Automation and remote control, and for using optional software packages
sold for Teledyne LeCroy instruments such as decoders and Serial Data Analysis software, can be downloaded from
our free technical library at: teledynelecroy.com/support/techlib

Our website maintains the most current product specifications and should be checked for updates. Detailed
specifications are listed on the product datasheet.

Note: Specifications are subject to change without notice.
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Safety

Safety
Symbols
These symbols appear on the instrument or in documentation to alert you to important safety concerns:

Caution of potential damage to instrument or Warning of potential bodily injury. Refer to manual. Do not
proceed until the information is fully understood and conditions are met.

Warning, risk of electric shock or burn.

Caution, contains parts/assemblies susceptible to damage by Electrostatic Discharge (ESD).

Frame or chassis terminal (ground connection).

Alternating current.

Standby power (front of instrument).

Precautions
Observe generally accepted safety procedures in addition to the precautions listed here. The overall safety of any
system incorporating this product is the responsibility of the assembler of the system.

Use proper power cord. Use only the power cord shipped with the instrument and certified for the country of use.
Secure the cord at all times.

Maintain ground. The AC inlet ground is connected directly to the chassis of the instrument. To avoid electric shock,
connect only to a mating outlet with a safety ground contact.

Caution: Interrupting the protective conductor inside or outside the oscilloscope, or disconnecting the safety
ground terminal, creates a hazardous situation. Intentional interruption is prohibited.

Connect and disconnect properly. Do not connect/disconnect probes, test leads, or cables while they are connected
to a live voltage source.

Observe all terminal ratings. Do not apply a voltage to any input that exceeds the maximum rating of that input. Refer
to the marking next to the terminals for maximum allowed values.

Use indoors only within the operational environment listed. Do not use in wet or explosive atmospheres.

Keep product surfaces clean and dry. See Cleaning.

Do not block the cooling vents. Leave a minimum six-inch (15 cm) gap between the instrument and the nearest
object. Keep the underside clear of papers and other objects.

Exercise care when lifting and carrying. Unplug the instrument to move it. Use the built-in carrying handle.

Do not remove the covers or inside parts. Refer all maintenance to qualified service personnel.

Do not operate with suspected failures. Check body and cables regularly. If any part is damaged, cease operation
immediately and secure the instrumentfrom inadvertent use.
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Operating Environment
Temperature: 5 °C to 40 °C

Humidity: Maximum relative humidity (RH) 80% up to 31 °C,
decreasing linearly to 50% relative humidity at 40 °C

Altitude: Up to 10,000 ft (3,048 m) at or below 30 °C

Measuring Terminal Ratings (C1-C4 and Ext)
ProBus® Inputs 50 Ω coupling ≤ 5 Vrms

1 MΩ coupling ≤ 400 Vpk max. (Peak AC ≤ 10 KHz + DC);
derating at 18 dB/decade from 10 KHz to 1 MHz; 5 Vpk max. above 1 MHz

ProLink Inputs 50 Ω coupling ±2 Vmax

ProAxial™ Inputs 50 Ω coupling ±2 Vmax

1.85 mm (DBI) Inputs 50 Ω coupling ±2 Vmax

Caution: Measuring terminals have no rated measurement category per IEC/EN 61010-1:2010. Measuring
terminals are not intended to be connected directly to supply mains.

Cooling
The instrument relies on forced air cooling with internal fans and vents. The internal fan control circuitry regulates
the fan speed based on the ambient temperature. This is performed automatically after start-up.

Caution: Do not block the cooling vents.

Take care to avoid restricting the airflow to any part. In a benchtop configuration, leave a minimum of 15 cm (6
inches) around the sides between the instrument and the nearest object. The feet provide adequate bottom
clearance. Follow rackmount instructions for proper rack spacing.

Cleaning
Clean only the exterior of the instrumentusing a soft cloth moistened with water or an isopropyl alcohol solution. Do
not use harsh chemicals or abrasive elements. Under no circumstances submerge the instrument or allow moisture
to penetrate it. Dry thoroughly before connecting a live voltage source.

Caution: Unplug the power cord before cleaning. Do not attempt to clean internal parts.
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Power
The instrument automatically adapts to the line voltage; manual voltage selection is not required.

AC Power Source: 100-240 VAC (±10%) at 50/60 Hz (±10%)
Automatic AC voltage selection

Standard Models DBI Models

Maximum Consumption:* 1250 W 1300 W

Nominal Consumption: 1125 W 1175 W

Standby Consumption: 15 W 15 W

* All PC peripherals and active probes installed on four channels.

The provided power cords mate to a compatible power inlet on the instrument for making line voltage and safety
ground connections. The AC inlet ground is connected directly to the chassis of the instrument. For adequate
protection again electric shock, connect to a mating outlet with a safety ground contact.

Caution: Secure the power cord with the cable clamp at all times. Failure to do so creates a fire hazard.
Ensure the rear panel power switch is in the Off position before connecting to AC mains.
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Oscilloscope Overview and Set Up

Front of Oscilloscope

A. Front Panel controls

B. Touch Screen display

C. Power/Standby button

D. ProBus analog inputs

E. ProLink or ProAxial analog inputs

F. 1.85 mm analog inputs (DBI models only)

G. Aux In (ProBus) and Aux Out (BNC)

H. Fast Edge output

I. Ground and Cal terminals

J. Low-speed Mixed Signal input

K. USB 3.2 Gen1x1 ports (2)

L. USB-C Gen1x1 port

M. Tilting feet
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Side of Oscilloscope

A. Speaker Out and Mic In

B. USB 3.2 Gen2x1 ports (4)

C. Ethernet ports (2)

D. HDMI and DisplayPort outputs

E. Built-in carrying handles
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Back of Oscilloscope

A. Removable solid state drive

B. AC power inlet with clamp

C. LBUS connector (for HDA125 only)

D. 10 MHz Ref In and Ref Out BNC connectors

E. USBTMC port

6
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Front Panel
Front panel controls duplicate functionality available through the touch screen and
are described here only briefly.

Knobs on the front panel function one way if turned and another if pushed like a
button. The first label describes the knob’s “turn” action, the second label its “push”
action. Actions performed from the front panel always apply to the active trace.

Many buttons light to show the active traces and functions.

Trigger Controls
The front panel Level knob changes the trigger threshold level (V). The number is
shown on the Trigger descriptor box. Pushing the knob sets the trigger level to the
50% point of the input signal.

The READY indicator is lit when the trigger is armed. TRIG'D is lit momentarily when
a trigger occurs.

Setup opens the Trigger Setup dialog. Press it again to close the dialog.

Auto sets Auto mode, which triggers the oscilloscope after a set time, even if the
trigger conditions are not met.

Normal sets Normal mode, which triggers the oscilloscope each time a signal is
present that meets the trigger conditions.

Single sets Single trigger mode. The first press readies the oscilloscope to trigger.
The second press arms and triggers the oscilloscope once (single-shot acquisition)
when the input signal meets the trigger conditions.

Stop prevents the scope from triggering on a signal. If you boot up the instrument
with the trigger in Stop mode, a "No trace available" message is shown. Press the
Auto button to display a trace.

Horizontal Controls
Turn the Delay knob to change the Trigger Delay value (S). Push the knob to reset
Delay to zero.

If the trace source is an input channel, turn the Horizontal Adjust knob to set the
Time/division (S) of the oscilloscope acquisition system. The value is shown on the
Timebase descriptor box. When using this control, the oscilloscope allocates
memory as needed to maintain the highest sample rate possible for the timebase
setting. If the active trace is a math, zoom or memory, use this knob to change the

Horizontal Scale, effectively "zooming" in or out. The value is shown on the corresponding descriptor box. Push the
knob to adjust scale in fine increments; push it again to return to stepped increments.

Vertical Controls
The Offset knob adjusts the zero level of the trace (this makes it appear to move up or down relative to the center
axis of the grid). The value appears on the trace descriptor box. Push it to reset Offset to zero.
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The Vertical Adjust knob sets Vertical Gain (V/div) for channel traces or Vertical Scale for math, zoom and memory
traces. The value appears on the trace descriptor box. Push the knob to toggle between fine and stepped
increments.

The Channel buttons (1-4) turn on a channel that is off, or activate a channel that is already on. When the channel is
active, pushing its channel button turns it off. A lit button shows the active channel.

The Zoom (Z) button creates a Quick Zoom of each open trace.The resulting zoom traces are 1/10 of the source
channel horizontal scale and centered on the display. Use the Horizontal knobs to adjust this, or touch the zoom
descriptor box twice to display the zoom dialog controls. Touch the Zoom button again to turn off the zooms.

The Digital (D) button enables digital input on -MS models.

Math, Zoom and Mem Indicators
These LEDs light to indicate when a type of trace other than an input channel is currently active and controllable
using the Front Panel. Touch a trace descriptor box to make it active and controllable.

Cursor Controls
Cursors identify specific voltage and time values on the waveform. The white cursor markers help make these points
more visible, as well as provide a simple way to reposition them. A readout of the Vertical values appears on the
trace descriptor box, while the Horizontal values appear below the Timebase descriptor box.

There are five preset cursor types, each with a unique appearance on the display. These are described in more detail
in the Cursors section.

Press the Cursor Type button to apply or remove cursors. Continue pressing to cycle through all cursor types until
the desired type is found ("Off" occurs when no cursors are visible).

Turn the Coarse knob to adjust the position of absolute cursors (dashed-dotted lines). Push it to return the cursor to
the default 2.5 division setting. If you're using the Both Rel cursor type, each push will toggle between the Horizontal
and Vertical absolute cursors. With the correct cursor selected (highlighted), turn the knob to adjust the position.

Turn the Fine knob to adjust the position of relative cursors (dashed lines). Push it to return the cursor to the default
7.5 division setting, or to select the other relative cursor when using the Both Rel cursor type.

When a numeric value field is selected, these knobs serve as the Adjust knobs. Turn the Coarse knob to make large-
increment adjustments; turn the Fine knob to make small-increment adjustments. Push either knob to return to the
default setting.

When a waveform trace is selected (by touching the descriptor box or the trace itself), these knobs
increase/decrease trace intensity.

Miscellaneous Controls
These miscellaneous controls also appear along the top and bottom rows of the front panel.

Auto Setup performs an Auto Setup. After the first press, you will be prompted for a confirmation. Press the button
again or use the touch screen to confirm.

Default Setup resets the oscilloscope to the factory default configuration. After the first press, you will be prompted
for a confirmation. Press the button again or use the touch screen to confirm.

Clear Sweeps resets the acquisition counter and any cumulative measurements.

Touch Screen toggles on/off touch screen functionality.

8
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Save performs whatever action was last selected on the Save dialog: save a LabNotebook, screen image, setup or
waveform file.

User can be configured as you choose, for example:

l To save a screen capture using your current Screen Image Preferences.

l To save other file types: LabNotebooks, setup or waveforms.

See Configuring the User Button for instructions on making the selection.

Signal Interfaces
Teledyne LeCroy instruments offer a variety of interfaces to input analog or digital signals. See the oscilloscope
product page at teledynelecroy.com for a list of compatible input devices.

ProBus Interface
Upper row C1-C4 inputs utilize the ProBus interface.

The ProBus interface contains a 6-pin power and communication connection and a BNC signal connection to the
probe, with sense rings for detecting passive probes. It offers both 50 Ω and 1 MΩ input impedance, enabling it to
provide power and control for a wide range of probes such as high impedance passive probes, high impedance
active probes, current probes, high voltage probes, and differential probes.

Note: For backward compatibility of remote control and automation scripts, ProBus inputs are Input C on
WaveMaster 8000HD models, despite their top row placement.

The ProBus interface completely integrates the probe with the channel. Upon connecting a Teledyne LeCroy probe,
the probe type is recognized and some setup information, such as input coupling and attenuation, is performed
automatically. This information is displayed on the Probe Dialog, behind the Channel (Cn) dialog. System (probe plus
instrument) gain settings are automatically calculated and displayed based on the probe attenuation.

The ProBus interface may have a BNC-terminated cable connected directly to it. Depending on the BNC connector
used on the cable, the interface is rated for up to 2 GHz with 50 Ω coupling or 1 GHz with 1 MΩ coupling.

Note: Operational bandwidth is equal to the maximum input frequency of your oscilloscope model. See the
product datasheet.

ProLink Interface
The ProLink interface is used for input of high-speed signals up to 20 GHz. This interface is used on the bottom row
inputs of 20 GHz WaveMaster 8000HD oscilloscopes.

The ProLink interface contains a 6-pin power and communication connection and a Blind Mate Adapter (BMA) signal
connection to the probe. It offers 50 Ω input impedance and provides probe power and control for a wide range of
probes with bandwidth ratings from 3 GHz to 20 GHz.

Note: For backward compatibility of remote control and automation scripts, ProLink inputs are Input A.

9

Front_Panel_Setup.htm


WaveMaster 8000HD Oscilloscopes Operator's Manual

ProAxial Interface
25 GHz and higher WaveMaster 8000HD models utilize the ProAxial® interface for high-speed signals on the four,
outside bottom row inputs.

The ProAxial interface is used for acquisition of high-speed signals up to 33 GHz depending on model. This interface
consists of a precision signal connector and a LEMO plug to power probes. It offers 50 Ω input impedance only.
Teledyne LeCroy probes with ProAxial platforms (such as DHxx-PX probes) may be connected directly to the
ProAxial interface, or probes with 2.92MM platforms and 2.92 mm cable assemblies may be connected through the
supplied 2.92 mm connector saver.

The high-bandwidth electrical path is comprised of two connector halves/subassemblies that have a common
mating interface:

l The first half, mounted onto the oscilloscope connector panel, has a combination of grooves, external threads
and a coaxial interface which comprises a Planar Crown® airline geometry at the outer end.

l The second half is the 2.92 mm connector saver. It has the mating interface to the oscilloscope connector on
one end, and a female 2.92 connector on the other.

The 2.92 mm connector saver has projections which interlock with slots in the connector mounted on the
oscilloscope, and a coupling nut which secures the two halves, resulting in a non-rotational, torque independent
electrical connection. The spring-biased inner and outer contacts eliminate the need for specifying proof torque, so
no tools are required to mate or un-mate the connection. The connector saver is easily replaceable should damage
occur, making it a more field reliable system. The 2.92 mm connector savers operate mode free well beyond 36 GHz.

Note: For backward compatibility of remote control and automation scripts, ProAxial inputs are Input A.
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1.85 mm Interface
The 1.85 mm interface is used for DBI acquisition of signals on the inside, two bottom row inputs of ≥50 GHz
WaveMaster 8000HD models.

The interface consists of a precision V-male connector with a V-female-to-V-female barrel adapter and a LEMO plug.
It offers 50 Ω input impedance only. The barrel adapter is easily field replaceable, should damage occur. The male
connector is mounted onto the oscilloscope connector panel when delivered. The V-female-to- V-female barrel
adapter must be manually attached before connecting cables.

Note: For backward compatibility of remote control and automation scripts, DBI inputs are Input B.

To attach the V-female-to-V-female barrel adapter:

Note: The example shows the procedure on a LabMaster oscilloscope. The process is exactly the same for
all other oscilloscopes with a 1.85 mm interface.

1. Remove the white cap from the V-male connector on the 1.85 mm input. Turn it counterclockwise to loosen.

2. Insert the V-female-to-V-female barrel adapter into the V-male connector.

3. Gently turn the V-male connector in the counterclockwise direction until it is finger tight.
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4. Insert the hand wrench over the flat portion of the barrel adapter. This holds the barrel adapter still while the
V-male connector is tightened around it.

5. Tighten the V-male connector around the V-female-to-V-female barrel adapter using the torque wrench in a
counterclockwise motion.

Hold the torque wrench at the end or you may apply too much force. When the torque wrench bends at the
moment arm, it is tightened to the right amount of force. Do not tighten further.

6. Connect a cable to the barrel adapter, then use the torque wrench to tighten it.

To remove the V-female-to-V-female barrel adapter: Reverse the steps above, turning the V-male connector
clockwise to loosen it. Be sure to turn the V-male connector and not the barrel adapter. You may have to manually
keep the torque wrench from bending while loosening the connector.

LBUS Interface
The LBUS (LeCroy Peripheral Bus) interface provides precise timing synchronization between the oscilloscope and
the HDA125-xx-LBUS.

Other Analog Inputs
EXT In can be used to input an external trigger pulse.

REF In can be used to input an external reference clock signal.

These inputs have a simple BNC interface with no power supply. See your product datasheet for voltage and
frequency ratings.

12
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Mixed Signal Inputs
The following options are available for inputting digital/mixed-signals into the oscilloscope.

Digital Leadset
The digital leadset shipped with the MSO option connects to the Mixed Signal Input on the front of the oscilloscope
to input of up-to-16 lines of digital data. Physical lines can be preconfigured into different logical groups, Digitaln,
corresponding to a bus and renamed appropriately depending on the group. The transitions for each line may be
viewed through different displays.

See Connecting the Digital Leadset for instructions.

HDA125 Digital Analyzer
The HDA125 High-speed Digital Analyzer is a complete system that adds digital acquisition and triggering
capabilities. The HDA125 is optimized for acquiring high-speed digital signals, with a sample rate of 12.5 GS/s on all
18 input channels. Depending on the model, it may operate through connection to the instrument's LBUS or SYNC
interface.

See Connecting the HDA125 and the HDA125 Operator's Manual for detailed instructions.

Probes
The oscilloscope is compatible with the included passive probes and most Teledyne LeCroy active probes that are
rated for the instrument’s bandwidth. Probe specifications and documentation are available at
teledynelecroy.com/probes.

Passive Probes
The passive probes supplied are matched to the input impedance of the instrument but may need further
compensation. Follow the directions in the probe instruction manual to compensate the frequency response of the
probes.

If using other passive probes than those supplied, be sure to perform a low frequency calibration before using them
to measure signal.

Active Probes
Teledyne LeCroy offers a variety of active probes for use with your oscilloscope. Most active probes match probe to
oscilloscope response automatically using probe response data stored in an on-board EEPROM. This ensures the
best possible combined probe plus oscilloscope channel frequency response without the need to perform any de-
embedding procedure.

Be aware that many active probes require a minimum oscilloscope firmware version to be fully operational. See the
probe documentation.
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Securing the Power Cord
Always secure the power cord with the clamp. Loosen the
Philips head screw, insert the power cord receptacle completely
into the AC inlet, then secure the clamp over the cord.

Caution: To avoid a fire hazard, the power cord must
be fully inserted and secured tightly to the clamp.

After securing the cord to the oscilloscope, connect it to a
grounded AC power outlet.

Caution: Only the power cord disconnects the product from the power source. Do not position the
equipment so that it is difficult to operate the power cord; it must remain accessible to the user at all times
to allow for quick disconnection.

Powering On/Off

Press the Power button to turn on the instrument. If the button is not easily accessible (e.g., in a rackmount),
you can go to Utilities > Preferences and enable Power on AC. Then, the instrument will start whenever the AC power
supply is turned on.

Caution: Do not power on or calibrate with a signal attached.

Powering on will automatically start all services and load the oscilloscope application software. After a 35-40 min.
warm up and calibration period, the oscilloscope will be fully operational.

To power down, you can quickly press the Power button again, but the safest way to power down is to use the File >
Shutdown menu option, which will always execute a proper shut down process and preserve settings. Holding the
Power button will execute a “hard” shut down (as on a computer), which we do not recommend doing because it
does not allow the operating system to close properly, and setup data may be lost.

Caution: Except for emergencies, never power off by pulling the power cord or turning off the AC supply
without first shutting down the oscilloscope application properly.

The Power button does not disconnect the instrument from the AC power supply. The only way to fully power down
the instrument is to unplug the AC power cord or otherwise turn off the AC power supply.

We recommend unplugging the instrument if it will remain unused for a long period of time.
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Software Activation
The oscilloscope software (firmware and standard applications) is active upon delivery. At power-up, the instrument
loads the software automatically.

Free firmware updates are available periodically. Visit the software download page of our website at
teledynelecroy.com and go to Oscilloscope Downloads > Firmware Upgrade.

Registered users can receive an email notification when a new update is released. Follow the instructions in
Firmware Update to download and install the software.

If you decide to purchase an option, you will receive a license key via email that activates the optional features. See
Options for instructions on activating optional software packages.

Connecting to Other Devices/Systems
Use the menu options listed below to configure connections to other devices.

LAN
The instrument is preset to accept a DHCP network address over a TCP/IP connection. Connect a cable from an
Ethernet (LAN) port to a network access device. Go to Utilities > Utilities Setup > Remote to find the IP address.

To assign a static IP address, choose Net Connections from the Remote dialog. Use the standard Windows
networking dialogs to configure the device address.

Choose File > File Sharing and open the Email & Report Settings dialog to configure email settings.

Audio/USB Peripherals
Connect the device to the appropriate port on the instrument. These connections are "plug-and-play" and do not
require any additional configuration.

Printer
MAUI oscilloscopes support USB printers compatible with the instrument's Windows OS. Go to File > Print Setup to
configure printer settings. Select Properties to open the Windows Print dialog.

External Monitor
You may operate the instrument using the built-in touch screen or attach an external monitor for extended desktop
operation. See your product datasheet for the supported monitor resolution.

Connect the monitor cable to a video output on the instrument. You can use an adaptor if the monitor cable has a
different interface. Go to Display > Display Setup > Open Monitor Control Panel to configure the display. Be sure to
select the instrument as the primary display.

To use the Extend Grids feature, configure the second monitor to extend, not duplicate, the oscilloscope display. If
the external monitor is touch screen enabled, the MAUI user interface can be controlled through touch on the
external monitor as well as the oscilloscope. See Windows 10 External Display Setup for additional instructions on
setting up external monitors with Windows 10 oscilloscopes.

15
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Remote Control
Go to Utilities > Utilities Setup > Remote to configure remote control. Connect the oscilloscope to the
network/controller using the cable type required by your selection.

l VICP( TCP/IP) and VXI-11(LXI) over Ethernet are supported standard, as is USBTMC.

l GPIB is supported with the use of the optional USB-GPIB adapter.

Note: Choose TCP/IP for remote control using MAUI Studio Pro. You can make the Ethernet connection
over a LAN or connect directly to the MAUI Studio host PC.

Auxiliary Output
To output signal to another instrument, connect a BNC cable from Aux Out to the other device. Go to Utilities >
Utilities Setup > Aux Output to configure the output.
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Using MAUI
MAUI (Most Advanced User Interface) is Teledyne LeCroy's unique oscilloscope user interface. MAUI provides an
extensible front-end to the MAUI oscilloscope application, integrating software options into a single application that
can be controlled using the latest Windows touch screen features.

MAUI Application
MAUI forms the front-end of Teledyne LeCroy oscilloscopes, providing a single interface for all standard and optional
oscilloscope applications. MAUI runs on the Microsoft Windows platform.

The oscilloscope firmware and standard applications are active upon delivery. At power-up, the instrument loads the
software automatically. Free updates are available periodically from the software download page of our website at
teledynelecroy.com. Go to Oscilloscope Downloads > Firmware Upgrade. Follow the instructions in Firmware Update
to download and install the software.

When you purchase an option, you will receive a license key via email that activates the optional features. See
Options for instructions on activating optional software packages.

Automation
The MAUI application is a COM Automation server. All the configurable application objects that are presented
through MAUI can be controlled using COM Automation strings embedded in remote control scripts. See the MAUI
Oscilloscopes Remote Control and Automation Manual for instructions.

Besides reading waveform and measurement data from the oscilloscope, a common use of Automation is the
creation of remote setup files. In fact, MAUI provides a simple way to save any oscilloscope configuration to a
LeCroy System Setup (.LSS) file, which is nothing more than a COM Automation program written in VB Script, ready
to restore the entire saved configuration when executed.

Our proprietary LabNotebook feature goes even further to save not only the setups but also the waveform data to a
file that can restore the full oscilloscope display to the exact state in which it was saved.

Further customization, such as the introduction of custom math or measurement processors into MAUI, can be
performed on oscilloscopes equipped with CustomDSO. See our website for examples.

Volatile vs. Non-Volatile Settings
Most of the oscilloscope settings are volatile, meaning they will automatically revert to the factory default whenever
the oscilloscope is rebooted, or when you choose to recall the default setup using the front panel Default Setup
button or the Recall dialog.

Those settings that are exceptions to this rule are called non-volatile. These settings will be retained session to
session until you manually change them. Non-volatile settings include:

l All preferences settings (including acquisition, calibration, color and miscellaneous)

l All networking, remote control and email settings

l All printer settings and screen image (file) preferences

l All report settings, including logo selections

l All file paths and names, including auto-naming selections

17
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Touch Screen
With MAUI, the touch screen is the principal control center of the oscilloscope. The entire display is active: use your
finger or a stylus to touch, drag, swipe, and draw selection boxes. With the addition of OneTouch, gestures such as
pinch and flick can be used to control the screen.

Many controls that display information also work as “buttons” to access other functions, and even the waveform
traces can be manipulated. If you have a mouse installed, you can click anywhere you can touch to activate a control;
in fact, you can alternate between clicking and touching, whichever is convenient for you.

The touch screen is divided into the following major control groups:

Menu bar

Grid

Descriptor boxes

Dialogs

Message bar

Menu Bar
The top of the window contains a complete menu of functions. Making a selection here changes the dialogs
displayed at the bottom of the screen. While many operations can also be performed from the front panel or
launched via the descriptor boxes, the menu bar is the best way to access dialogs for Save/Recall (File) functions,
Display functions, Status, LabNotebook, Pass/Fail setup, optional Analysis packages, and Utilities/Preferences
setup.

If an action can be “undone”, the Undo button at the right of the menu bar restores the oscilloscope display to
the state prior to the action.

Grid
The grid displays the waveform traces. Every grid is 8 Vertical divisions representing the full number of 4096 Vertical
levels and 10 Horizontal divisions representing the total acquisition time. The value of each division depends on the
Vertical and Horizontal scale of the traces that appear on that grid.

Multi-Grid Display
The screen can be divided into multiple grids, each showing different types and numbers of traces (in Auto Grid
mode, it will divide automatically as needed). Regardless of the number and orientation of grids, every grid always
represents the same number of Vertical levels so that absolute measurement precision is maintained. See Display.
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Different types of traces opening in a multi-grid display.

Grid Indicators
These indicators appear around or on the grid to mark important points on the display. They are matched to the
color of the trace to which they apply. When multiple traces appear on the same grid, indicators refer to the
foreground trace—the one that appears on top of the others.

Axis labels mark the times/units represented by a grid division. They update dynamically as you pan the
trace or change the Vertical/Horizontal scale. Originally shown in absolute values, the labels change to
show delta from 0 (center) when the number of significant digits grows too large. To remove axis labels,
go to Display > Display Setup and deselect Axis Labels.

Trigger Time, a small triangle along the bottom (horizontal) edge of the grid, shows the time of the trig-
ger. Unless Horizontal Delay is set, this indicator is at the zero (center) point of the grid. Delay time is
shown on the Timebase descriptor box.

Pre/Post-trigger Delay, a small arrow to the bottom left or right of the grid, indicates that a pre- or post-
trigger Delay has shifted the Trigger Position indicator to a point in time not displayed on the grid. All
Delay values are shown on the Timebase descriptor box.

Trigger Level at the right edge of the grid tracks the trigger voltage level. A solid triangle indicates the
last triggered level. If you change the trigger level prior to acquisition (e.g., in Stop mode), a hollow tri-
angle of the same color appears at the new trigger level. The trigger level indicator is not shown if the
triggering channel is not displayed.

Zero Volts Level is located at the left edge of the grid. One appears for each open trace on the grid, shar-
ing the number and color of the trace.

Cursor markers appear over the grid to indicate the voltage and time being measured on the waveform.
Drag-and-drop cursor markers to quickly reposition the measurement.

Grid Intensity
You can adjust the brightness of the grid lines by going to Display > Display Setup and entering a new Grid Intensity
percentage. The higher the number, the brighter and bolder the grid lines.
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Descriptor Boxes
Trace descriptor boxes appear just beneath the grid whenever any type of waveform trace or graph is turned on.
They function to:

l Inform—descriptors summarize the current trace settings and its activity status.

l Navigate—touch the descriptor box once to activate the trace, again to open the setup dialog.

l Arrange—drag-and-drop descriptor boxes to move traces among grids.

l Configure—drag-and-drop descriptor boxes to change source or copy setups.

The following descriptors appear within standard MAUI. Graph/trace descriptor boxes that are unique to software
options (e.g., eye diagrams) are described with the option.

Channel Descriptor
Channel trace descriptor boxes correspond to analog signal inputs. They show (clockwise from
top left): channel number, pre-processing list (if any), coupling, vertical scale (gain) setting,
vertical offset setting, sweeps count (when averaging), vertical cursor positions, and number of
segments acquired (when in Sequence mode). On WaveMaster 8000HD models, channel
operating bandwidth adjusted for DBI, bandwidth filters and probes is also shown, and per
division values are indicated by a slash "/" following the number.

If you are interleaving channels (e.g., DBI), channel descriptor boxes will show the channel's overall acquisition
status: trigger only, active or not active.

Codes are used to indicate coupling and pre-processing affecting the channel.
Symbols on Channel Descriptor Boxes

Processing Type Code

Coupling D50, DC1, AC1 or GND
Bandwidth Limiting BWL
Averaging AVG
(Sinx)/x Interpolation /
Enhanced Sample Rate

SINX / ESR

Deskew DSQ
Noise Filter (ERes) FLT
Inversion INV

Note: Interpolation, Averaging and Noise Filter are disabled on acquisitions >500 Mpts in length.

Math, Zoom and Memory Descriptors
Similar descriptor boxes appear for math (Fn), zoom (Zn) and memory (Mn) traces. These
descriptors show any Horizontal scaling that differs from the channel timebase. Units will be
automatically adjusted for the type of trace. The descriptors can be used same as channel
descriptors to re-activate the trace , move the trace or open the trace context menu.
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Timebase and Trigger Descriptors
The Timebase descriptor box shows: (clockwise from top right) Horizontal
Delay, Time/div, Sample Rate, Number of Samples and Sampling Mode
(blank when in real-time mode).

The Trigger descriptor box shows: (clockwise from top right) Source and
Coupling, Level (V), Slope/Polarity, Type and Mode.

Horizontal (time) cursor readout, including the time between cursors and the frequency, is shown beneath the
TimeBase and Trigger descriptor boxes. See the Cursors section for more information.

Trace Context Menu
The trace context menu is a pop-up menu of actions to apply to a trace, such as turn off, add
measurement, label or rename.

To open the trace context menu, either right-click on the descriptor box, or touch and hold on the
descriptor box until a white box appears, then lift your finger.

Dialogs
Dialogs appear at the bottom of the display for entering setup data. The top dialog will be the main entry point for the
selected functionality. For convenience, related dialogs appear as a series of tabs behind the main dialog. Touch the
tab to open the dialog.

Right-hand Subdialogs
At times, your selections will require more settings than can fit on one dialog, or the task invites further action, such
as zooming a new trace. In that case, subdialogs will appear to the right of the dialog. These subdialog settings
always apply to the object that is being configured on the tab to the left.
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Action Toolbar
Several setup dialogs contain a toolbar at the bottom of the dialog. These buttons enable you to perform
commonplace tasks—such as turning on a measurement—without having to leave the underlying dialog. Toolbar
actions always apply to the active trace.

Measure opens the Measure pop-up to set measurement parameters on the active trace.

Zoom creates a zoom trace of the active trace.

Math opens the Math pop-up to apply math functions to the active trace and create a new math trace.

Decode opens the main Serial Decode dialog where you configure and apply serial data decoders and triggers. This
button is only active if you have serial data software options installed.

Store loads the active trace into the corresponding memory location (C1, F1 and Z1 to M1; C2, F2 and Z2 to M2, etc.).

Find Scale performs a vertical scaling that fits the waveform into the grid.

Add/Edit Name opens the virtual keypad for you to alias the trace.

Label opens the Label pop-up to annotate the active trace.

Histogram, Trend, and Track buttons appear in the Action toolbar at the bottom of the Parameter (Pn) dialogs. They
allow you to create a Math function to plot the parameter while remaining on the measurement dialogs.

Message Bar
At the bottom of the oscilloscope display is a narrow message bar. The current date and time are shown at the far
right. Status, error, or other messages are shown at the far left, where "Teledyne LeCroy" normally appears.

You will see the word "Processing..." highlighted with red at the right of the message bar when the oscilloscope is
processing your last acquisition or calculating.

This will be especially evident when you change an acquisition setting that affects the ADC configuration while in
Normal or Auto trigger mode, such as changing the Vertical Scale, Offset, or Bandwidth. Traces may briefly
disappear from the display while the oscilloscope is processing.

Language Selection
To change the language of the oscilloscope application:

1. Go to Utilities > Preference Setup > Preferences and make a Language selection.

2. Follow the prompt to restart the application.
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Windows 10 Gestures
Windows 10 oscilloscopes support new touch screen gestures for accessing applications and settings:

l Swipe from the left of the screen to switch applications or show the desktop. Continue swiping to return to
MAUI.

l Swipe from the right of the screen to open the Action Center, from where you can access system settings.

Controlling Traces
Traces are the visible representations of waveforms that appear on the display grid. They may show live inputs (Cn,
Digitaln), a math function applied to a waveform (Fn), a stored memory of a waveform (Mn), a zoom of a waveform
(Zn), or the processing results of special analysis software.

Traces are a touch screen object like any other and can be manipulated. They can be panned, moved, labeled,
zoomed and captured in different visual formats for printing and reporting.

Each visible trace will have a descriptor box summarizing its principal configuration settings. See OneTouch Help for
more information about how you can use traces and trace descriptor boxes to modify your configurations.

Turning On/Off Traces

Turn On/Off Analog Trace
To turn on a channel trace, do any of the following:

l From the front panel, press the Channel button.

l From the touch screen, choose Vertical > Channel n Setup.

l Touch the Add New box and select Channel, or drag another Cn descriptor box to Add New.

To turn off a trace, press the front panel Channel button a second time, or from the touch screen, either:

l Right-click on the descriptor box and choose Off.

l Touch the descriptor box and clear the Trace On checkbox on the setup dialog.

Turn On/Off Digital Trace
To turn on digital traces, from the touch screen, choose Vertical > Digitaln Setup, then check Group on the Digitaln
dialog.

To turn off the traces, clear the Group checkbox.

Turn On/Off Other Trace
To turn on/off math or memory traces, check or clear the Trace On box on the respective setup dialogs.

You can also touch the Add New box and select the trace type, or drag another descriptor box of that same type to
the Add New box (e.g., drag M1 to Add New to turn on a the next available memory trace).
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Activating Traces
Although several traces may be open, only one trace is active and can be adjusted using front panel controls and
touch screen gestures. A highlighted descriptor box indicates which trace is active. All actions apply to that trace
until you activate another. Touch the trace descriptor box to make it the active trace (and the foreground trace in that
grid).

Active trace descriptor (left), inactive trace descriptor (right).

Whenever you activate a trace, the dialog at the bottom of the screen automatically switches to the appropriate
setup dialog.

Since multiple traces can be opened on the same grid, the trace shown on top of the others is the foreground trace.
Grid indicators (matched to the input channel color) represent the foreground trace.

Touch a trace or its descriptor box to bring it to the foreground. This also makes it the active trace.

Note that a foreground trace may not be the same as the active trace. A trace in a separate grid may subsequently
become the active trace, but the indicators on a given grid will still represent the foreground trace in that group.

Adjusting Traces
To adjust Vertical Scale and Offset, or Horizontal Scale and Delay, just activate the trace and use the front panel
knobs. To make other adjustments—such as units—touch the trace descriptor box twice to open the appropriate
setup dialog.

Many settings are adjusted by selecting from the pop-up that appears when you touch a control.
When an entry field appears highlighted in blue after touching, it is active and can be adjusted by
turning the front panel knobs. Fields that don't have a dedicated knob (as do Vertical Level and
Horizontal Delay) can be modified using the Adjust knob.

If you have a keyboard installed, you can type entries
in an active (highlighted) data entry field. Or, you can touch it again, then
"type" the entry by touching keys on the virtual keypad or keyboard.

To use the virtual keypad, touch the soft keys exactly as you would a
calculator. When you touch OK, the calculated value is entered in the
field.

Measurements and math are calculated on only the center 500 Mpts of
acquisitions greater than 500 Mpts in length, known as the analysis
zone. This region of the source trace is indicated by shading applied
outside the area, leaving the analysis zone "highlighted" by its absence.
The area of the analysis zone can be adjusted by using Horizontal Delay
and other methods to shift the desired portion of the trace into the
unshaded area. See Navigating Long Acquisitions.
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Moving Traces
You can move a trace from one grid to another by dragging its descriptor box to the desired grid. This is a convenient
way to quickly re-arrange traces on the display.

If you are in Q-Scape display mode, you can drag the descriptor box to a grid on another tab, provided the grid is
visible while you are moving the trace. For example, you cannot drag descriptors across tabs in Q-Scape Single
mode, because the target grids aren't visible, but you can in Q-Scape Dual or Q-Scape Mosaic modes. This is true
even in extended display. For more information, see Display.

See OneTouch Help for ways to pan traces within the same grid.

Naming Traces (Aliases)
A custom name can be added to the mnemonic associated with a trace on its descriptor box, making the
oscilloscope user interface more intuitive. This custom name will appear in reports and wherever this trace is
referenced on the user interface. On trace descriptor boxes, the original trace label will appear above the alias.

A custom name (alias) can be added to trace descriptor boxes.

Note: Although there is a 250 character logical limit, we recommend keeping names to 10 characters or
less, as characters over this number will be truncated on the display. Custom aliases apply only to the
oscilloscope display; use the original trace mnemonic (C1-Cn, F1-Fn, etc.) to refer to traces in remote
control programs.

Adding Name

1. Select Add/Edit Name from the Action toolbar on the trace setup dialog.

2. On the virtual keyboard, enter the new name (alias) and click OK.

Removing Name
To remove an alias from the trace, click Add/Edit Name again and choose Remove Name.
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Labeling Traces
The Label function gives you the ability to add custom annotations to the trace display. Once
placed, labels can be moved to new positions or hidden while remaining associated with the
trace.

Create Label

1. Select Label from the context menu, or touch the Label Action toolbar button on the trace setup dialog.

2. On the Trace Annotation pop-up, touch Add Label.

3. Enter the Label Text.

4. Optionally, enter the Horizontal/Vertical Pos. (in same units as the trace) at which to place the label. The
default position is 0 ns. Use Trace Vertical Position places the label immediately above the trace.

Reposition Label
Drag-and-drop labels to reposition them, or change the position settings on the Trace Annotation pop-up.

Edit/Remove Label
On the Trace Annotation pop-up, select the Label from the list. Change the settings as desired, or touch Remove
Label to delete it.

Clear View labels to hide all labels. They will remain in the list.
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Finding Trace Status
If a small letter "i" inside a bubble appears on the trace descriptor box, this indicates there is additional information
regarding a waveform processing error that resulted in the oscilloscope being unable to display a trace, or producing
a trace that could lead to unreliable measurements.

To find out the additional information behind this indicator, use the MAUI Browser installed on the oscilloscope to
view the Automation result interface: app.Subsystem.Wfmn.Out.Result.Samples

For example, if the F1 descriptor shows the "i" indicator, look at: app.Math.F1.Out.Result.Samples

See the MAUI Oscilloscopes Remote Control and Automation Manual for instructions on using MAUI Browser to view
Automation results.

The Status property of the Out. Result.Samples interface will show the value of the error status bit that was
generated (there is no value if there is no error). The table below shows the status bit meaning.

Bit # Value Description

0 0x0000000000001 Invalid
1 0x0000000000002 Overflow
2 0x0000000000004 Underflow
3 0x0000000000008 Contains Undefined Values
4 0x0000000000010 Less Than
5 0x0000000000020 Greater Than
6 0x0000000000040 Not A Pulse
7 0x0000000000080 Not Cyclic
8 0x0000000000100 Averaged
9 0x0000000000200 Unlocked PLL
10 0x0000000000400 Other Error
11 0x0000000000800 Other Warning
12 0x0000000001000 Other Info
32 0x0000100000000 Inputs Incompatible
33 0x0000200000000 Algorithm Limits Reached
34 0x0000400000000 Bad Definition
35 0x0000800000000 Too Few Data
36 0x0001000000000 Too Many Data
37 0x0002000000000 Uniform HorizInterval Required
38 0x0004000000000 Bad Units
39 0x0008000000000 Data Range Too Low
40 0x0010000000000 Data Undersampled
41 0x0020000000000 Poor Statistics
42 0x0040000000000 Slow Transition Time
43 0x0080000000000 Data Resampled
44 0x0100000000000 Data Interpolated
45 0x0200000000000 Measurement Scale Imprecise
46 0x0400000000000 No Data Available
47 0x0800000000000 Some Cummulated Results Invalid
48 0x1000000000000 Insufficient Memory
49 0x2000000000000 Channel Not Active
50 0x4000000000000 Use Status Description
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MAUI with OneTouch
Gestures like touch, drag, swipe, pinch and flick can be used to create and change setups with one touch. Just as
you change the display by using the setup dialogs, you can change the setups by moving different display objects.
Use the setup dialogs to refine OneTouch actions to precise values.

As you drag & drop objects, valid targets are outlined with a white box. When you're moving over invalid targets, you'll
see the "Null" symbol ( Ø ) under your finger tip or cursor.

Turn On
To turn on a new channel, math, memory, or zoom trace, drag any descriptor box of the same type to the Add New
("+") box. The next trace in the series will be added to the display at the default settings. It is now the active trace.

If there is no descriptor box of the desired type on the screen to drag, touch the Add New box and choose the trace
type from the pop-up menu.

To turn on the Measure table when it is closed, touch the Add New box and choose Measurement.

Activate
Touch a trace or its descriptor box to activate it and bring it to the foreground. When the descriptor box appears
highlighted in blue, front panel controls and touch screen gestures apply to that trace.
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Copy Setups
To copy the setup of one trace to another of the same type (e.g., channel to channel, math to math), drag-and-drop
the source descriptor box onto the target descriptor box.

To copy the setup of a measurement (Pn), drag-and-drop the source column onto the target column of the Measure
table. You can do the same for a query (Qn) on the Pass/Fail readout table.

Change Source
To change the source of a trace, drag-and-drop the descriptor box of the desired source onto the target descriptor
box. You can also drop it on the Source field of the target setup dialog.

To change the source of a measurement, drag-and-drop the descriptor box of the desired source onto the parameter
(Pn) column of the Measure table. You can do the same to a query (Qn) on the Pass/Fail readout table.
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Position Cursors
To change cursor measurement time/level, drag cursor markers to new positions on the grid.
The cursor readout will update immediately.

To place horizontal cursors on zooms or other calculated traces where the source Horizontal Scale has forced
cursors off the grid, drag the cursor readout from below the Timebase descriptor to the grid where you wish to place
the cursors. The cursors are set at either the 5 (center) or the 2.5 and 7.5 divisions of the grid. Cursors on the source
traces adjust position accordingly.

Change Trigger
To change the trigger level, drag the Trigger Level indicator to a new position on the Y axis.
The Trigger descriptor box will show the new voltage Level.

To change the trigger source channel, drag-and-drop the desired channel (Cn) descriptor box onto the Trigger
descriptor box. The trigger will revert to the coupling and slope/polarity last set on that channel.

Store to Memory
To store a trace to internal memory, drag-and-drop its descriptor onto the target memory (Mn) descriptor.
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Move Trace
To move a trace to a different grid, drag-and-drop the trace descriptor box onto the target grid.

Scroll
To scroll long lists of values or readout tables, swipe the selection dialog or
table in an up or down direction.

Pan/Swipe Trace
To pan a trace, activate it to bring it to the forefront, then drag the waveform
trace right/left or up/down. If it is the source of any other trace, that trace will
move, as well.

For channel traces, the Timebase descriptor box will show the new
Horizontal Delay value. For other traces, the zoom factor controls show the
new Horizontal Center.

Tip: If you are using the multi-zoom feature, all time-locked traces
will pan together.

Panning is an excellent way to quickly move a trace into the Analysis Zone on >500 Mpts acquisitions. To pan at an
accelerated rate, swipe the trace right/left or up/down.

Swipe from the far left of the screen to switch "tabs" and show the Windows desktop. Swipe from left again to return
to the oscilloscope application.

31

Zoom_Multi-Zoom.htm


WaveMaster 8000HD Oscilloscopes Operator's Manual

Turn Off
To turn off a trace, flick the trace descriptor box toward the bottom of the screen.

To turn off a measure parameter or Pass/Fail query, flick the Pn or Qn cell toward the bottom of the screen. If it's the
last active cell of the table, the table will close.

Rectangle Zoom
To create a new channel zoom trace, touch then drag diagonally to draw a rectangle
around the portion of the trace you want to zoom. Touch the Zn descriptor box to open
the zoom factor controls and adjust the zoom exactly.
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Pinch Zoom
To "zoom in" on any trace, unpinch two fingers over the trace horizontally.

To "zoom out" on any trace, pinch two fingers over the trace horizontally.

Note: Pinch gestures do not create a separate zoom (Zn) trace, they only adjust the Horizontal Scale. When
you pinch a channel (Cn) trace, the Timebase for all channels changes. If the trace is the source of any
other, all its dependent traces change, as well.
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Waveform Acquisition
Topics in this section explain how to configure the instrument to acquire and view the status of waveforms.

Auto Setup
Auto Setup configures the essential acquisition settings based on the first input signal it finds, starting with C1. If
nothing is connected to C1, it searches C2 and so forth until it finds a signal. Vertical Scale (Volts/div), Offset,
Timebase (Time/div), and Trigger are set to a 50% Edge trigger on the first, non-zero-level amplitude, with the entire
waveform visible for at least 10 cycles over 10 horizontal divisions.

To run Auto Setup:

1. Press the front panel Auto Setup button, or choose Auto Setup from the Vertical, Timebase, or Trigger menus
(these all perform the same function).

2. To confirm, press the Auto Setup button again, or use the touch screen display.

After running Auto Setup, you'll see the words "Auto Setup" next to an Undo button at the far right of the menu bar.
This allows you to restore the settings in place prior to the Auto Setup. 

Caution: You will undo all new measurements or math function definitions entered since the Auto Setup
when you Undo the Auto Setup.
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Vertical
Vertical, also called Channel, settings usually relate to voltage level and control traces along the Y axis.

Note: While Digital settings can be accessed through the Vertical menu on oscilloscopes with mixed-signal
capabilities, they are handled quite differently. See Digital.

The amount of voltage displayed by one vertical division of the grid, or Vertical Scale (V/div), is most quickly adjusted
by using the front panel Vertical knob. The Cn descriptor box always shows the current Vertical Scale setting.

Detailed configuration for each trace is done on the Cn dialogs. Once configured, channel traces can be quickly
turned on/off or modified using the Channel Setup dialog

Channel Setup Dialog
Use the Channel Setup dialog to quickly make basic Vertical settings for all analog input channels. On WaveMaster
8000HDs, you can also use it to make Differential Pair settings.

To access the Channel Setup dialog, choose Vertical > Channel Setup from the menu bar.

To turn on/off the channel trace, select/deselect the checkbox.

To change the trace color, touch the color block, then choose the new color from the pop-up.

Basic Vertical Settings
To change any basic Vertical settings, touch the input field and enter the new value.

To quickly propagate the changes, touch Copy Channel Setup and select the channels to Copy From and Copy To.

Tip: On instruments with OneTouch, you can copy settings from one channel to another just by dragging the
source channel descriptor box onto the target channel descriptor box.

Differential Pair Settings
On WaveMaster 8000HD oscilloscopes, you can create a differential input. On the Channel Setup dialog, choose
which channels make up Diff Pair 1 and Diff Pair 2. A new Differential Channel dialog (e.g., C1-C2) is added to the
group. Use this dialog to control the vertical settings of the differential signal.
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Cn (Channel) Dialog
Full vertical setup is done on the individual Cn dialogs. To access them, choose Vertical > Channeln Setup from the
menu bar, or touch the Channel descriptor box.

If a Teledyne LeCroy probe is connected, its Probe dialog appears to the right of the Cn dialog. If the channel is part
of a differential pair, a Differential Channel dialog will appear following the combined channel dialogs.

Note: In case of a waveform processing error (e.g., overflow), a small letter "i" inside a bubble will appear on
the Cn descriptor box to indicate there is information regarding the waveform status. See Finding Waveform
Status for instructions on finding the error.

Vertical Settings
The Trace On checkbox turns on/off the channel trace.

Select the the input to which the signal on that channel is connected, ProBus (top row), ProLink/ProAxial (outside
four bottom row) or 1.85 mm (inside bottom row inputs, where available). The channel LED indicators on the body of
the oscilloscope show which input is set for each channel.

Note: For backward compatibility with remote control scripts, ProBus is Input C, ProLink/ProAxial is Input A,
and 1.85 mm is Input B. The Input buttons do not appear if the input is not supported, or will appear disabled
if the channel would be inactive when interleaved.

Vertical Scale sets the gain (sensitivity) in the selected Vertical units, Volts by default. Select Variable Gain for fine
adjustment or leave the checkbox clear for fixed 1, 2, 5, 10-step adjustments.

Offset adds a defined value of DC offset to the signal as acquired by the input channel. This may be helpful in order
to display a signal on the grid while maximizing the vertical height (gain) of the signal. A negative value of offset will
"subtract" a DC voltage value from the acquired signal (and move the trace down on the grid) whereas a positive
value will do the opposite. Touch Zero Offset to return to zero.

A variety of Bandwidth filters are available. To limit bandwidth, select a filter from this field.

Set Coupling appropriate to the input use:

l ProBus/ProBus2: DC 50 Ω, DC1M, AC1M or GND (Ground)
l ProLink: DC 50 Ω or GND
l ProAxial: DC 50 Ω or GND
l 1.85 mm: DC 50 Ω or GND

Caution: Maximum input voltage depends on the input used. Limits are displayed on the body of the
instrument. Whenever the voltage exceeds this limit, the coupling mode automatically switches to GND. You
must then manually reset the coupling to its previous state. While the unit provides this protection, damage
can still occur if extreme voltages are applied.
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Probe Attenuation
Probe Attenuation values for third-party probes may be entered manually on the Cn dialog. The instrument will
detect it is a third-party probe and display these fields.

When a Teledyne LeCroy probe is connected to a channel input, the Attenuation field becomes a button to access
the Probe dialog, a tab added to the right of the Cn tab. Enter Attenuation on the Probe dialog.

Rescale Settings
The rescale settings provide the same capability as the oscilloscope Rescale math function
(y=ax + b, where the original value is x, Units/V is a, and Add is b), only applied directly to the input trace rather than to
a separate math function trace. To rescale, enter the number of units equal to 1 Volt in Units/V and any additive
constant in Add.

The Vertical Units setting may be changed from Volts (V) to Amperes (A) or Others. This is useful when using a third-
party current probe (which is not auto-detected) or when probing across a current sensor/resistor. Units assigned
directly to an input will carry to other traces calculated using that input, such as math or spectrum traces. When
using a unit other than volts or amperes, first choose a unit subcategory from the pop-up dialog that appears, then
the unit.

Pre-Processing Settings
Pre-processing functions modify the acquired signal prior to display, math and measurement processing.

Average performs continuous averaging—the repeated addition, with unequal weight, of successive source
waveforms. It is particularly useful for reducing noise on signals drifting very slowly in time or amplitude. The most
recently acquired waveform has more weight than all the previously acquired ones: the continuous average is
dominated by the statistical fluctuations of the most recently acquired waveform. The weight of old waveforms in
the continuous average gradually tends to zero (following an exponential rule) at a rate that decreases as the weight
increases. Averaging is disabled on >500 Mpts acquisitions.

Interpolate applies (Sinx)/x interpolation to the waveform. The selection of None or Linear applies Linear
interpolation, which inserts a straight line between sample points and is best used to reconstruct straight-edged
signals such as square waves. (Sinx)/x interpolation, on the other hand, is suitable for reconstructing curved or
irregular wave shapes. Choose an upsample factor of 2 or more points. The Interpolation setting is disabled on >500
Mpts acquisitions.

Deskew adjusts the horizontal time offset by the amount entered in order to compensate for propagation delays
caused by different probes or cable lengths. The valid range is dependent on the current timebase setting. The
Deskew pre-processing setting and the Deskew math function perform the same action.

Noise Filter applies Enhanced Resolution (ERes) filtering to increase vertical resolution, allowing you to distinguish
closely spaced voltage levels. The tradeoff is reduced bandwidth. ERes functions similarly to smoothing the signal
with a simple, moving-average filter. It is best used on single-shot acquisitions, acqusitions where the data record is
slowly repetitive (and you cannot use averaging), or to reduce noise when your signal is noticeably noisy but you do
not need to perform noise measurements. It also may be used when performing high-precision voltage
measurements and zooming with high vertical gain, for example. ERes is disabled on >500 Mpts acquisitions.

Invert changes the apparent polarity of the signal, substituting an equivalent negative value for a positive one, and
vice versa, so that the waveform appears to be "flipped" on screen.

De-Embedding allows you to remove the effects of cables used to input signals. On WaveMaster 8000HD, select it to
de-embed using S-parameter models.
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Response Optimization
Frequency response and group delay contribute to the pulse response characteristics of the oscilloscope:

l Frequency response is the decrease in the magnitude response with respect to frequency. A fourth-order
Bessel roll-off slightly attenuates the frequencies near the bandwidth rating of the oscilloscope, while a brick-
wall frequency response passes slightly higher frequency content.

l Group delay is the rate of change of the total phase shift with respect to angular frequency through a device or
transmission medium. Amplifiers in analog oscilloscopes typically have some group delay at the highest
frequencies. This inherent group delay minimizes the preshoot present on a step response and provides the
traditional pulse response with no preshoot before the step. When zero group delay is provided at all
frequencies, preshoot and overshoot are equalized.

By slightly adjusting frequency and group delay using digital signal processing, the various Optimize settings
optimize the characteristic response of the oscilloscope for your specific application.

Eye Diagram is a flat group delay compensation resulting in equalized preshoot and overshoot.
This selection improves the symmetry of serial eye diagrams. In addition, a fourth-order Bessel
frequency response is implemented.

Flatness is a flat group delay compensation with a brick-wall frequency response. While this
provides the fastest rise time, there is also a slight penalty of more preshoot and overshoot
compared to Eye Diagram mode. This selection is most often used in narrow-band
RF measurements where it is desired to maintain constant magnitude response over the
oscilloscope passband.
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Differential Channel Dialog
When two single-ended inputs are combined into a differential pair using the Channel Setup dialog, a new Differential
Channel dialog is added to the group to enable you to control the differential signal trace.

Diff Trace On is checked by default, and the oscilloscope displays a new trace and descriptor box for
<Source 1> - <Source 2>.

You may optionally turn the CM Trace On. The common mode signal is now shown in trace
<Source 1> + <Source 2>.

The Source 1 and Source 2 channels that were combined into the differential pair are shown at the left of the dialog.
You can use these fields to change the channels that make up the differential pair.

Note: Differential traces are restricted to 50 Ω Coupling. The source channels are similarly restricted once
they are combined into a differential pair.

Aligning Traces
You can use the Align feature to quickly improve the differential signal. After pressing the button, the oscilloscope
calculates the skew that will minimize the common mode RMS. The amount of Skew added is shown on the dialog.

Note: The differential signal must be reasonably clean, with + and - signals at the same bit rate. If necessary,
first deskew the signals to within <1 bit period before using Align.

The Skew value is applied by default, but you can return the traces to the original position by clearing the Apply
checkbox. You can also manually enter a Skew value to further refine the original setting.

Differential and CM Descriptors
The same settings appear on the Differential and CM trace descriptor boxes as on the regular Channel descriptors,
except that instead of the Offset, the trace horizontal scale is shown.

Modifying Vertical Scale and Offset
The differential channel scale and offset controls affect both of its source channels' vertical settings, eliminating the
tiresome task of adjusting each source channel individually:

l Setting the Vertical Scale of the differential channel automatically sets each source channel to half of the
differential channel Vertical Scale.

l Setting the Offset of the differential channel automatically sets each source channel to that Offset value.

Individual source channel vertical settings may be individually fine-tuned on their own channel dialog. Any such
settings will be overridden if the differential channel settings are subsequently changed.
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De-embedding
The De-embedding feature, standard on WaveMaster 8000HD oscilloscopes, allows you to quickly remove the
effects of input cables by de-embedding S-parameter models of the cables' electrical characteristics. The
compensated signal is a more accurate representation of what was actually transmitted from the DUT.

When the De-embedding checkbox is selected from the channel pre-processing settings, the Cable De-Embedding
dialog will appear for you to describe the cable being used on the channel.

Bandwidth Limit
When de-embedding a cable, a bandwidth limit is required and must be set. The Bandwidth Limit control imposes a
reasonably sharp low pass filter in addition to the S-Parameter system response. This is useful when de-embedding
a lossy channel, to limit the amount of boost applied. When a channel is de-embedded, high frequency response
must be boosted to compensate for the high frequency attenuation in the channel. However, if the signal has been
attenuated into the noise floor, boosting the signal on the oscilloscope makes it impossible to distinguish between
the signal and the noise. The system boosts the noise along with the signal. The Bandwidth Limit setting can limit
the overall response to the lower frequencies where signal components are detectable above the noise. If this value
is set to zero (the default) then no bandwidth limit is applied.

Auto BW allows the software to determine the bandwidth limit, using a specified Max Boost, (electrical) Max Length
and filter Order. Max Boost has the same effect as Bandwidth Limit, but instead of setting the frequency, you set the
maximum boost allowed. The software looks at the S-Parameter responses and sets up the low-pass filter at the
frequency where one of the outputs has more boost than the specified Max Boost.

S-parameters and Port Assignment
Enter the full path to the S-Parameter Filename containing the cable characteristics. The default location is
oscilloscope D:De-embedding; it may be convenient to copy all your cable models there.

Assign to Port 1 and Port 2 a data column from the S-parameter file.

Apply
When you have completed the setup, touch Apply. Apply builds the system description for the circuit and compiles it.
The color indicator next to the Apply button shows the compilation status:

l Green if everything is properly set up.
l Yellow if the settings have changed and recompiling is needed.
l Red if something is wrong with either the S-Parameter file or port assignment.

View Response
Choose View Response to display the S-parameters as a Magnitude or Phase plot. Select the S-parameter you wish
to plot.
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Probe Dialog
The Probe Dialog immediately to the right of the Cn dialog displays the attributes of the probe connected to that
channel and (depending on the probe type) allows you to control the probe from the touch screen.

Caution: Remove probes from the circuit under test before initializing Auto Zero or DeGauss.

Depending on the type of probe you have connected to the channel, you may see any of the following controls:

Power On initiates power to active probes via the oscilloscope interface.

LED Active turns on AutoColor ID if the probe has this feature. The LED on the probe body will light in the color of the
channel to which the probe is connected.

Auto Zero corrects for DC offset drifts that naturally occur from thermal effects in the amplifier of active probes.
Teledyne LeCroy probes incorporate Auto Zero capability to remove the DC offset from the probe's amplifier output
to improve the measurement accuracy.

The Degauss control is activated for current probes. Degaussing eliminates residual magnetization from the probe
core caused by external magnetic fields or by excessive input. It is recommended to always Degauss probes prior to
taking a measurement.

If using a WaveLink probe, touch Tip Select and select the type of tip/lead you are using.

Note: Making the tip selection here results in the amplifier and tip combination having the response
calibrated for at the factory. Failure to do so may result in inaccurate measurements.

On oscilloscopes running MAUI version 8.5.1.1 or later, HVD3000 probes set attenuation relative to the
oscilloscope’s V/div setting and the Voltage Range selection:

l Auto automatically raises attenuation when V/div is >7.9 or lowers attenuation when V/div is <7.9, allowing you
to properly view the input waveform.

l Lock to High locks attenuation to the highest setting, regardless of the V/div setting. Maintaining a high
attenuation will allow small signals on larger voltage waveforms to be accurately measured.

Use the Refresh button to update the attributes display.
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Digital (Mixed-Signal)
When a mixed-signal device is connected to the oscilloscope, digital input setup options are added to the Vertical
menu. There are set up dialogs for digital groups Digital1 to Digital4, which correspond to possible digital buses. You:

l Choose which lines make up each digital group, what they are named and how they appear on the display

l Set the logic determination thresholds

A pattern trigger can be set on digital logic, or a combination of digital logic and analog states.

Connecting the Digital Leadset
The digital leadset enables input of up-to-16 lines of
digital data. Physical lines can be configured into
different logical groups, Digitaln, corresponding to a
bus. The transitions for each line may be viewed
through different display modes.

The digital leadset features two digital banks with
separate Threshold controls, making it possible to
simultaneously view data from different logic families.
Initially, logical lines are named and numbered the
same as the physical lead , although any line can be
renamed appropriately or re-assigned to any lead.

Each flying lead has a signal and a ground connection.
A variety of ground extenders and flying ground leads
are available for different probing needs.

Note: To achieve optimal signal integrity,
connect the ground at the tip of the flying lead for each input used in measurements. Use the provided
ground extenders or ground flying leads to ground the connection.

To connect the leadset to the instrument, push the connector
into the Mixed Signal interface below the front panel until you
hear a click. After connecting the device, go on to set up your
digital groups.

To remove the leadset, press and hold the buttons on each side
of the connector head, then pull out to release.
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Connecting the HDA125
The HDA125 High-speed Digital Analyzer is a complete system that adds digital acquisition and triggering
capabilities to Teledyne LeCroy Zi series oscilloscopes. With a sample rate of 12.5 GS/s on all 18 channels, the
HDA125 is optimized for acquiring high-speed digital signals. Accurate digital interpretation of high-frequency
analog signals is ensured by the high input sensitivity (150 mV minimum signal swing) and low-loading QuickLink
probing system.

See the HDA125 Operator's Manual for full instructions.

To connect the HDA125 to the oscilloscope:

1. Close the oscilloscope application (File > Exit), or shut down the oscilloscope (File > Shutdown).

2. Connect the digital leadset to the digital input on the front of the HDA125.

3. Connect the HDA125 to the oscilloscope:

l Connect the LBUS cable from the LBUS connector on the back of the HDA125 to the LBUS connector on
the oscilloscope. Be sure the head is turned so that the wedge fits into the groove at the top of the
connector. Fasten the thumb screws.

l Connect the USB3 cable into any USB ports on both instruments.

Note: The USB3 cable will work with USB2 ports, but the transfer speed will be reduced. We
recommend using the high-speed USB3 ports.

l Connect the power cable to DC IN and plug it into a grounded outlet.

4. Power up the HDA125.

5. Launch the oscilloscope application by double clicking the Start DSO icon on the instrument desk top, or
power up the oscilloscope if it was shut down (this will launch the application).

6. Solder the QI-SL tips to the test points on your DUT, then insert them into the color-coded ports on the digital
leadset.

Once the device is connected, digital acquisition features are added to the instrument's Vertical menu. Use the
Digitaln dialogs to specify the bus configuration and set the logic threshold using industry standard or custom levels.
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Digital Group Set Up
Digital Group set up is virtually the same whether using the MSO Digital Leadset or the HDA125 for input. The only
significant differences are the number of digital lines available and a Deskew feature on the HDA125.

A group represents all the lines that comprise a bus or that you wish to view relative to each other.

Digital Group dialog when using Digital Leadset (MSO).

Digital Group dialog when using HDA125.

To set up a digital group:

1. From the menu bar, choose Vertical > Digitaln Setup.

2. On the Digitaln set up dialog, check the boxes for all the lines that comprise the group. Touch the Right and
Left Arrow buttons to switch between lead banks as you make line selections.

Note: Groups can include lines from either lead bank.

3. Choose a Display Mode (see below). Use the controls at the right of the dialog to define the Group Height and
Vertical Position.

4. When you're finished defining the groups and display on the Digitaln dialog, open the Logic Setup dialog to
define logic thresholds.

5. Check the Group box to start the display.

Digital Display Set Up
When a digital group is enabled, the Display Mode setting determines how the data appears on the display.

Lines (default) shows a time-correlated trace indicating high, low, and transitioning points (relative to the Threshold)
for every digital line in the group.

Bus collapses the lines in a group into their Hex values.

Line & Bus displays both types of digital trace. The Bus trace appears immediately below the Line traces.
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Digital1 (magenta) shows four digital lines displayed with a Vertical Position +4.0 (top of grid) and a Group Height 4.0
divisions (half of grid). Digital4 (green) shows five digital lines and the bus trace displayed with the same Vertical

Position and Group Height, which compresses the entire display into the same area.

The size and placement of the traces depend on the Vertical Position and Group Height settings.

In Vertical Position, enter the number of divisions (positive or negative) relative to the zero line of the grid where the
display begins.The top of the first trace appears at this position.

In Group Height, enter the total number of grid divisions the entire display should occupy. All the selected traces
(Line and Bus) will appear in this space. Individual traces are resized to fit the total number of divisions available.

To close the display of digital traces, uncheck the Group box on the Digitaln dialog.

Tip: You may wish to enable groups with many lines one or two at a time to maximize the screen space
available for each. Closing the set up dialogs will also increase available screen space.

Deskew
When using the HDA125, the Deskew control allows you to add positive or negative delay time to shift the horizontal
position of the group on the screen.

Renaming Digital Lines
The labels used to name each line can be changed to make the user interface more intuitive.

Touch Label and select the type:

l Data (default) appends "D." to the front of each line number.

l Address appends "A." to the front of each line number.

l Custom lets you create your own labels line by line.

 To use Custom labels:

l Touch the Line number field below the corresponding checkbox. If necessary, use the Left/Right Arrow buttons
to switch between banks.

l Use the virtual keyboard to enter the name, then press OK.
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Renumbering Digital Lines
Labels can also be "swapped" between lines. This procedure helps in cases where the physical lead number is
different from the logical line number you would like to assign to that input. It can save time having to reattach leads
or reconfigure groups.

Example: A group is set up for lines 0-4, but lead 5 was accidentally attached to the probing point. By
"swapping" line 5 with line 4, you do not need to change either the physical or the logical setup.

1. Select a Label of Data or Address.

2. Touch the Line number field below the corresponding checkbox. If necessary, use the Left/Right Arrow
buttons to switch between banks.

3. From the pop-up, choose the line with which you want to swap labels.

Activity Indicators
Activity indicators appear at the bottom of the Digitaln dialogs. They show which lines are High (up arrow), Low
(down arrow), or Transitioning (up an down arrows) relative to the Logic Threshold value.

Shortcut Buttons
At the right side of the Digitaln dialogs are buttons to:

Create a new Zoom of a Digital group display. Each press of the button zooms each group displayed in order,
creating Z1 for Digital1, then Z4 for Digital4, etc. The zoom's horizontal and vertical scale can be changed from that
of the original digital group display to show transitions in more detail.

Open the Serial Decode dialogs to configure decoders. Digital lines can be selected for Data and/or Clock sources
when configuring decoders. Be sure the digital logic levels you set on Logic Setup are compatible with the decoding
levels.

Store the active digital group data to internal memory. As with Zoom, Digital1 will be stored to M1, Digital4 to M4,
etc., but the group must first be activated by selecting the setup tab or the descriptor box.

Move the active digital group to the Next Grid.
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Digital Logic Set Up
Digital logic determination is made according to the settings you make on the Logic Setup tab when defining digital
groups.

Digital Leadset (MSO)

For the low-speed digital leadset, logic determination level can be set per digital lead bank. You can use standard
Logic Family TTL, ETL, CMOS 5V, CMOS 3.3V, CMOS 2.5V, PECL 5V or LVDS.

Alternatively, by selecting Logic Family User Defined, you can define a custom logic Threshold voltage and
Hysteresis. Pulses that fail to cross the Hysteresis band will not be determined to be logical 1 or 0.

HDA125

For the high-speed HDA125, logic determination Threshold voltage and Hysteresis can be set line by line.

You can also set an individual Skew time on each line to deskew lines in the group, or Invert lines that have been
inadvertently connected with reversed polarity, instead of having to physically reconnect the lead.

Using the arrow buttons to move between lead banks, set logic for every line in the group.

If every line is to share the same logic determination values, you can just set up D0 then Copy D0 to all enabled.
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Digital Pattern Trigger
Pattern is the default trigger type selection when a digital input device is connected to the instrument. A Pattern
trigger can be set on a digital logic pattern, or a combination of digital logic and analog states.

Logic Bus Method
The Logic Bus method simplifies pattern set up by utilizing digital groups and logic you have already defined on the
Digital setup dialogs. Lines not included in the digital pattern are disabled (X = "Don't Care").

1. Select the Trigger descriptor and choose Trigger Type Pattern.

2. On the Digital Pattern dialog, select the Logic Bus button.

3. Enter the Source Digitaln group to use for the pattern. The dialog will show the high/low logic pattern already
set on that digital group and the hexadecimal Value it represents. The bottom of the dialog shows the entire
pattern across both lead banks.

Note: Digital lines inherit the Logic Setup made when defining the digital group. However, you can change
the logic threshold on the Levels dialog. The two settings are linked; they will always reflect whatever was
last selected on either dialog. MSO logic thresholds can only be set per lead bank, not individual line.

Logic Method
If you have not yet set up digital groups, you can set a logic pattern line by line using the Logic method. All available
lines remain active for selection.

1. Select the Trigger descriptor and choose Trigger Type Pattern.

2. On the Digital Pattern dialog, select the Logic button.

3. To apply a digital logic pattern, either:

l Enter the hexadecimal value of the pattern in Hex. Lines will take a logical 1, 0 or X ("Don't Care")
according to the pattern. Inactive lines will remain X.

l Touch the Dn button for each active line and select whether it must be High or Low compared to the
logic threshold. Depending on your selection, a logical 1 (High) or 0 (Low) now appears on the dialog.
Leave X selected for any line you wish to exclude from the pattern. Use the Left and Right Arrow buttons
to display lines in other digital banks.
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Note: As an alternative, you may set edge conditions on any line. Touch the Dn button and choose
the edge. Edge conditions always assume a logical OR in the overall trigger criteria.

Tip: As you work, the checkboxes along the bottom of the dialog will change to show the full pattern.

4. Open the Levels dialog and either:

l Select a Logic Family for each digital bank (if using Digital Leadset) or digital line (if using HDA125)

l Choose Logic Family User Defined, then enter a custom Threshold voltage and Hysteresis

Adding an Analog Pattern
A pattern of high/low states on analog channels, including the EXT input, can be added to a digital pattern trigger.
The analog pattern forms an additional trigger condition that must be met coincident with the digital pattern.

Note: Only the AND operator is available when combining analog and digital patterns. All the states in the
analog pattern must occur simultaneously.

1. Touch the Left Arrow button until the C1-EXT group of inputs is displayed in the main section of the dialog.

2. Touch the Cn button for each input to be included in the pattern, and select whether it must be High or Low
compared to the threshold Level you will set.
Depending on your selection, a logical 1 (High) or 0 (Low) now appears on the dialog. Leave Don't Care ("X")
selected for any input you wish to exclude.

3. Open the Levels dialog and enter the voltage threshold for each analog channel included in the trigger.

4. If you've included an EXT input in the analog pattern, open the Ext dialog and enter the Attenuation to use on
the EXT input.

5. The Go to Digital Logic Setup button will return you to the Logic Setup dialog for setting digital thresholds.

Glitch Filter
Filter Out Unstable Conditions ignores short glitches that last less than 3.5 ns in logic state triggers . It is selected by
default, you can optionally deselect it to turn off the filter.
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Timebase
Timebase (Horizontal) settings control traces along the X axis. The timebase is shared by all channels.

The time represented by each horizontal division of the grid, or Time/Division, is most easily adjusted using the front
panel Horizontal knob. Full Timebase set up is done on the Timebase dialog, accessed either by choosing Timebase
> Horizontal Setup from the menu bar or by touching the Timebase descriptor box.

Controls specifically used for interleaving are located at the far right of the main Timebase dialog. They allow you to
increase the sampling rate, memory, and bandwidth of a single input by implementing Digital Bandwidth Interleave
(DBI).

Timebase Set Up
Use the Timebase dialog to select the Sampling Mode, Memory /Sample Rate and number of Active Channels. You
can also use it instead of the Front Panel to modify the Time/Div and horizontal Delay.

Sampling Mode
The Sampling Mode determines how the instrument samples the input signal and renders it for display. See
Sampling Modes for a description of each type.

Note: Modes not available when using any type of digital interleaving, such as DBI, will apear disabled.

Timebase Mode
Time/Division is the time represented by one horizontal division of the grid. Touch the Up/Down Arrow buttons on
the Timebase dialog or turn the front panel Horizontal knob to adjust this value. The overall length of the acquisition
record is equal to 10 times the Time/Division setting.

Delay is the amount of time relative to the trigger event to display on the grid. Raising/lowering the Delay value has
the effect of shifting the trace to the right/left. This allows you to isolate and display a time/event of interest that
occurs before or after the trigger event.

l Pre-trigger Delay, entered as a positive value, displays the acquisition time prior to the trigger event, which
occurs at time 0 when in Real Time sampling mode. Pre-trigger Delay can be set up to the instrument's
maximum sample record length; how much actual time this represents depends on the timebase. At maximum
pre-trigger Delay, the trigger point is off the grid (indicated by the arrow at the lower right corner), and
everything you see represents 10 divisions of pre-trigger time.

l Post-trigger Delay, entered as a negative value, displays time following the trigger event. Post-trigger Delay can
cover a much greater lapse of acquisition time than pre-trigger Delay, up to the equivalent of 10,000 divisions
after the trigger event (it is limited at slower time/div settings and in Roll mode). At maximum post-trigger
Delay, the trigger point is off the grid far left of the time displayed.

Set to Zero returns Delay to zero.
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Sampling Rate
These controls specify how the instrument samples when in Real Time mode.

Set Maximum Memory sets the oscilloscope to take the maximum number of samples possible given the amount of
pre- or post-trigger Delay and the Time/div, up to the maximum record length. This optimizes the sample rate for fast
timebases when in Real Time mode.

In this mode, Maximum Sample Points shows the maximum number of samples taken per acquisition. The actual
number of samples acquired can be lower due to the other timebase settings.

Fixed Sampling Rate allows you to set a fixed rate of sampling, in which case the length of acquisition depends on
the Time/div. The oscilloscope will use whatever memory is required for the acquisition time, until none remains.
Lowering the rate can extend the acquisition to accommodate slower timebases or longer delays.

In this mode, Maximum Sample Points changes to Sampling Rate for you to enter the desired rate.

Note: To avoid aliasing and other waveform distortions, it is advisable (per Nyquist) to acquire at a sample
rate at least twice the bandwidth of the input signal. Those with higher speed acquisition systems may need
to manually adjust Bandwidth, Time/div, Sample Rate, and the number of Active Channels to achieve the
optimal result.

Navigation Reference
The Navigation Reference setting controls how the oscilloscope behaves when you adjust trace Horizontal Scale
(Time/div) using the setup dialogs, front panel knob, or Pinch Zoom gesture:

Centered (50%) scales divisions equally so that whatever is at the center (50%) grid line remains at the center of the
display. Other events move in reference to the center as Time/div changes. With this setting, the trigger point could
potentially move off the grid as the scale changes.

Lock to Trigger scales divisions around the trigger point. The trigger event remains in place as Time/div changes,
while other events move in reference to the trigger. If the trigger is currently placed at time zero, this will appear to
behave the same as Centered, but the difference will be apparent if you have used Delay to shift the trigger position.

See Navigating Long Acquisitions.

Interleaving
Digital Bandwidth Interleaving combines the digital capabilities of channels to increase bandwidth, memory and
sample rate. See Using DBI.
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Sampling Modes
The Sampling Mode determines how the instrument samples the input signal and renders it for display.

Real Time Sampling Mode
Real Time sampling mode is a series of digitized voltage values sampled on the input signal at a uniform rate. These
samples are displayed as a series of measured data values associated with a single trigger event. By default (with no
Delay), the waveform is positioned so that the trigger event is time 0 on the grid. The relationship between sample
rate, memory, and time can be expressed as:

Capture Interval = 1/(Sample Rate XMemory)
Capture Interval/10 = Time Per Division

Usually, on fast timebase settings, the maximum sample rate is used when in Real Time mode. For slower timebase
settings, the sample rate is decreased so that the maximum number of data samples is maintained over time.

Sequence Sampling Mode
In Sequence Mode sampling, the completed acquisition consists of a number of fixed-size segments each
containing the trigger event. The instrument calculates the capture duration and number of sample points in each
segment from the user-defined number of segments and total available memory. Acquired segments can be
arranged adjacent to one another, forming the waveform display of a typical acquisition, or in other types of
sequence displays to facilitate comparison of the segments.

Sequence Mode is ideal for capturing specific events that may be separated by long time intervals. The instrument
can acquire over long periods waiting for the trigger event, recording only the desired segments while ignoring the
uninteresting periods between events. Measurements can be made on selected segments or on the entire
acquisition sequence.

Note: You cannot operate some Serial Decoders on Sequence Mode acquisitions.
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Sequence Mode Set Up
The Sequence dialog appears behind the Timebase dialog only when Sequence Mode sampling is selected. Use it to
define the number of fixed-size segments to be acquired.

1. From the menu bar, choose Timebase > Horizontal Setup..., then Sequence Sampling Mode.

2. On the Sequence tab under Acquisition Settings, enter the Number of Segments to acquire.

3. To stop acquisition in case no valid trigger event occurs within a certain timeframe, check the Enable Timeout
box and provide a Timeout value.

Note: While optional, Timeout ensures that the acquisition completes in a reasonable amount of time
and control is returned to the operator/controller without having to manually stop the acquisition,
making it especially useful for remote control applications.

4. Touch Display mode and select a sequence display mode from the pop-up menu:

Adjacent

Waterfall (cascaded)

Mosaic (tiled)

Overlay

Perspective

5. To see the trigger times of those segments acquired, stop acquisition and touch Show Sequence Trigger
Times. This will launch the Trigger Time tab of the Acquisition Status dialogs.

When in Sequence sampling mode, you can view individual segments easily using the front panel Zoom button. A
new zoom of the channel trace defaults to Segment 1.

You can view other segments by changing the First and total Num(ber) of segments to be shown on the Zn dialog.
Touch the Zn descriptor box to display the dialog.
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Tip: By setting Num to 1, you can use the front panel Fine Adjust knob to scroll through each segment in
order.

Channel descriptor boxes indicate the total number of segments acquired in sequence mode. Zoom descriptor
boxes show the first segment displayed and total number of segments displayed ([#] #). As with all other zoom
traces, the zoomed segments are highlighted on the source trace.

Example: You have acquired 10 segments of two channels. You choose to display only segment 1. The Cn
descriptor box reads 10 Seg(ments). The Zn descriptor box reads [1]1 Seg, meaning you are displaying a total
of one segment starting with segment 1.

Using DBI
Digital Bandwidth Interleave (DBI), used on >33 GHz oscilloscope models, is a method for combining the digital
capabilities of channels to increase bandwidth, sample rate and memory length, just as oscilloscope manufacturers
have for years interleaved channels to increase sample rate and memory.

The physical input used for the interleaved channel "B" will be different than during lower-bandwidth operation. See
the table below.

Note: The oscilloscope will tell you what channel to use for high-speed serial triggers when the oscilloscope
is operating in DBI mode.

DBI Acquisition Settings

Vertical
Channels are interleaved by selecting the 1.85 mm setting on the channel dialogs. Switching to any other input
setting on any of the interleaved channels will revert the Timebase to the standard (non-DBI) acquisition settings.
Use only "B" channels for acquisition until you disable DBI by returning all channels to the default bandwidth on the
Timebase dialog or the channel fly out menu.

The Vertical Scale (V/div) value is automatically set to 50 mV/div. If you change this to a different value after
deactivating DBI, the system resumes the last "B" channel Scale V/div value when DBI is reactivated.

The high bandwidth of DBI channels requires 50 Ω Coupling.

Timebase
The Timebase is automatically set to a fixed sample rate. Memory length is adjusted accordingly, depending on your
Time/div setting. The changes appear on the Timebase descriptor box.
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Setting Up DBI from the TimeBase Dialog

1. Choose TimeBase > Horizontal Setup... to access the Timebase dialog.

2. The DBI buttons represent the possible configuration of active channels and the bandwidths they would yield
with DBI enabled. Touch the buttons corresponding to the channels/bandwidth you want.

Setting Up DBI from the Channel Fly Out Menu
On SDA/WaveMaster 8000HDs, you can also use the channel fly out menu to set up DBI.

Swipe up from the bottom of the screen to display the menu, then simply touch the boxes representing the desired
combination of active channels and bandwidth-coupling for each input row.

For DBI, choose the 1.85 mm inputs for channels 2B and/or 3B.

DBI Combinations
DBI combines the leftmost pair (e.g., C1 and C2) and the rightmost pair (e.g., C3 and C4) to result in two, higher
bandwidth channels.

Enhanced Sample Rate
On instruments with Enhanced Sample Rate (ESR), Sinx/x interpolation is applied globally to all channels in order to
improve measurement accuracy over a wide range of timebases.

On WaveMaster 8000HD and WaveRunner 8000HD oscilloscopes, the maximum ESR upsampling factor is 2x.

In "Set Maximum Memory" mode, ESR will be enabled whenever the timebase settings dictate that the required
acquisition length is less than or equal to the maximum memory value selected. The ESR factor is automatically
adjusted to yield the best possible sample rate. In "Fixed Sample Rate" mode, the ESR rate will correspond to the
maximum selectable sample rate.

Interpolation per channel can be added or set to Linear (None) on the Channel (Cn) setup dialog.

When ESR is in use, the code E/ESR will appear on the descriptor boxes of the active channels.
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Clock Source Settings
By default, the instrument uses its internal 10 MHz clock to synchronize the timebase across channels and control
the timing of the digitizers. In some cases, an external clock can be input to control these functions.

Note: External clocks can only be used in real-time sampling mode.

An external reference clock (input via REF In) can be used to synchronize the instrument's internal timebase with an
external frequency source so that multiple instruments can lock timebases to a common source.

To use an external reference clock:

1. Connect a clock source to the reference clock input using a BNC cable.

2. Go to Timebase > Horizontal Setup and choose Real-Time Sampling Mode.

3. On the Clock Source tab under Reference Clock choose External.

Navigating Long Acquisitions
On acquisitions >500 Mpts in length, measurements and math calculations take place on only the center 500 Mpts
of the acquisition—the "Analysis Zone". This area is marked on the source channel trace by grey shading applied
outside of it (over the part not analyzed). You may need to reposition the trace so that the portion you wish to
analyze falls within the Analysis Zone. Also, you may wish to shorten the time it takes to complete a complex
analysis by analyzing only the most significant part of the acquisition. This can be easily done using Timebase
controls and/or Zoom.

Navigating with Horizontal Delay
Stop acquisition, then turn the Horizontal Delay knob until the part of the trace you wish to analyze is within the
Analysis Zone.

Tip: Panning/swiping is an excellent way to add Delay and place the trace within the Analysis Zone.

Note: Your next acquisition will reflect any change to your Timebase settings. If you wish to preserve your
initial acquisition settings, save the setup to internal memory before navigating, then recall it before you
resume acquisition.
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Shading over source trace (left) shows edges of Analysis Zone on long acquisition. Truncated math trace reveals
extent of Analysis Zone. After adding Delay (right), Math trace shows shift in analysis zone.

Navigating with Zoom
Stop acquisition, then create a zoom trace of the area you wish to analyze. Apply math and measurements to the
zoom rather than the channel trace.

Math applied to a zoom is calculated on the entire trace (up to 500 Mpts). Highlighting on the source trace shows the
area analyzed.
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Navigation Reference
Changing the Navigation Reference setting can also help to reposition the trace for analysis by selecting for different
regions of the acquisition to remain centered as the Time/div changes:.

Centered (50%) scales divisions equally so that whatever is at the center (50%) line remains at the center of the
display. Other events move in reference to the center as Time/div changes. With this setting, the trigger point could
potentially move off the grid as the scale changes.

Timebase at 2 ms/div with -6.5 ms Delay shifting the trigger left of the center of the gird.

Timebase changed to 1 ms/div with Navigation Reference set to Centered (50%). Note how with this setting, the trigger
event has shifted off the grid to the left as time "expands", but the center of trace remains in the same place.

Lock to Trigger rescales divisions around the trigger point. The trigger remains in place as Time/div changes, while
other events move in reference to the trigger. If the trigger is currently at time zero, this appears to behave the same
as Centered, but the difference will be apparent if you have used Delay to shift the trigger position.

Timebase changed to 1 ms/div, the trigger remains at the same position, but the rest of the trace shifts right as time
"expands." The value of each horizontal division is different than when centered, although Time/div is still 1 ms/div.
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History Mode
History Mode allows you to review any acquisition saved in the history buffer, which automatically stores all
acquisition records until full. Not only can individual acquisitions be restored to the grid, you can "scroll" backward
and forward through the history at varying speeds to capture changes in the waveforms over time. To access this
feature, choose Timebase > History Mode, then select View History to enable the display.

Each record is indexed and time-stamped, and you can choose to view the absolute time of acquisition or the time
relative to when you entered History Mode. In the latter case, the last acquisition is time zero, and all others are
stamped with a negative time. The maximum number of records stored depends on your acquisition settings and
the total available memory.

Entering History Mode automatically stops new acquisitions. To leave History Mode, restart acquisition by pressing
one of the front panel Trigger Mode buttons.

Note: History Mode does not work with Sequence Mode acquisitions, or ERES on the input channel.

Oscilloscope in History mode.

Replay Acquisition History
Watching a "movie" of the history allows you to see waveform changes that are invisible during real-time acquisition.
Use the buttons to navigate the history.

l Top row buttons scroll: Fast Backward, Slow Backward, Slow Forward, Fast Forward.

l Bottom row buttons step: Back to Start, Back One, Go to Index (row #), Forward One, Forward to End.

Press Pause when you see something of interest, then use the History table to find the exact Index.

Select Single Acquisition
Select View Table to show the index of records. Select the row from the table or enter its Index number on the dialog.
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Trigger
Triggers define the event around which digitized information is displayed on the grid.

Different Trigger Types are used to select different events in the trigger source waveforms: edge voltages, pulse
widths, high/low states, etc. These may be a single channel event or a complex pattern of events across several
channels. On instruments with Mixed Signal capabilities, pattern triggers can be set on analog channels (including
the External Trigger input), digital lines or a mix of both.

In addition to the type, the Trigger Mode determines how the instrument behaves as it encounters trigger events:
take a single acquisition and stop, holding on to the display of the last acquisition, or continuously take and display
acquisitions.

In both cases, when the previous acquisition has completed processing, the oscilloscope is again ready to acquire
and the READY indicator is lit. If, while READY, the trigger circuit detects a signal that matches the trigger conditions,
the oscilloscope triggers on the next matching event, and the TRIG'D indicator is lit.

Unless modified by a pre- or post-trigger Delay, the trigger event appears at time 0 at the horizontal center of the grid,
and a period of time equal to five divisions of the timebase is shown to the left and right of it. Delay shifts the
acquisition "window" on screen, displaying a different portion of the waveform.

An additional condition of Holdoff by time or events is available for Edge and Pattern triggers, including those that
appear within Qualified triggers. Holdoff arms the trigger on the first matching event, inserts the holdoff count, then
triggers on a subsequent event. Often, especially with repetitive signals, the initial arming event appears to the left of
the trigger in "negative" acquisition time.

Trigger Modes
The Trigger Mode determines how often the instrument acquires. It is equivalent to how analog oscilloscopes
"sweep," or refresh, the display. Trigger Mode can be set from the Trigger menu or from the front panel Trigger
control group.

In Single mode, when you choose Trigger > Single or press the front panel Single button, the oscilloscope readies,
arms, and triggers provided all trigger conditions (including Holdoff) are met. It then stops and continues to display
the last acquisition until a new one is taken. The oscilloscope remains armed unless manually stopped or triggered,
and if a valid trigger does not occur, invoking Single a second time will force a trigger and display the acquisition.

In Normal mode, operation is the same as in Single, except that the trigger automatically re-arms after the previous
acquisition is complete, and data is continuously refreshed on the touch screen.

Auto operates the same as Normal mode, except that a trigger is forced if the trigger event has not occurred within a
preset timeout period.

Stop ceases acquisition processing until you select one of the other three modes. The arming and Holdoff counters
are cleared, even if there has not yet been a trigger since the previous acquisition.
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Trigger Types
The Trigger Type sets the triggering conditions.

Edge triggers upon a achieving a certain voltage level in the positive or negative slope of the waveform.

Width triggers upon finding a positive- or negative-going pulse width when measured at the specified voltage level.

Pattern triggers upon a user-defined pattern of high and low voltage levels on selected inputs. On oscilloscopes with
mixed-signal capability, it may be a digital logic pattern or a combined digital-analog pattern. If your oscilloscope
does not have mixed-signal capability, the pattern can be set using analog channels alone.

Measurement is not technically a trigger, per se, but permits the instrument to stop and display acquisition based on
a post-processing measurement result, similar to a trigger.

Serial triggers on the occurrence of user-defined serial data events. This type will only appear if you have installed
protocol-specific serial trigger and decode options. Go to teledynelecroy.com/serialdata to download manuals.

MultiStage Types
MultiStage triggers set one event that "qualifies" or arms, and another that triggers. First select MultiStage to show
all the triggers in the group.

QualFirst is only enabled when using Sequence sampling mode. It arms the oscilloscope when the A event occurs in
the first segment, then triggers on all subsequent B events, saving each as a Sequence Mode segment.

Qualified arms on the A event, then triggers on the B event. In Normal trigger mode, it automatically resets after the B
event, and re-arms upon the next matching A event.

Smart Triggers
Smart triggers allow you to apply Boolean logic conditions to the basic signal characteristics of level, slope, and
polarity to determine when to trigger. First select Smart to show all the triggers in the group.

Glitch triggers upon finding a pulse-width that is less than a specified time or within a specified time range.

Window triggers when a signal exits a window defined by voltage thresholds.

Interval triggers upon finding a specific time between two consecutive edges of the same polarity. Use it to capture
intervals that fall short of, or exceed, a specified range.

Dropout triggers when a signal loss is detected. The trigger is generated at the end of the timeout period following
the last trigger source transition. It is used primarily in Single acquisitions with pre-trigger Delay.

Runt triggers when a pulse crosses a first threshold, but fails to cross a second threshold before re-crossing the first.
Other defining conditions for this trigger are the edge (triggers on the slope opposite to that selected) and runt width.

Slew Rate triggers when the rising or falling edge of a pulse crosses an upper and a lower level. The pulse edge must
cross the thresholds faster or slower than a selected period of time.

Other Triggers
What are commonly known as External, Line and Fast Edge triggers are not trigger types, per se, but alternative
sources that may be used with several types of triggers, most usually Edge triggers that fire upon the occurrence of
a particular edge and level of the trigger input.

"External triggers" (Ext source) look for the selected slope and level in an externally generated pulse that is input to
the oscilloscope's Ext. In port. In Pattern triggers, the Ext. In port may be examined for a High/Low state as part of
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the overall triggering pattern. Select the Coupling to use for the Ext. In port when defining the pattern.

"Line triggers" (Line source) are Edge triggers that look for the 50% level of the selected slope on the AC power line
connected to the oscilloscope.

"Fast Edge triggers" are Edge triggers that look for the 50% level of the selected slope on the oscilloscope's internally
generated Fast Edge square wave signal. Note that when using this signal to trigger, there is no need to connect
from the oscilloscope's Fast Edge terminal, just select it as the Source during set up.

Trigger Set Up
To open the Trigger dialog, press the front panel Trigger Setup button or touch the Trigger descriptor box.

Different controls will appear depending on the Trigger Type selected (e.g., Slope for Edge triggers). Complete the
settings shown after making your selection.

The trigger condition is summarized in a preview window at the far right of the Trigger dialog. Refer to this to confirm
your selections are producing the trigger you want.

Source
For most triggers, the Source is the analog channel or digital line to inspect for the trigger conditions. Depending on
the type of trigger, in addition to input channels C1-Cn or digital lines D0-Dn, the trigger source may be:

l A pulse from an external instrument connected to the Ext In. input (i.e., external trigger)

l The Line frequency of the oscilloscope power input (i.e., line trigger)

l The oscilloscope generated Fast Edge signal (i.e., fast edge trigger)

Note: There is no need to connect the Fast Edge signal to an input when using it to trigger, only when using
it as a reference channel to deskew probes.

Pattern triggers may utilize multiple sources (such as a mix of analog and digital signals), and likewise MultiStage
triggers may use different sources for the arming and triggering events.

Tip: On instruments with OneTouch, the trigger source can be easily set by dragging the desired channel
descriptor box onto the Trigger descriptor box. Note that the trigger coupling and slope/polarity will revert to
whatever was last set on that channel.

Coupling
For analog triggers, specify the type of signal Coupling at the input:

l DC - Frequency components are coupled to the trigger circuit for high frequency bursts, or where the use of AC
coupling would shift the effective trigger level.

l AC - Capacitively coupled. DC levels are rejected, and frequencies below 50 Hz are attenuated.
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l LFREJ - Coupled through a capacitive high-pass filter network, DC is rejected and signal frequencies below 50
kHz are attenuated. For stable triggering on medium to high frequency signals.

l HFREJ - DC coupled to the trigger circuit, and a low-pass filter network attenuates frequencies above 50 kHz
(used for triggering on low frequencies).

Slope/Polarity
For some triggers, such as Edge, you will be asked to select the waveform Slope (e.g., rising vs. falling) on which the
triggering event occurs. For others, such as Width, the equivalent selection will be Polarity (e.g., positive vs.
negative).

Level
For analog triggers, enter the voltage Level at which the triggering condition must occur. Use the Find Level button to
set the level to the signal mean.

Trigger types that require multiple crossings to define the triggering condition—such as Window, SlewRate and
Runt— will have Upper Level and Lower Level fields.

For digital pattern triggers, the level is determined by the Logic Family that is set on the digital group. This can also
be specified by a custom (User-Defined) crossing Threshold and Hysteresis. Usually, there will be a separate Logic
tab for these settings.

Hysteresis
For Edge triggers, you may select to Optimize for HF. When this box is left unchecked, the trigger circuit's hysteresis
is set quite high to eliminate any potential trigger instability from high-frequency noise riding on a low-frequency
input signal. Because HF signal amplitudes tend to be smaller, the Optimize for HF setting reduces the hysteresis
value to make the trigger more sensitive. The effect this will have on trigger behavior depends on the signal's
spectral and noise content rather than just fundamental frequency, so it's overall effect is difficult to quantify.

Conditions (Smart Triggers)
Smart triggers all allow you to apply Boolean logic to extend the possible triggering conditions beyond an absolute
Level and Slope/Polarity.

Triggering events can be Less Than, Less Than or Equal To, Greater Than, etc. an Upper Value and/or Lower Value.

In some cases, it is possible to set a discrete range of values that satisfy the condition. Depending on the trigger, the
triggering values may be any that are In Range bounded by the upper/lower values, or any that are Out Range of the
upper/lower bounds.

The extent of the range can often also be specified by using a Nominal and Delta value, rather than an absolute
upper and lower value. In this case, the Nominal value sets the center of the range, and the Delta determines how
many units plus/minus the Nominal value are included in the range.

For Dropout triggers, the default is to Ignore Opposite Edge, setting the trigger to fire on a dropout of the Positive or
Negative edge within the given timeframe. Deselecting it has the effect of setting the trigger on Both edges, which
will fire when dropout occurs on either edge.
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Patterns
A triggering logic pattern may be set on digital lines, analog channels, or a combination of both. See Digital Pattern
Trigger for digital/mixed-signal trigger setup instructions.

To trigger on a pattern of analog channel High/Low states:

1. On the Trigger dialog, select the Pattern trigger type.

2. Select the Boolean Operator that describes the relationship among analog inputs (e.g., C1 must be High AND
C2 must be Low).

3. For each input in the trigger pattern, select what State it must be in compared to the threshold Level. Leave
"Don't Care" for any input you wish to exclude.

4. For each input included in the trigger, enter the voltage threshold Level.

5. If you've included the EXT(ernal) input in the pattern, open the Ext tab and enter the input Attenuation.

Measurement Trigger
Measurement is not technically a trigger, but permits the instrument to stop and display acquisition based on a post-
processing measurement result, similar to a trigger. The available measurements will each offer a different method
for specifying the "trigger" conditions, based on the type of measurement. Generally, you will be able to specify a
triggering value or range of values, and for @level parameters, the voltage level at which the measurement is taken.

Serial Trigger
The Serial trigger type will appear if you have installed serial data trigger and decode options. Select the Serial type
then the desired Protocol to open the serial trigger setup dialogs. For setup instructions, see the software instruction
manual at teledynelecroy.com/support/techlib under Manuals > Software Options.

Note: Certain software serial triggers can only be input on certain channels; the set up dialog will instruct
you which channel to use. Information on the operation of hardware serial pattern triggers can be obtained
from the High Speed Serial Triggers Instruction Manual.
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Qualified Trigger
A Qualified trigger arms on the A event, then triggers on the B event. In Normal trigger mode, it automatically resets
after the B event, and re-arms upon the next matching A event. Unlike a basic Edge or Pattern trigger with Holdoff,
the A and B events can occur in different signals, allowing you to use the state of one signal to "qualify" the trigger on
another.

On the Trigger dialog, select MultiStage trigger type and choose Qualified.

On the Qualified dialog, choose the A and B events.

Besides an Edge or Pattern, two special conditions may be selected as the arming event (A):

l State, an analog or digital High/Low state ocurring on a single input.

l PatState, a pattern of analog or digital High/Low states across multiple inputs.

When B is an Edge or Pattern, use the When B Occurs buttons to add a time window to the conditions:

l Any Time triggers if B occurs any time after being qualified by A.

l Less Than triggers only if B occurs before the time limit once qualified by A.

l Greater Than triggers only if B occurs after the time limit once qualified by A.

l Events triggers on the next B event after the specified N Events once qualified by A.

As with regular Holdoff, the counter may begin from the Acquisition Start or the Last Trigger Time.

Once you've selected the A and B events on the Qualified dialog, set up the conditions on the respective "Event"
dialogs exactly as you would a single-stage trigger.

QualFirst Trigger
The QualFirst trigger, which is only used in Sequence sampling mode, is set up exactly like the Qualified trigger.
QualFirst arms the oscilloscope when the A event occurs in the first segment, then triggers on all subsequent B
events, saving each as a Sequence Mode segment.
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Trigger Holdoff
Holdoff is either a period of time or an event count that may be set as an additional condition for Edge and Pattern
triggers. Holdoff disables the trigger temporarily, even if the other conditions are met. Use Holdoff to obtain a stable
trigger for repetitive, composite waveforms. For example, if the number or duration of sub-signals is known, you can
disable them by setting an appropriate Holdoff value.

Note: Qualified triggers operate using time or event conditions similar to Holdoff, but arm and trigger
differently.

Hold Off by Time
This is a period of time to wait after the arming event before triggering on the next event. The maximum allowed
time is 20 seconds; Holdoff time is otherwise limited only by the input signal frequency, coupling, and the
instrument's bandwidth.

When a Holdoff by time is counted from the start of the acquisition, the oscilloscope readies, arms on the first event,
holds for the specified time, then triggers on the next event. After one full acquisition has completed, the
oscilloscope again readies, arms, holds, and triggers for the following acquisition.

Positive Edge trigger with Holdoff by time counted from the start of acquisition.

When a Holdoff by time is counted from the last trigger time, the oscilloscope immediately re-arms on the first event
following the trigger and begins counting the Holdoff, rather than wait to complete the full acquisition. The Holdoff
count continues even during the very brief time between acquisitions while the oscilloscope is processing. As soon
as the Holdoff is satisfied and the oscilloscope is again ready, it triggers on the next event. The re-arming and
Holdoff may occur in one acquisition, and the trigger in the next.

Positive Edge trigger with Holdoff by time counted from the last trigger time.

Note: Because there is only one trigger per acquisition, the trigger event will always belongs to the new
acquisition. The processing time shown here is for purposes of illustration only.
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Regardless of where in the acquisition record the trigger event was found (first edge or last), the display will show
time pre- and post-trigger based on your Time/Div and Delay settings.

Hold Off by Events
Events refers to the number of times the trigger conditions have been met following the arming event.

For example, if the Holdoff is two edges counted from the start of the acquisition, the oscilloscope readies, arms on
the first edge, holds off for the next two, triggers on the fourth edge, then completes the acquisition. Because there
must always be a first arming edge, it appears to be "Holdoff plus one."

Positive Edge trigger with Holdoff by events counted from start of acquisition.

As with Holdoff by time, when a Holdoff by events is counted from the last trigger time, the oscilloscope re-arms
immediately following the trigger and begins the Holdoff count. If the count is satisfied by the time the oscilloscope
is again ready, the trigger occurs on the next event at the start of the new acquisition.

Positive Edge trigger with Holdoff by events counted from last trigger time.

Holdoff Set Up
To add Holdoff to an Edge or Pattern trigger, touch the Trigger descriptor box or press the front panel Trigger Setup
button, then open the Holdoff tab.

Choose to Holdoff by Time (clock) or Events, then enter the Time (S) or number of Events to wait before triggering.

Choose to Start Holdoff Counter On either the current Acquisition Start time or the Last Trigger Time (time of trigger
from previous acquisition).
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Software Assisted Trigger
Software Assisted Trigger is used to find the trigger-level crossing point closest to the hardware trigger point. It then
adjusts the time offset of the waveform so that it is aligned with the specified trigger level and slope.

In the following figure, the white trace is the waveform at the input to software-assisted trigger processing. The red
trace shows it after processing, aligned with the trigger point indicated by the red marker below the grid.

Note: This feature can only be used with an Edge trigger type in Normal trigger mode.

1. From the menu, choose Triggers > Trigger Setup, then touch the Software Assisted Trigger tab.

2. Touch Enable.

3. Create a trigger window by entering a Hysteresis value. This value sets a boundary above and below the main
trigger level to exclude noise.

4. Choose Auto or Normal mode; this determines the trigger behavior when trigger crossings are not found in
the trigger source waveform.

l Auto mode allows all waveforms through the channel.

l Normal mode allows waveforms only with a trigger crossing within the horizontal gate region through
the channel.

5. Set Start and Stop time values on the Horizontal Gate part of the Software Assisted Trigger tab. These values
control where in the waveform the software-assisted trigger processing searches for trigger crossings.
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TriggerScan
TriggerScan is a debugging tool that helps you quickly discover waveform anomalies by automating the process of
building triggers designed to find rare events in an acquisition.

Triggerscan trains the system by looking at acquired waveforms. During the training, TriggerScan analyzes the
waveforms to determine what waveforms normally look like. Using this information, it generates a list of smart
triggers designed to isolate abnormal situations. All acquisition settings are preserved in the TriggerScan setup file
for future use.

After loading the trigger setups from the Trainer, TriggerScan scans new acquisitions for rare events by cycling the
different triggers. As triggers occur, the waveforms are displayed on the screen. AutoSaving waveform files with
each trigger allows you to capture the TriggerScan data.

Training TriggerScan
The TriggerScan Trainer inspects the current acquisition and automatically builds a list of trigger setups that could
potentially be used to find events of interest.

Note: Run the Trainer if you want to change the trigger types or if you change the channel or signal. You
must acquire and display at least 3 cycles of a signal before running the Trainer.

1. Touch Trigger > Trigger Setup... from the menu bar, then open the TriggerScan tab.

2. Touch the Trainer button.

3. On the TriggerScan Trainer pop-up, choose the Source channel on which to train and trigger, and select all the
trigger types you want to set up.

4. Touch the Start Training button. When training is complete, a list of smart trigger setups is displayed in the
Trigger List.

Modifying Trigger List
Follow these steps to change the triggers created by TriggerScan. Once you have finalized the Trigger List, you are
ready to start scanning.

1. To add a new trigger to the list: Set up the new trigger as desired on the Trigger dialog. Then, back on the
TriggerScan dialog, touch the Add New button to append the new trigger to the Trigger List.

2. To replace a trigger with one manually set up on the Trigger dialog: highlight the trigger in the Trigger List,
then touch the Update Selected button.

3. To delete a trigger from the list: highlight the trigger in the Trigger List, then touch the Delete Selected button.
All trigger setups can be deleted in one step by touching the Delete All button.

4. Optionally:
l Enter a Dwell Time the time instrument should wait before loading the next trigger.
l Check Stop On Trigger. You can use this to isolate events as triggers find them.
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Saving TriggerScan Setups
You can preserve the Trigger List by saving it to a setup file. The current Trigger List is not preserved after exiting the
application unless you manually save it.

1. On the TriggerScan dialog, touch Setup File Name and enter a file name, or touch the Browse button and
select a location and file name.

2. Touch the Save Setup... button.

To reload a saved Trigger List, touch the Browse button, locating the file, then touch Load Setup....

Running TriggerScan
When the Trigger List is set, touch the Start Scan button on the Trigger Scan dialog. The instrument automatically
cycles through all the triggers in the list.

To run only a single trigger, select it from the Trigger List and touch Load Selected. The trigger settings are copied to
the Trigger dialog and will be used when you start acquisition.

Viewing Acquisition Status
All current acquisition settings can be viewed through the various Status dialogs. Access them by choosing the
Status option from the Vertical, Timebase, Trigger, Math, or Analysis menus. The available options will depend on
your model.
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Display
Display menu settings affect the number and style of grids that appear on screen and some of the visual
characteristics of traces, such as persistence.

The oscilloscope features a multi-grid display, where each separate grid represents the full number of 4096 vertical
levels. Auto Grid Mode is enabled by default. This feature adds a grid each time a new trace is turned on. Other Grid
Mode selections are available on the Display dialog; the icons show what the result of that selection will be.

Display Set Up
To access the Display dialog, choose Display > Display Setup.

Open the Persistence dialog to apply persistence to the trace display.

Grid Mode
The Grid Mode setting determines the number and layout of display grids, each of which represents the full number
of vertical levels. The selection icon shows the number and arrangement of grids.

Grid Mode Number Orientation Notes

Auto
(default)

variable landscape Automatically adds or deletes grids as traces turned on/off, up to the maximum sup-
ported

Single 1 landscape All traces share one grid
Dual 2 landscape One top, one bottom
Tandem 2 portrait One left, one right
Triple 3 variable Two landscape grids left, one portrait grid right
Quad 4 landscape Stacked top to bottom
Quattro 4 landscape One in each quarter of screen
Octal 8 landscape Two columns of four stacked top to bottom
Twelve 12 landscape Three columns of four stacked top to bottom
Sixteen 16 landscape Four columns of four stacked top to bottom
Twenty 20 portrait Five columns of four stacked top to bottom
XY 1 portrait Single XY type grid
XYSingle 2 portrait One VT grid left, one XY grid right
XYDual 3 variable Two VT grids left, one XY grid right

Note: Additional grid modes may become available with the installation of software options.
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Other Grid Settings
To dim or brighten the background grid lines, touch Grid Intensity and enter a value from 0 to 100.

Grid on top superimposes the grid over the waveform.

Note: Some waveforms may be hidden from view with the grid on top.

Axis labels display the values represented by each division of the grid, based on your vertical scale and timebase.
Turned on by default, they may appear as absolute values or delta from center (0). Deselect the checkbox to remove
them from the display.

Trace Settings
Choose a line style for traces: solid Line or disconnected sample Points.

When more data is available than can actually be displayed given the number of vertical levels, Trace Intensity helps
to visualize significant events by applying an algorithm that dims less frequently occurring samples. Touch Intensity
and enter a value from 0 to 100.

Intensity 40% (left) dims samples that occur ≤ 40% of the time to highlight the more frequent samples,
vs. intensity 100% (right) which shows all samples the same.

XY Plots
XY plots display the phase shift between otherwise identical signals. They can be used to display either voltage or
frequency on both axes, each axis now corresponding to a different signal input, rather than a different parameter.
The shape of the resulting pattern reveals information about phase difference and frequency ratio.

Note: The inputs can be any combination of channels, math functions or memories, but both sources must
have the same X-axis scale.

Choose an XY grid mode and select the sources for Input X and Input Y.

Sequence Display Mode
These settings are used to select the Display Mode used when sampling in Sequence mode.
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Persistence Display
The Persistence feature retains waveform traces on the display for a set amount of time before allowing them to
gradually "decay," similar to the analog-style display of old, phosphor screen oscilloscopes. The display is generated
by repeated sampling of events over time and the accumulation of the sampled data into "persistence maps".
Statistical integrity is preserved because the duration (decay) is proportional to the persistence population for each
amplitude or time combination in the data.

The different persistence modes show the most frequent signal path in three-dimensional intensities of the same
color (Analog), or in a graded spectrum of colors (Color).

Access the Persistence dialog from the Display dialog or by choosing Display > Persistence Setup.

Turn On Persistence
1. Check Persistence On.

2. To set up all traces together, touch All Locked. This constrains all input channels to the same persistence
settings. To set up traces individually, touch Per Trace.

3. Use the buttons to select a persistence mode:

In Analog Mode, as a persistence data map develops, different intensities of the same
color are assigned to the range between a minimum and a maximum population. The
maximum population automatically gets the highest intensity, the minimum
population gets the lowest intensity, and intermediate populations get intensities in
between these extremes.

Color Mode persistence works on the same principle as Analog persistence, but
instead uses the entire color spectrum rather than intensities of a single hue: violet for
minimum population, red for maximum population.

3d Mode persistence creates a topographical view of your waveform from a selection
of shadings, textures, and hues. The advantage of the topographical view is that areas

of highest and lowest intensity are shown as peaks and valleys, in addition to color or brightness. The shape
of the peaks (pointed or flat) can reveal further information about the frequency of occurrences in your
waveform. You choose the Quality of the 3D display:

Solid quality can be either color or monochrome. Saturation is set at 50%, with
hotter colors indicating highest intensity.

In the monochrome view of solid, the lightest areas indicate highest intensity,
corresponding to the red areas in the color view.
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In shaded (projected light) quality, the shape of the pulses is emphasized. This
quality is monochrome only.

In wire frame quality, lines of equal intensity are used to construct the persistence
map. This display can be either color or Monochrome.

In 3d mode, X Axis Rotation and Y Axis Roation can range 180° from -90° to +90°. In the examples above, the
X-axis is rotated 60° an the Y-axis 15°.

Tip: To quickly rotate the graph, grab a corner of the persistence map and drag it in the desired
direction.

4. Select the Saturation level as a percentage of the total population. All populations above the saturation level
are assigned the highest color intensity. At the same time, all populations below the saturation level are
assigned the remaining intensities. Data populations are dynamically updated as data from new acquisitions
is accumulated. A saturation level of 100% spreads the intensity variation across the entire distribution; at
lower saturation levels, the intensity will saturate (become brighter) at a lower population, making visible
those events rarely seen at higher saturation levels.

5. In Persistence Time, enter the duration (S) after which persistence data is erased from the display.

6. You can superimpose the last waveform over the persistence map by selecting Show Last Trace (not
available in 3d mode).

Turn Off Persistence
To turn off persistence and return to the regular trace style, clear the Persistence On checkbox.
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Math and Measure
Teledyne LeCroy offers a rich set of standard, pre-programmed tools for the "quickest time to insight" into the
characteristics of acquired waveforms. Most instruments calculate measurements on all samples in an acquisition,
enabling you to rapidly accumulate thousands or millions of parameter values. You can also apply a variety of
mathematical functions to the input waveform trace and view the transformation in a math trace.

Zooming
Zooms magnify a selected region of a trace by altering the horizontal and/or vertical scale relative to the source
trace. They may be created in several ways, using either the front panel or the touch screen.

The current settings for each zoom trace can be seen on the Zn dialogs, while the Zoom dialog is a convenient panel
for turning on/off different zooms or quickly changing the zoom source.

You can adjust zooms the same as any other trace by using the front panel Vertical and Horizontal knobs or the
touch screen zoom factor controls.

The MultiZoom feature locks the Horizontal Scale and Center of those traces that you choose to include in the
MultiZoom group. As you change the scale or position of any trace in the group, all traces change in unison.

Creating Zooms
Any type of trace can be zoomed by creating a new zoom trace (Zn) following the procedures here. Zoom traces
open in the next empty grid, with the zoomed portion of the source trace highlighted. If there are no more available
grids, zooms will open in the same grid as the source trace.

Note: On most instruments with OneTouch, traces can be "zoomed" by pinching/unpinching two fingers
over the trace, but this method does not create a separate zoom trace. Pinching channel traces will alter the
acquisition timebase and the scale of all traces. Create a separate zoom trace to avoid this.

Zoomed area of original trace highlighted. Zoom in new grid below.
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Quick Zoom
Use the front panel Zoom button to quickly create one zoom trace for each displayed channel trace. Quick zooms
are created at the same vertical scale as the source trace and 10:1 horizontal magnification. The MultiZoom feature
is turned on, and all the new zooms are automatically added to the MultiZoom group.

To turn off the quick zooms, press the Zoom button again.

Rectangle Zoom
To "rectangle zoom", touch-and-drag diagonally to draw a rectangle around the part of the
source trace you wish to magnify. If you choose a Zn location, a new zoom of that trace is
created; if you choose the source trace as the destination, you will rescale the original
trace.

A new zoom will expand the horizontal area selected to fit the full width of the grid, while
the vertical area will be rescaled proportionally. The degree of vertical and horizontal
magnification, therefore, depends on the size of the rectangle that you draw.

Alternatively, with OneTouch you can drag any Zn descriptor box over the Add New box, or
touch the Add New box and choose Zoom from the pop-up menu. The next available
zoom trace opens with its Zn dialog displayed for you to modify scale as needed.

Zoom Function
Finally, you can create a Zoom math function. This method creates a new Fn trace, rather than a new Zn trace, but it
can be rescaled in the same manner. It is a way to create more zooms than you have Zn slots available on your
instrument.

Index Zoom
If you are working in a serial decoder, you can zoom the region of the source trace that is represented by one index
(row) of the decoder result table simply by touching that row. This method works for many software options that
present tabular results, besides the decoders.

Adjusting Zoom Scale
The zoom's horizontal units will often differ from the signal timebase, because the zoom is only showing a portion of
the total acquisition spread across 10 divisions. You can adjust the zoom factor using the front panel knobs or the
zoom factor controls however you like without affecting the timebase (a characteristic shared with math and
memory traces).

Close Zoom
New zooms are turned on and visible by default. If the display becomes too crowded, you can close a particular
zoom and the zoom settings are saved in its Zn slot, ready to be turned on again when desired.

To close the zoom, right-click (touch-and-hold until the white box appears) on the zoom descriptor box, then from
the context menu choose Off.

76



Math and Measure

Zoom Dialog

Choosing Math > Zoom Setup from the menu bar opens a dialog summarizing all active and inactive zoom trace
settings. Use the selection boxes to turn on/off zooms. There are also options to:

l Reset All, return all zooms to x1 magnification.
l Quick Zoom, create a corresponding zoom trace for each open channel trace, same as using the front panel

Zoom button.
l Turn on MultiZoom for all active zooms.

Zn Dialog

Behind the main Zoom dialog is a separate tab for each potential zoom trace (Z1-Zn). Each Zn dialog reflects the
center and scale for that number zoom. Use the Zoom factor controls to adjust each zoom independently.

Trace Controls
Trace On shows/hides the zoom trace. It is selected by default when the zoom is created.

Source lets you change the source of the zoom to any digital, math or memory trace while maintaining all other
settings.

Segment Controls
These controls are used to select the segment(s) to be "zoomed" for display when sampling in Sequence Mode.

Zoom Factor Controls
l Out and In buttons increase/decrease zoom magnification and consequently change the Horizontal

and Vertical Scale settings. Touch either button until you've achieved the desired level.

l Var.checkbox enables zooming in single increments.

l Horizontal Scale/div sets the time represented by each horizontal division of the grid. It is the equivalent of
Time/div in channel traces, only unlike that setting, it may differ for each zoom trace.

l Vertical Scale/div sets the voltage level represented by each vertical division of the grid; it's the equivalent of
V/div in channel traces.

l Horizontal/Vertical Center sets the time/voltage at the center of the grid.

l Reset Zoom returns the zoom to x1 magnification.

77

MultiZoom.htm
Sequence_Sampling_Mode.htm


WaveMaster 8000HD Oscilloscopes Operator's Manual

MultiZoom
The MultiZoom feature unifies the Horizontal Scale (Time/div) setting of those traces that you choose to include in
the MultiZoom group. The traces in the group can be zooms or other types of calculated (as opposed to acquired)
time traces, such as memories or math functions. This allows you to zoom in/out on several traces in unison, even if
they represent different sources, and pan the entire group together by dragging one trace or using the Auto Scroll
controls.

Note: Traces that cannot be in the same MultiZoom group because they are not time traces or are different
record lengths will be excluded from selection when setting up MultiZoom.

MultiZoom is automatically enabled when you use the Quick Zoom method, and all Quick Zooms are added to the
MultiZoom group. The descriptor boxes of those traces in the group are marked with a green underline.

When MultiZoom is enabled manually from the Zoom or MultiZoom dialogs, active zooms are automatically added
to the MultiZoom group, although other types of calculated traces must be added manually. As you add traces to the
group by checking the selection box on the MultiZoom dialog, they are set to the same Horizontal Scale as the first
trace that was added to the group since MultiZoom was last enabled. Once the group is set, modifying any member
of the group using the front panel Horizontal knobs or touch screen Horizontal controls will change the entire group.

Note: Since zooms are added first, the lowest numbered zoom in the group is usually the "master" trace to
which all others are rescaled, even though it may not appear at the top of the list of eligible traces on the
MultiZoom dialog. When MultiZoom is used with decoded Serial Data waveforms, the result table
functionality overrides this behavior, and zooms created by touching a table cell will center on that part of
the acquisition.

MultiZoom does not affect the Vertical Scale and Offset of any traces in the MultiZoom group. These continue to be
controlled independently for each trace.

Set Up MultiZoom

1. Choose Math > Zoom Setup... to open the Zoom dialog.

2. Check the MultiZoom box. All active zooms are added to the group and rescaled to match the first active
zoom in the list.

3. To modify the group further by adding or removing other types of traces, open the MultiZoom dialog and
select all the traces that are In the MultiZoom group.

4. The default MultiZoom sets traces to the Same Zoom Position (Horizontal Center). You may optionally
choose an Independent Zoom Position in order to simultaneously view different parts of the acquisition in
different traces, while continuing to zoom and scroll in unison. After you select Independent, then open the
individual trace dialog (e.g., Zn) and change the Horizontal Center.
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Note: Scrolling or dragging any of the MultiZoom group traces will shift the Horizontal Center of this
trace by the same amount of Delay as the others, however, it will remain proximate to the center you
set, which can be useful when wanting to step through two different sections of a longer acquisition.

Scroll Waveforms
The Auto-Scroll controls appear at the right of the MultiZoom dialog. They work similarly to A/V controls to allow you
to continuously scroll all the selected traces in time-locked steps from the beginning to the end of the acquisition.
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Cursors
Cursors are markers (lines, cross-hairs, and arrows) that identify horizontal and vertical values where they intersect
the X or Y axis. Use cursors to make fast, accurate measurements of points on the waveform.

Both Relative cursors. The same cursor type is applied to all open traces.

Cursor Types

Horizontal Cursors
Horizontal cursors are positioned at points on the x-axis and will measure the source trace horizontal and vertical
values at that point.

Horizontal Cursor Readouts

The Horizontal Abs(olute) cursor displays a single line, X1. The readout below the Timebase and Trigger descriptors
shows the horizontal value where X1 intersects the x-axis, in whatever is the x-axis unit of the source trace. The
readout on the source trace descriptor box shows the vertical value where X1 intersects the source trace, y@X1, in
whatever is the y-axis unit of the source trace.

The Horizontal Rel(ative) cursor displays two lines: X1 with the down-pointing arrow, and X2 with the up-pointing
arrow. The readout below the Timebase and Trigger descriptors always shows:

l The value where each cursor intersects the x-axis (X1 and X2)

l The difference of X2 – X1 ((∆x)

l For time traces, the frequency in Hz calculated from the delta time (1/(∆x).

80



Math and Measure

The readout on the source trace descriptor box depends on which Show option is selected:

l Absolute shows the vertical values where X1 and X2 intersect the source trace.

l Delta shows the difference in vertical value where each cursor intersects the source trace (marked by the
arrows), calculated as: y@X2 – y@X1 = ∆y. When the X1 arrow is higher than the X2 arrow, this will be a
negative number, as it represents a drop (e.g., in voltage), even when X2 is positioned above the zero level.
When the X1 arrow is lower than the X2 arrow, this will be a positive number, as it represents a rise.

l Abs + Delta shows both absolute and delta readouts.

l Slope calculates the difference in vertical value over the difference in horizontal value represented by the slope
from the X1 arrow to the X2 arrow, or: ∆y/∆x. The value will be intelligently converted to whatever unit is
appropriate for the source trace. Like the Delta readout, it will be positive or negative depending on the vertical
position of X2 relative to X1, regardless of its horizontal position.

When horizontal cursors are not tracking, they can be moved to any position along the x-axis individually. The
horizontal delta represents X2 – X1, which will be a positive number so long as X2 remains to the right of X1. If X2 is
moved to the left of X1, this will now be a negative number.

Tip: On instruments with OneTouch, when you drag the horizontal cursor readout from below the Timebase
descriptor box onto a zoom trace grid or descriptor box, the cursors will automatically adjust position to
reflect the difference in scale between the zoom and source traces.

Horizontal Scale
Horizontal cursors can be placed on traces whose x-axis has a dimension other than time, such as an FFT or a
Trend. When there is at least one non-time-domain trace open, the Standard Cursors dialog contains an X-Axis
control where you can choose the units to be measured by the horizontal cursors. The options will be appropriate to
the types of traces open; for example, if there is an FFT trace, there is an option for Hz. The cursors are placed on
those traces that display x-axis values in the selected units, rather than those with an x-axis of time.

Vertical Cursors
Vertical cursors intersect the y-axis and show the vertical value at that point (e.g., a voltage). These cursors can go
"off trace" to show vertical scale values that are not represented in the acquisition. Vertical cursors have no
horizontal readout below the Timebase descriptor, as they do not have an x-axis element. As they are set by
divisions, they remain in the same position and do not "readjust" with changes in the scale of the underlying traces.

The Vertical Abs(olute) cursor displays a single line, Y1. The readout on the source trace descriptor box shows the
vertical value at the point where Y1 intersects the y-axis.

The Vertical Rel(ative) cursor displays two lines: the dashed-dotted line is Y1, and the dashed line is Y2. As with the
Horizontal Relative cursor, the readout on the source trace descriptor box depends on the Show selection:

l Absolute shows the vertical values where Y1 and Y2 intersect the y-axis.

l Delta shows the difference in value of Y2 – Y1 (∆y). As long as Y2 remains below Y1, this is a negative number,
even if Y2 is positioned above the zero level. If Y2 is moved above Y1, it will become a positive number.

l Abs + Delta shows both vertical readouts.

Combination Cursors
The Both Rel(ative) option places both Vertical Relative and Horizontal Relative cursors together. The readouts will
be the same as when placing the cursors individually.

81



WaveMaster 8000HD Oscilloscopes Operator's Manual

Apply and Position Cursors
To turn on cursors, either:

l From the menu bar, choose Cursors and select the desired cursor type from the drop-down list.

l On the front panel, press the Cursor button to turn on cursors, then continue pressing to cycle through all the
cursor types. Stop when the desired type is displayed.

Note: There must be a trace on the grid for cursors to execute, although acquisition may be in process or
stopped when you turn them on.

To turn off cursors, either:

l From the menu bar, choose Cursors > Off.

l Continue cycling the Cursor button until you reach "Off" (the cursor lines disappear).

To reposition a cursor:

l Drag-and-drop the cursor marker to a new position. Indicators outside the grid show to which trace the cursor
belongs when you have multiple traces on one grid.

Use the Position data entry controls on the Standard Cursors dialog to place cursors precisely.

l Alternatively, use the Front Panel Cursor knobs. The Cursor knob adjusts absolute cursors, while the knob
adjusts relative cursors. If you're using the Both Rel cursor type, pushing the knobs will toggle between the
Horizontal and Vertical cursors. With the correct cursor selected (highlighted), turn the knob to adjust the
position. Otherwise, pushing the knob will reset the cursor to the default position.

Tip: When there are multiple traces on the same grid, first bring the desired trace to the foreground by
touching the trace or its descriptor box. The Cursor knob will only operate on the foreground trace.

On oscilloscopes with OneTouch, if Horizontal cursors are applied to a source trace but do not appear on its
dependent traces (e.g., a zoom) because of differences in scale, drag-and-drop the cursor readout from below the
Timebase descriptor box onto the target trace descriptor box. This will apply the cursor at the 5 (absolute) or 2.5 and
7.5 (relative) division marks of the target trace and adjust the source trace cursor accordingly.

To track cursors, moving both lines together at a consistent distance, check Track on the Standard Cursors dialog.
Drag the X1 or Y1 cursor marker, or select the set using the front panel controls and turn the Cursor knob. The delta
readouts should show little or no change when tracking, although absolute readouts will change depending on the
new position of the cursors. Moving the X2 or Y2 cursor will reset the relative distance and the delta, after which you
can again track by moving the X1 or Y1 markers.
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Standard Cursors Dialog
These controls can be used instead of the front panel controls to turn on cursors or to refine the cursor position.
Access the dialog by choosing Cursors > Cursors Setup from the menu bar.

Cursor Type buttons select the type of cursor displayed on the grid.

The Show controls determine what values are shown in the vertical readout when using relative cursors:

l Absolute shows specific voltages for the two cursor locations.

l Delta shows the difference between the specific voltages at the cursor locations.

l Abs+Delta shows both the absolute and delta readouts.

l Slope (Horizontal Relative only) shows the slope of the waveform between the cursor locations.

Refer to Cursor Types for a detailed explanation of what is shown with each option.

The Position controls at the right-side of the Standard Cursors dialog display the current cursor location and can be
used to set a new location.

l X 1 and X 2 sets the position of Horizontal cursors. They may be entered as time or a fraction of a division.

l Y 1 and Y 2 sets the position of Vertical cursors, entered as a fraction of a division.

Track locks relative cursor lines so they move together, maintaining the same distance from each other. Only move
X1 or Y1 to reposition the cursors. Moving X2 or Y2 will change the relative distance.

XY Cursors Dialog
If your Grid Mode selection includes an XY trace display, an XY Cursors dialog appears behind the Standard Cursors
dialog. Use it to exactly position and track cursors on XY traces, the same as you use the settings on the Standard
Cursors dialog for time traces. The functionality is the same.
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Measure
Parameters are tools that give you access to a wide range of waveform properties, such as Rise Time, RMS voltage
and Peak-Peak voltage. The instrument offers a quick selection of standard parameters, or you can create a user-
defined set of parameters (My Measure) drawn from all available measurements.

On instruments equipped with CustomDSO (XDEV), custom scripts may be used to calculate a parameter. Several
scripting "languages" are supported, depending on the application. You can find these options in the Custom
submenu of the Measure Selector. Scripts may be imported or written in the instrument's Script Editor window. See
Using P Script for a description of the process.

Parameter readouts are shown in a dynamic Measure table that appears below the waveform grids. All active
measurements can be used as inputs to other processes, such as Pass/Fail tests, even when the Measure table is
hidden from view. The history of a parameter can be graphed as a histogram, track or trend for statistical analysis.

Measurements are calculated and can be applied to other processes even when they are not displayed.
In the image at right, the P1 amplitude measurement is used in a Pass/Fail test, although the Measure table is hidden.

Measure Dialog
The Measure Dialog gives quick access to measurement features. Besides turning on/off parameters, use the
Measure dialog to display statistics, histicons and help markers for standard and user-defined parameter sets. You
can also gate parameters to limit the horizontal scope of the measurement.

Use the Parameter (Pn) dialogs to create a user-defined set of parameters.

Selecting Measurements

1. To open the Measure dialog, touch the Add New box and select Measurement, or choose Measure > Measure
Setup from the menu bar.

2. Check Show Table to display the readout. This is not required to take the measurement.

3. Choose the Std. Vertical or Std. Horizontal parameters.
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Or, to turn on your own parameters, choose My Measure, then select the On checkbox next to each parameter
you wish to display. Open the Pn dialogs to define new parameters.

4. Optionally:
l Show Help Markers.
l Gate parameters to limit measurements to only edges inside the gates.
l Add Statistics and Histicons to the Measure Table.

Touch Clear Sweeps to reset all measurement counters and restart all statistics.

Touch Clear All Definitions to reset all parameters to "None".

Caution: Definitions cannot be restored after clearing, you must repeat parameter set up.

Standard Parameter Sets
The pre-configured standard parameter sets available on the Measure dialog are:

l Std Vertical: Pk-Pk, Ampl, Max, Min, Sdev, Mean, Base, Top

l Std Horizontal: Rise, Fall, Period, Frequency, Width, Duty Cycle, Delay, N Points

To quickly begin a new set of user-defined parameters based on the standard vertical or horizontal sets, touch Quick
Setups and choose the set to copy. Refine the settings on the Pn dialogs.

Statistics and Histicons
Checking Statistics On on the Measure dialog adds the mean, min, max and sdev of each parameter to the
measured value shown on the Measure table.
Statistics for each parameter are calculated once per acquisition and accumulate until you either Clear Sweeps or
the measurement buffer is full. The Num row of the Measure table shows the total number of measurements
included in the Statistics calculation. If the measurement is gated, the statistics are calculated for only the data
points between the gates, just as the parameter value itself will reflect the limits imposed by the gate.

Mean The weighted mean of the parameter calculated over the number of times shown.

Min The minimum value of the parameter measured over the number of times shown.

Max The maximum value of the parameter measured over the number of times shown.

Sdev The population standard deviation of the parameter calculated over the number of times shown.

Num For any parameter that computes once on an entire acquisition, Num represents the number of sweeps over
which the statistics are computed.

For any parameter that computes on every event within an acquisition, such as a full period, Num represents the
number of events per sweep times the number of sweeps computed. Thus, for a Single acquisition of five periods,
the Num shown for any per period measurements will be 5, as five measurements were made and the statistics
reflect those five measurements. After another Single acquisition, Num will be 10, or five measurements times two
sweeps. The statistics now reflect all 10 measurements.

Histicons are miniature histograms of measurements that may be added to the
Measure table . They let you see at a glance the statistical distribution of each
parameter. Check Histicons on the Measure dialog.

Tip: You can quickly display a full histogram by touching the histicon you want to enlarge.
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Gating Measurements
All measurements are calculated on only that portion of the waveform trace that is visible on the grid and within the
measurement gates. On >500 Mpts acquisitions, measurements are also limited to the center 500 Mpts of the
acquisition. Any setting that moves the trace outside the observation window or makes it appear "clipped" will affect
measurements.

The default starting positions of the measurement gate posts are 0 div and 10 div, which coincide with the left and
right edges of the grid, and the First and Last points. Therefore, the measurement gates initially enclose the entire
visible acquisition. By moving the measurement gates, you can focus the measurement on the section of the
acquisition of greatest interest. For example, if you "gate" six rising edges of a waveform, calculations are performed
only on the six pulses bounded by the gate posts.

Gates (vertical white lines) limit the data measured and visibly change measurement calculations.

If you wish to gate all parameters to the same number of edges, use the Gate fields on the Measure dialog. For user-
defined parameter sets ("My Measure"), first check Lock to activate the Start and Stop fields. Standard parameter
sets are automatically gated to the same number of edges, you do not need to first Lock the gates. The quickest way
to set a gate is to drag the gate posts from the far left and right of the grid to the desired positions, or you can enter
the Start and Stop positions down to hundredths of a division. When gates are locked, all measurements will change
together when you drag either gate post to reposition the gate.

Deselect Lock to return gates to their last unlocked position. Touch Default to return gates to the edge of the grid.

To apply different gates to individual user-defined parameters, deselect Lock on the Measure dialog and use the
Gate subdialog of the Pn dialog to enter the Start and Stop positions. These positions will be resumed when gates
are unlocked.
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Help Markers
Help Markers clarify measurements by displaying lines, labels and hysteresis bands to mark the points being
measured on the trace. For "@Level" parameters, markers make it easier to see where your waveform intersects the
chosen level. If you change the set of parameters displayed, the markers will change, as well.

You can choose to use Simple markers, which are only the lines, or Detailed markers, which include the
measurement point labels.

You also have the option, by means of the Always On checkbox, to leave the markers displayed over traces after you
have closed the Measure dialogs or readout table.

Note: Unlike regular cursors, which are white and can be moved, help markers are blue and only augment
the display; they cannot be moved, and they do not reset the measurement points. Some optional analysis
software packages include markers designed specially for that domain of reference, which are documented
in the option manual.

Detailed Help Markers
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Parameter Set Up
Use the Pn dialogs to define a new set of measurement parameters ("My Measure").

Note: On acquisitions >500 Mpts in length, measurement are calculated on only the center 500 Mpts of the
acquisition. See Navigating Long Acquisitions for information on positioning the region you want measured
in this zone.

1. From the menu bar, choose Measure > Measure Setup.

2. Choose Measure Mode My Measure.

3. Open the Pn dialog and check On to activate the parameter.

4. Select the Type Measure On Waveforms.

5. Touch the Source selectors and choose the trace to be measured. Some measurements require two sources.

6. Touch the Measure field and select the measurement from the pop-up menu.

7. Make any further selections on the subdialogs that appear after your Measure selection. These are explained
on the dialog and are necessary to fully define the measurement.

l For @Level parameters, enter the measurement level and optional hysteresis.

l For certain time-based measurements, choose the slope(s) on which to begin the measurement.

l Where relevant, choose to make the measurement per period or cycle.

8. Optionally, turn on help markers, or use the parameter subdialogs to:

l Gate measurements (limit the horizontal scope of the measurement)

l Accept only measurements that meet additional conditions

Slope, Level and Hysteresis
Several time-based measurements enable you to select on which edge of the waveform the measurement begins, or
at what level the measurement is taken (e.g., *@level parameters). These measurements usually also offer options
for determining how the level is defined, and for setting up a hysteresis band to prevent unwanted waveform effects
from altering the measurement.

Slope
The Slope determines the edge of a pulse (the X axis point) at which measurements are made, or from which edge to
which edge a single period/cycle is counted. Slope can impact per period and cyclic measurements, as the number
of complete periods may be different depending on which edge is used.

For two-input parameters, such as Dtime@level, you can specify the Slope used for each input separately to
determine the points on each waveform to be compared.

88

#Adjustin


Math and Measure

There are three possible settings for Slope:

l Positive, use the rising edge of a pulse

l Negative, use the falling edge of a pulse

l Both, use either edge, whichever next occurs that meets the other criteria

Here, the P1 Half Period parameter uses a Slope of Both, resulting in 10 measurements in this five period acquisition,
one every time the signal crosses the 50% Level, rising or falling (only the first rising edge measurement is marked by
the Help Marker).

If Slope were set to Positive, there would be only five measurements in this acquisition, one every time the rising
edge crossed the 50% Level, but not the falling edge (the Num row shows the difference).
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Level
Level is the point on the Vertical (Y) axis used to take a measurement. The default Level for measurements is 0 V or
50% amplitude, the center grid line when there is no Vertical Offset . When Level can be specified, it can usually be
set as either:

l An Absolute number of Volts, or whatever is the vertical unit of the source waveform

l A Percent of waveform amplitude, as determined by the Top-Base calculation

Measurements that may be calculated per period usually have a Levels setting to specify the Level on the rising edge
from which full periods are counted.

Hysteresis
The Hysteresis setting defines an amplitude “band” which the input signal must exceed before a crossing can be
determined. Some non-zero Hysteresis value is required to prevent false crossing determinations. The default value
is 500 millidivisions (mdiv), with the unit “divisions” being equal to oscilloscope vertical grid divisions.

l Lower hysteresis values improve the ability to detect crossings on a smaller amplitude signal, but with risk that
false crossings will be detected. This also means that the signal must meet a minimum amplitude requirement,
and be relatively noise free at lower amplitudes.

l Higher hysteresis values improve the ability to reject the impact of signal distortion or noise in determination of
the crossing, but with risk that accuracy of crossing detection will be reduced.

For example: a non-monotonic signal crosses the 50% measurement threshold on the rising edge nine times within
the observation window, although there are actually only four waveform cycles. Without Hysteresis, the non-
monotonicity period is incorrectly detected as crossing and therefore a measurement interval, which will result in
incorrect calculation of periodic measurements.

A Hysteresis level that is greater than the amplitude of the non-monotonicity results in only four measurement
intervals, avoiding false measurement calculations.
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Periodic and Cyclic Measurements
Some measurement set up dialogs display a checkbox for Show one value per period or Cyclic.

Periodic measurements return one measurement per full waveform period in the acquisition. Usually, "per period" is
an option for Vertical parameters, like Amplitude, that would normally return only the value of the last full period in
the acquisition. By choosing Show one value per period, the Amplitude of each full period measured is computed
into the mean, and num will show the number of measurements used (value will still show the value of the last pulse
measured). The example below shows how the P1 Amplitude parameter Num statistic changes from 1 to 5 when
set to measure per period. A hysteresis band Help Marker also appears, showing the level at which the periods are
counted.

Tip: A WaveScan set to Measurement mode on the same source and measurement will show all the per
period values within the acquisition.

Similarly, cyclic measurements are computed over the span of full periods in the acquisition, ignoring any partial
periods at the beginning or end of the acquisition. For example, if the Area parameter is set to Cyclic, and the
acquisition has five full cycles, then only the Area of those five cycles is calculated, as shown below. The blue Help
Markers show the five full periods, while the partial periods at the start and end of the acquisition are omitted.
Normally, the Area of the full, visible acquisition is calculated. In both cases, only one measurement value is returned,
but the value will be different.
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Counting Periods/Cycles
Per period and cyclic measurements are subject to the other measurement settings, such as the Slope and Level
from which to count the waveform periods. Always visit the subdialogs that appear when checking Show one value
per period or Cyclic to determine if there are further settings to be made.

When the measure gates are in their default positions of 0 and 10 div, the periods/cycles are counted across the full
width of the grid. If the gates are set elsewhere, then the measurements are computed on only as many full
periods/cycles are within the gate. As shown below, gating the cyclic Area measurement reduces the calculation to
the three full cycles that are within the measure gates.

N-Cycle and N-Period Set Up
The measurements Period@level and Dperiod@level include settings to specify how often to make the
measurement and at which cycle to start, rather than using only the full integer number of cycles. The subdialogs
containing these settings are called variously N-Cycle Setup and N-Period Setup, but they do the same thing.

Group Size sets the interval of full cycles at which to take the measurement. For example, the image below shows an
acquisitive of five full cycles, which is evident from the P2 Period statistics showing Num 5, indicating that's how
many periods were calculated. P1 Dperiod@level, which by default measures the delta between two consecutive
periods, shows only a Num of 4, because using a Group Size of 1, four comparisons could be made—period 1 to
period 2, period 2 to period 3, and so forth.
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Note that although the Help Markers overlay the first two periods, the measurement value of -1.686 ns reported is
actually the final measurement comparing the last two periods, as would be shown by looking at a WaveScan of the
same acquisition.

When the Dperiod@level Group Size is changed to 2, the measurement is taken every other period, and because only
two measurements can be made out of the five period total (periods 1 to 3 and 2 to 4), the P1 Num changes to 2.

Start Cycle is the cycle from which to begin counting the measurement, which can be any number Group Size-1, as
the count will begin with the first full group. When the P1 Dperiod@level Start Cycle is changed from 0 to 1, period 1
is skipped, and the measurement begins at period 2. Now, Num has changed to 1, because only one measurement
can be made using periods 2 and 4, omitting 3 and 5 due to the Group Size of 2.
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Dperiod@level also allows you to also specify how the Group Size interval is treated, as a separator or a summation.
Use One Value Per Group (shown above) measures every nth cycle, the first in each group. Sum All Values in Group
(shown below) calculates the sum of all the cycles in the group and compares it to that of the next group.

Accepting Measurements
Some measurements can be constrained to a vertically or horizontally limited range of values, or to samples "gated"
by the state of a second waveform. Both constraints can operate together. This capability enables you to exclude
unwanted characteristics from your measurements. It is much more restrictive than a measurement gate, which is
used only to narrow the span of analysis along the horizontal axis.

Note: Since this feature operates on only a subset of the data, possible alerts or status indicators
concerning the measurement (such as "Data range too low") are not displayed.

If the measurement supports this feature, you will see the Accept subdialog next to the Pn dialog for you to define
your constraints.

Range Limited Parameters

1. From the menu bar, choose Measure > Measure Setup..., then touch the Pn tab to open the parameter setup
dialog.

2. On the Accept subdialog, select Values In Range and enter the start and stop values, or touch the Find Range
button to quickly display the most recently measured range of values.
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Note: The correct units for the measurement (V, s, Hz, dB, etc.) are automatically displayed. If you
select a simple ratio parameter that yields a dimensionless number (such as power factor), units are
omitted.

Waveform Gated Parameters

1. From the menu bar, choose Measure > Measure Setup, then touch the Pn tab to open the parameter setup
dialog.

2. On the Accept subdialog, select Values Based on Waveform State.

3. Touch When Wform and select the gating waveform. It can be any waveform active at the same time as the
measurement source waveform.

4. Touch State Is and select High or Low from the pop-up menu. Measurements will only be taken when the
gating waveform is in the selected state.

5. Touch Level Type and select Absolute (voltage) or Percent (of amplitude) from the pop-up menu.

6. Enter the crossing Level value at which you want measurements to begin.

You can also touch the Find Level button to automatically set the level at 50% of the gating waveform.
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List of Standard Measurements

Note: Unless otherwise stated, measurements are calculated according to IEEE standards. Additional
measurements may be available depending on the software options installed. The keyword to use in remote
control programs appears in Summary on the Pn dialog.

Waveform Measurements
Amplitude - Difference between the upper and lower levels in two-level (bi-modal) signals. Differs from Peak-to-Peak
(pkpk) in that noise, overshoot, undershoot, and ringing do not affect the measurement. Amplitude is calculated
using the formula for Top-Base. On signals that cannot be identified as bi-modal (e.g., triangle waveforms),
Amplitude returns the same value as Maximum – Minimum. Amplitude may be calculated once per period, rather
than once per acquisition, by selecting "Show one value per period" on the Amplitude subdialog.

Area - Integral of data. Computes the area of the waveform relative to the zero level. Values greater than zero
contribute positively to the area; values less than zero contribute negatively. If Cyclic is checked on the Area
subdialog, the area is calculated only over the total number of full cycles, rather than the entire acquisition. See
Periodic Measurements.

Base - Lower level in two-level (bi-modal) signals (the higher is Top), or lower of two most probable waveform states
on waveforms that are not bi-modal. Base differs from Minimum in that noise, overshoot, undershoot and ringing do
not affect the measurement. On signals that are not bi-modal (e.g., triangle waveforms), Base returns the same value
as Minimum. Base may be calculated once per period, rather than once per acquisition, by selecting "Show one value
per period" on the Base subdialog.

Bit Rate - Bit rate of input data stream, calculated on rising edges only, so it is not affected by DCD. The
measurement must be made on at least three rising edges, so that there is more than one interval between rising
edges. Otherwise, the measurement returns the clock frequency, and a warning symbol will appear on the Measure
table.

Cycles - Number of cycles in a periodic waveform that occur between the measurement gates (by default, 0 and 10
divisions, or the full acquisition). The first cycle begins at the first rising threshold crossing after the left
measurement gate.

Delay - Time from the acquisition trigger to the first 50% level crossing visible in the observation window. On
acquisitions without a Timebase Delay setting, this is usually a negative number.

Delta Delay - Time from the first 50% level crossing of Source1 to the first 50% level crossing of Source2. Delta Delay
can be used to measure the propagation delay between two signals by triggering on one and measuring the Delay of
the other. It may yield a negative result in cases where the Source2 crossing occurs before the Source1 crossing.
See Gating Measurements.

Dperiod@level - Cycle-to-cycle deviation of the period measurement, measured from rising edges (Pos Slope), falling
edges (Neg Slope), or next crossing (Both Slope) at the specified Level. See Slope, Level and Hysteresis. By default, it
measures the adjacent cycle deviation (cycle-to-cycle jitter) for each cycle in a waveform, but it may be configured to
compare cycles at set intervals or the mean value of groups of cycles by using an N-Cycle Setup. See Periodic
Measurements.

Dtime@level - Time between transitions on two, different input signals, measured on rising edges (Pos Slope), falling
edges (Neg Slope), or next crossing (Both Slope) at the specified Level. Dtime@level may yield a negative result in
cases where the Source2 crossing occurs before the Source1 crossing. See Gating Measurements and Slope, Level
and Hysteresis.
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Dtrig Time - Time from last acquisition trigger to the present acquisition trigger. For Sequence Mode acquisitions,
the time between segment triggers within a single segmented waveform.

Duration - Time from first acquisition trigger to last acquisition trigger included in an average, histogram, or
segmented waveform. For single-sweep acquisitions, Duration is 0. For segmented waveforms (Sequence mode
acquisitions), Duration is the time from the first segment trigger to the last segment trigger (that occurs between the
measurement gates). For averages, histograms and other waveforms calculated over a history of acquisitions,
Duration is the time from the first to the last accumulated waveform's trigger.

Duty Cycle - Percent of period for which data are above or below the 50% level of the signal, using a hysteresis band
of 22% of amplitude.

Duty@level - Percent of period for which data are above or below a specified level, measured on rising edges (Pos
Slope) or falling edges (Neg Slope). See Slope, Level and Hysteresis.

Dwidth@level - Difference between adjacent Widths, measured on rising edges (Pos Slope), falling edges (Neg
Slope), or next crossing (Both Slope) at the specified Level.

Edge to Edge - Time from the specified edge on Source1 to the specified edge on Source2.

Edge@level - Number of edges in waveform that cross the specified threshold Level, measured on rising edges (Pos
Slope), falling edges (Neg Slope), or next crossing (Both Slope). See Slope, Level and Hysteresis.

Fall 80-20% - Duration of a pulse waveform's falling transition from 80% to 20% of the amplitude, measured for all
falling transitions with the value for the last full pulse shown. On signals that do not have two major levels (e.g.,
triangle waveforms), the Top-Base measurement used to calculate Amplitude can default to Maximum and
Minimum, giving less predictable results.

Fall Time - Duration of a pulse waveform's falling transition from 90% to 10% of the Amplitude, measured for all
falling transitions, with the value for the last full pulse shown. On signals that do not have two major levels (e.g.,
triangle waveforms), the Top-Base measurement used to calculate Amplitude can default to Maximum and
Minimum, giving less predictable results.

Fall@level - Duration of pulse waveform's falling transition between two, user-specified transition levels, measured
for all falling transitions, with the value for the last full pulse shown. Two vertical values on the falling edge are used
to compute fall time:

High = upper threshhold value x Amplitude/100 + Base
Low = lower threshold value x Amplitude/100 + Base

See Slope, Level and Hysteresis.

First - Time at which the left measurement gate intersects the Horizontal axis, marking the first sample point
included in the measurement. By default, this is the time at 0 divisions, set at the far left of the grid.

Frequency - Reciprocal of each Period of cyclic signal. Period is measured as time between every pair of 50%
crossings on the rising edge, starting with the first rising transition after the left measurement gate.

Freq@level - Reciprocal of each Period of a cyclic signal. Period is measured as the time between every pair of
crossings at the specified level and edge, starting with first matching transition after left measurement gate. See
Slope, Level and Hysteresis.

Half Period - Half period of a waveform, measured as the time between adjacent transitions of opposite slope at a
specified level. You can configure this measurement to be taken from only rising edges to falling edges (Pos Slope),
from only falling edges to rising edges (Neg Slope), or from every crossing to the next (Both Slope). See Slope, Level
and Hysteresis.
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Hold Time - Time from the first data signal edge at specified slope and level (Source2), to nearest previous clock
signal edge at specified slope and level (Source1). Use Hold Clock subdialog to specify clock edge, and Hold Data
subdialog to specify the data edge.

Last - Time at which the right measurement gate intersects the Horizontal axis, marking the last sample point
included in the measurement. By default, this is the time at 10 divisions, set at the far right of the grid.

Level@X - Vertical value at the specified x-axis position, which may be set by entering a value or moving the white
measurement cursor. If the position is between two sample points, it gives the interpolated value. When the Nearest
point checkbox is selected, it gives the vertical value of the nearest data point.

Maximum- Largest vertical value in a waveform. Unlike Top, does not assume the waveform has two levels.

Mean - Average of vertical values in a waveform. Computed as centroid of distribution for a histogram of the data
values.

Median - Average of Top and Base values.

Minimum - Smallest vertical value in a waveform. Unlike Base, does not assume the waveform has two levels.

N-Cycle Jitter - Peak-to-peak jitter between edges measured at N UI intervals. Results may be viewed in time (S) or
UI.

NBPhase - Narrow Band Phase, phase at a specified frequency of the signal.

NBPower - Narrow Band Power, power at a specified frequency of the signal.

Num Points - Number of data points in the source waveform between the measurement gates.

Overshoot- - Amount of overshoot following falling edges, represented as percentage of amplitude. Overshoot- is
calculated using the formula (Base - Minimum)/Amplitude x 100. On signals that do not have two major levels (e.g.,
triange waveforms), this measurement may not give predictable results.

Overshoot+ - Amount of overshoot following rising edges, represented as a percentage of amplitude. Overshoot+ is
calculated using the formula (Maximum - Top)/Amplitude x 100. On signals that do not have two major levels (e.g.,
triangle waveforms), this measurement may not give predictable results.

Peak to Peak - The difference between the maximum and minimum vertical values within the measurement gates.
Unlike Amplitude, does not assume a waveform has two levels.

Period - The time between 50% crossings on the rising edge, starting with the first transition after the left
measurement gate. Period is measured for each adjacent pair, with values averaged to give the final result.

Period@level - The time between crossings at a user-specified slope and level, starting with first transition after the
left measurement gate. See Slope, Level and Hysteresis. By default, Period is measured for each adjacent pair, with
values averaged to give the final result, but it can be configured to compare cycles at set intervals by using an N-
Period Setup. See Periodic Measurements.

Phase - Phase difference between analyzed and reference signals, measured from the 50% level of their rising
edges.

Rise 20-80% - Duration of a pulse waveform's rising transition from 20% to 80% of amplitude, measured for all rising
transitions with the value for the last full pulse shown. On signals that do not have two major levels (such as triangle
or saw-tooth waves), the Top-Base measurement used to calculate rise can default to Maximum and Minimum,
giving less predictable results.

Rise Time - Duration of a pulse waveform's rising transition from 10% to 90% of amplitude, measured for all rising
transitions with the value for the last full pulse shown. On signals that do not have two major levels (e.g., triangle
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waveforms), the Top-Base measurement used to calculate rise can default to Maximum and Minimum, giving less
predictable results.

Rise@level - Duration of a pulse waveform's rising edge between user-defined transition levels, measured for all
rising transitions with the value for the last full pulse shown The two values used to compute the rise time are
calculated as:

Low = lower threshold x Amplitude/100 + Base
High = upper threshold x Amplitude/100 + Base

See Slope, Level and Hysteresis.

RMS - Root Mean Square of the vertical values (between the measurement gates), calculated:

Where:
Vi = measured vertical values
N = number of data points

If Cyclic is checked on the RMS subdialog, the RMS is calculated over only full cycles, rather than the entire
acquisition. See Periodic Measurements.

Setup - Time from data edge (Source2) to next nearest clock edge (Source1).

Skew - Time of Clock2 edge (Source2) minus the time of previous Clock1 edge (Source1).

Slew Rate - Slew rate (local dV/dt) at user-specified slope and level. See Slope, Level and Hysteresis.

Std Dev - Standard deviation of the vertical values between the measurement gates, calculated:

Where:
Vi = measured vertical values
N = number of data points

This is equivalent to the RMS for a zero-mean waveform. Also referred to as AC RMS.If Cyclic is checked on the Std
Dev subdialog, the standard deviation is calculated over only full cycles, rather than the entire acquisition. See
Periodic Measurements.

TIE@level - Difference between the measured crossing time at the specified slope and level and the ideal expected
time. The measurement may be given in time (S) or unit interval (UI). A UI equals one clock period. The Virtual Clock
(set up on the VClock subdialog) enables you to simulate your choice of Standard (1.544 MHz) or Custom reference
clocks. You can also use a mathematically derived Golden PLL to filter low frequency jitter. The cutoff frequency is
user selectable. See Slope, Level and Hysteresis.

Time@level - Time from trigger (t=0) to crossing at a specified slope and level. See Slope, Level and Hysteresis.

Top - Higher vertical value in two-level (bi-modal) signals (the lower is Base), or higher of two most probable
waveform states on waveforms that are not bi-modal. Top differs from Maximum in that noise, overshoot,
undershoot and ringing do not affect the measurement. On signals that do not have two major levels (e.g., triangle
waveforms), Top returns the same value as Maximum. Top may be calculated once per period, rather than once per
acquisition, by selecting "Show one value per period" on the Top subdialog.
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Width - Width of cyclic signal at 50% level and positive slope, using a hysteresis of 22% of amplitude, measured for
all transitions with the value for the last full pulse shown.

WidthN - Width of cyclic signal at 50% level and negative slope, using a hysteresis of 22% of amplitude, measured for
all transitions with the value for the last full pulse shown.

Width@level - Width of cyclic signal at a user-specified level, slope and hysteresis, measured for all transitions with
the value for the last full pulse shown. See Slope, Level and Hysteresis.

X@max - The horizontal axis location of the maximum vertical value between the measurement gates.

X@min - The horizontal axis location of the minimum vertical value between the measurement gates.

Histogram Measurements
These measurements can be made on histogram math functions. You will receive an error status if you attempt to
place them on a pulse waveform or other incompatible source.

FWXX - Full Width at xx%, width of the largest area histogram peak at a user-specified percentage of the population
of the highest peak.

Hist ampl - Difference in value of the two most populated peaks in a histogram when the distribution is bi-modal. If
the distribution is not bi-modal, it is the difference between the Maximum and Minimum values in the histogram.

Hist base - Value of the left-most of the two most populated histogram peaks.

Hist max pop - Count of the maximum population (highest) peak in a histogram.

Hist maximum - Highest measured value in a histogram.

Hist mean - Average or mean value of measurements in a histogram.

Hist median - Median value of measurements in a histogram, the 'X-axis' of a histogram that divides the population
into two equal halves.

Hist minimum - Lowest measured value in a histogram.

Hist mode - Value represented by the highest histogram peak, shown in the unit of the histogrammed parameter.

Hist pop@x - Population of the histogram bin at a specified horizontal position.It is helpful to Stop Trigger and turn
on Axis Labels for this measurement so you can see the visible range of horizontal values. Once you enter a value in
this range, the histogram cursor will appear for you to drag to different positions along the X axis. The value reported
on the Measure table will change as you drag the cursor.

Hist range - The Max-to-Min range of a histogram.

Hist rms - Root mean square of the values in a histogram.

Hist sdev - Standard deviation of the values in a histogram.

Hist top - Value of the right-most histogram peak.

Hist X@peak - Value of the nth highest histogram peak. You supply the value of n.

Peaks - Number of peaks in a histogram.

Percentile - Horizontal data value that divides a histogram so that the population to the left is xx% of the total.

Total Pop - Total population (number of values plotted) of a histogram.
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Custom Measurements
These "measurements" enable you to insert a custom script into the oscilloscope process and read back results into
the parameter in real time.The script must yield a numeric result.

Custom measurements are standard on WaveMaster, LabMaster, DDA and SDA models. They are enabled with the
XDEV option on others.

ExcelParam - Custom measurement calculated in Excel. The measurement will transfer one or two waveforms (as a
series of time-value pairs) into an Excel spreadsheet and read the result of the function into the parameter.

Fast MultiWave Port - Provides memory mapped C++ file access using multiple inputs for custom measurement
calculation. The result may optionally be read back into the parameter.

HParamScript - Custom Visual Basic or Java script that calculates a measurement on one or two input histograms,
as opposed to waveforms.

MathCad param - Custom MathCad function that calculates a measurement.

MATLAB param - Custom MATLAB function that calculates a measurement. You may write a MATLAB script on the
oscilloscope, or call a pre-existing MATLAB function into a script. MATLAB can run locally on the oscilloscope, or
remotely on a host that is accessible to the oscilloscope. See the MAUI Oscilloscopes Remote Control and
Automation Manual for instructions on connecting to MATLAB remotely.

ParamScript - Visual Basic or Java script that calculates a measurement from one or two input waveforms. The
script may run locally on the oscilloscope, or remotely on a host that is accessible to the oscilloscope. See the MAUI
Oscilloscopes Remote Control and Automation Manual for instructions on connecting remotely.
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Measure Table
The header of the Measure table shows the parameters configured for each measurement slot (P1-Pn).

The value row of the Measure table shows the measurements taken for each parameter on the last acquisition. You
may optionally calculate and display the statistical mean, min, max and sdev of all parameters. Statistics are
calculated once per acquisition and accumulate over multiple acquisitions, up to the two billion value limit of the
measurement buffer.

To quickly set up the table, drag any configured cell onto an empty cell of the Measure table. Then, drag the
descriptor box of the trace to be measured onto the new parameter. Touch the cell to choose a new measurement
or make any other modifications on the Pn dialog.

Close setup dialogs when the Measure table is displayed to maximize the area available for viewing waveforms. The
table itself can be used to reopen setup dialogs. To open the Parameter Setup (Pn) dialog, touch the Pn cell of the
table. Touch the far left Measure column to open the Measure dialog and modify the table. The table is static when
using standard measurement sets, as these cannot be changed.

Symbols in the status row of the Measure table indicate the following:

OK: valid value returned.

Warning: there is a problem with the signal or the setup that prevents measuring. Touch the parameter cell
to see an explanation in the message bar.

No Pulse/Insufficient Data: The software is unable to determine top and base. This may indicate that there
is insufficient difference between the maximum and minimum for the software to detect a pulse, or there
may be an insufficient number of points in the visible top or base of a pulse, such as when closely
examining a step response.

Underflow Condition: The bottom most (negative) sample point of the waveform falls below the ADC
range. Probably, the bottom of the pulses appear to be cut off.

Overflow Condition: The top most (positive) sample point of the waveform is above the ADC range.
Probably, the top of the pulses appear to be cut off.

Simultaneous Underflow and Overflow Condition: Both conditions are present at once.
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Parameter Math
In addition to measuring waveforms, you can set up a parameter that performs mathematical operations on the
results of other parameters. Parameter math differs from math functions in that the input and the output are still
numerical values that display in the Measure table. Math functions, on the other hand, input and output waveform
traces that appear on the grid.

The setup for parameter math is much like that for other parameters. Some parameters can be qualified on the
Accept subdialog using value ranges or gating waveforms, as can regular waveform measurements. If you have the
Advanced Customization (XDEV) option, there is functionality for applying custom scripts to calculate the results.

Exclusions
The following are not supported by Parameter Math:

l Multiplication and division of parameters that return logarithmic values

l Source parameters that are the result of other parameter math operations

Setting Up Parameter Math

1. From the menu bar, choose Measure > Measure Setup....

2. Choose Measure Mode My Measure and open a parameter setup (Pn) dialog.

3. Touch the Math on Parameters button.

4. Touch Math Operator and choose an operation from the Select Measurement menu.

5. Touch the Source fields and select the parameters that are the inputs to the measurement.

6. Check On to enable the new output parameter and add it to the measurement readout.

Using P Script (Custom Parameter Math)
On instruments installed with the Advanced Customization option (XDEV), you can write your own VBScript or
JavaScript to apply a mathematical operation to one or two input parameters. Choose the Math Operator P Script.
Scripting can be done directly on the instrument in the Script Editor window, or you can import an existing script.

Note: Param Script is a VBScript or JavaScript that performs a measurement on one or two waveforms to
output a parameter. P Script, which is Parameter Math, is a VBScript or JavaScript that inputs one or two
parameter values and performs a math operation on them to output another parameter.

1. Choose Measure > Measure Setup from the menu bar.

2. Touch the Pn tab of the output parameter to display the parameter setup dialog.

3. Touch the Math on Parameters button.

4. Touch Math Operator and choose P Script.

5. Enter the Source input parameter(s).
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6. On the Script Math subdialog, touch Script Language and choose either VBScript or JScript.

7. Touch the Edit Code button to open the Script Editor window.

8. Enter your code in the window, or Import from File an existing script. Click Apply and OK to finish.

Scripts created in this window can be exported to a new file for future use.

104



Math and Measure

Using Web Editor
Whereas with Parameter Math you can apply a single math operation to measurement parameters, the Web Editor
enables you to create processes that chain many operations on multiple inputs, including custom math and
measurements (with the XDEV option), and yield multiple outputs. These processes are integral to the operation of
the instrument; there is no need to export data to other programs.

Processes are "programmed" in the X-Stream application simply by arranging a series of blocks representing
different math functions or measurements and connecting them to form a flow chart—a "processing web." The
terminal parameters and functions represent the final outputs of this process.

Create Processing Web

1. From the menu bar, choose Measure > Measure Setup.

2. On the Measure dialog, choose Measure Mode My Measure.

3. Open the Pn dialog and select Advanced Web Edit.

4. Touch the Show Processing Web button. You will see a "peg board" display with potential input sources
aligned along the left, and a terminal marked with the parameter number to the far right.

5. On the Source Filter subdialog, deselect any types (e.g., zooms) that you do not want to use in the process.
This simplifes the display and reduces the need to scroll.

6. On the Wed Editor dialog, choose the type of process to add to the flow. You can Add Math, Add Measure, or
Add Param Math.
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7. From the pop-up, choose the operation or measurement that will occur at that node. A new block appears on
the display. Drag the block to a location in the flow.

Tip: Touch the location to place a green plus sign before adding the node. Then, the new block will be
created at this spot. Otherwise, blocks may cover one another until moved.

8. The process block will have a input "pin" on the left. If a waveform is required, the pin is blue; if a number is
required, the pin is purple. Touch and drag a matching colored pin from the sources on the left of the screen
to the block. Choose as many sources as there are input pins on the block.

Tip: You may need to use the scrollbar to see all the available sources. For convenience, the Math
and Measure dialogs behind the Web Editor dialog summarize what is currently configured for those
sources.

When you drop the pin, a line is drawn from the source to the process. If a source is incompatible with a
process, you will not be able to pin it.

9. If the process requires additional configuration, a subdialog appears next to the Web Editor dialog. Use it to
enter the values to apply to that processing node.

10. Continue to add processes as needed, pinning the output of each block to the input of the next block in the
flow. The final process should be the same type as the terminal (in this example, a measurement).

Tip: The color of the input/output arrows indicates which connections are compatible.The flow does
not need to be strictly sequential, as many processes can accept inputs that have undergone other
processes. The only requirement is that the outputs are pinned to acceptable inputs.

11. Drag the output pin from the final process block to the input pin on the terminal.
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Preview Outputs
You can add preview "windows" to see the output of a process at any stage in the flow. These previews apply only to
the Web Editor.

Select the output pin of the processing block you wish to preview. It will turn bright green. Then, on the Web Editor
dialog choose Add Preview.

Delete Process/Connection
To delete any process from the web, select the block then touch Delete. All the connections to/from it are
automatically deleted.

To remove a connection between process blocks, touch the line. A scissor icon appears above it. Confirm whether or
not to "cut" the connection.

Add Other Terminals to Processing Web
Other measurements or math functions can share the same processing web. For example, you may wish to create a
math function of the waveform that would result from a sub-processing node, while the final output of the full
process is a measurement parameter.

To add a terminal:

1. Open the Math or Measure dialog behind the Web Editor dialog.

2. Touch the Web Edit icon following the location (Pn or Fn). The summary changes to Web Edit, and a new
terminal block appears on the Web Editor peg board.

3. Connect the output pin of the desired process to the input pin of the terminal. You can select outputs that are
already pinned to other blocks.

Exit Web Editor
When your processing web is complete, close the Web Editor dialog or choose Scope Display from the Display
menu. The screen will resume the regular oscilloscope display.
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Using Histograms
Histograms display the statistical distribution of parameter values using bars of varying heights to represent
measurement frequency. The Histogram math function plots the number of parameter measurements that fall
within a small range, known as a bin, as a function of the parameter value. Each bin is represented by a bar on the
chart. The histogram can use from 20 to 5000 bins, each representing a consecutive sub-range of measured values,
and it can hold up to two billion measured values.

The Phistogram function creates a histogram of parameter values falling within a vertical or horizontal "slice" of a
persistence map (the trace created when Persistence display is turned on during acquisition).

The Histogram function descriptor box shows: the number of values represented by each
vertical grid division of the histogram bars (#/div), the bin width represented by each bar of the
histogram (vertical or horizontal units/div), and the total number of values computed in the
histogram (#).

Thumbnail versions of parameter histograms are called Histicons. They are available as a checkbox option on the
Measure dialog. Histicons appear on the Measure table, rather than as a new math trace, although they can be
converted to a regular histogram function simply by touching them.

Uses of Histograms
Histograms show the distribution and probability density of waveform parameter values over multiple acquisitions.
They are especially useful for visualizing and quantifying random processes, such as jitter. Comparing the total
populations of each bin of the histogram can help quantify rarely occurring events that might otherwise be
overlooked, one advantage of the statistical study of measured data. Example applications of histograms include:

l Characterizing DDR read/write timing limits
l Examing systemic and random variations that produce jitter and time interval error
l Measuring rise time, setup / hold time, and propagation delay of electronic devices
l Detecting and diagnosing circuit problems, such as crossover distortion

The shape of the histogram yields immediate information about the parameter being measured:

Gaussian/Unimodal histograms have one peak near the center of the distribution with roughly equilateral roll off on
each side. The Gaussian distribution is a good indication that a random process is shaping variations in the
measurement, such as the effect of random jitter on a pulse measurement.

Bimodal histograms have two, distinct peaks in the distribution at the outer edges, indicative of steady-state high
and low values.

Uniform/Symmetric histograms look rectangular, indicating a wide distribution of values.

Skewed histograms show a peak at either the negative or positive edge of the measurement range, with a steady roll
off toward the other side.

Because the shape of histogram distributions is particularly interesting, additional histogram measurements are
available for analyzing these distributions. They are generally centered on one of several peak value bins. You will
find the histogram measurements in the Statistics sub-menu of the Measure Selector.
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Histogram Calculation
Histograms are calculated on the portion of the waveform within the acquisition window and the measurement
gates, just as are the parameters. Likewise, histogram measurements are limited to the bars of the histogram that
are visible on the grid and that fall within the measurement gates.

In Sequence sampling mode, one acquisition for each segment occurs prior to parameter calculations, and a sweep
is equivalent to acquisitions for all segments (for non-segmented waveforms, an acquisition is identical to a sweep).
If a single segment of a sequence-mode acquisition is selected for viewing, histograms will be recalculated for only
the measurements on that segment.

Measurements calculated once per acquisition (Amplitude, Area, Base, Cycles, Delay, Delta Delay, Duration, First,
Last, Maximum, Mean, Median, Minimum, Nb Phase, Nb Power, Overshoot+, Overshoot-, Peak-Peak, Phase, Points,
RMS, Std Dev., etc.) will not produce characteristic histogram distributions, unless you allow sweeps to accumulate.

Plotting Histograms

1. Open the parameter setup dialog (Pn) for the parameter you wish to histogram.

Tip: A quick way to do this is to touch the Measure table Pn cell.

2. Touch the Histogram action button at the bottom of the Pn dialog and choose the function (Fn) in which to
draw the histogram.

3. Touch the new hist descriptor box to display the Fn dialog, then open the Histogram subdialog and define the
histogram Buffer and Scaling.

Pressing Clear Sweeps at any time resets the measurement counter and restarts the histogram.

Histogram Buffer
Enter the maximum #Values in one bin of the histogram. This determines the total number of measurements that
are represented by a bar at full height. Once this number is reached, the histogram will be rescaled according to the
Vertical Scale method selected, as it continues to accumulate data.

Histograms are dynamically computed using the last N measurements in the parameter buffer, up to two billion. If
#Values is modified, the histogram is redrawn using the last N events required.

If the parameter source is a memory, storing new data to memory effectively acts as an acquisition trigger/sweep
and updates the parameter buffer and the histogram.
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Histogram Scaling
Bins
First, enter the total #Bins that comprise the histogram. This determines how many bars appear in the histogram.
Histogram peak bin values are useful because they indicate the dominant values of a parameter, but using a too high
number of bins can yield a spiky histogram, making meaningful peaks hard to distinguish. An optimal bin number is
one where the change in bin value is insignificant, and the histogram distribution does not have a jagged
appearance.

l For Vertical (amplitude) parameters, the default value of 100 is a good number .

l For Horizontal (timing) parameters, it is safe to use up to the maximum number of bins.

The instrument analyzes histogram data to identify peaks from background noise and histogram definition artifacts
such as small gaps, which are due to very narrow bins.

Histogram bins represent a sub-range of parameter measurements, and measurements within a bin may have a
value anywhere within that sub-range. However, measurements of the histogram itself assume that all
measurements in a bin have a single value. The instrument uses the center value of each bin in all its histogram
measurements. The greater the number of bins used to subdivide a histogram’s range, the less the potential
deviation between actual center values and the values used in histogram measurements. However, more bins may
require a greater number of sweeps to populate the bins sufficiently to yield a characteristic histogram distribution.

Center and Width
How parameter values are distributed into the bins is determined by the Center and Width values.

The Center is the center value of the measurement range represented by the histogram. This will generally be a value
near the expected peak value, or a center bar in a symmetric histogram. Examine the mean value of the parameter
you wish to histogram to determine a good value to place at center.

The Width is the measurement interval represented by each bin of the histogram, which is counted in vertical
units/div for Vertical parameters, or horizontal units/div for Horizontal parameters. If Width is 500 ns, a Horizontal
measurement between 0 (center) and 500 ns falls into the first positive bin, and one between 0 and -500 ns falls into
the first negative bin, and so forth. The more bins that are in the histogram, the smaller the Width should be to
ensure that values will distribute across the histogram, showing a meaningful deviation from center.

The instrument's range finding function, Find Center and Width, can be used to calculate an optimal range and
redraw the histogram using it. The instrument gives a running count of where values fall relative to the range on the
Histogram function subdialog, and if any fall above or below it, the range finder can recalculate the histogram using
those values while still in the buffer. First check Enable Auto Find to use this feature.

Vertical Scale
Histograms build vertically as data accumulates over multiple acquisitions. It is possible that, after a sufficient
number of sweeps, the peak bars of a histogram will reach the grid maximum, causing an overflow condition, and
the histogram must be rescaled to accurately reflect the distribution. Choose a Vertical Scale method by which to
handle situations where the histogram buffer is full:

l Linear rescales the number of values represented by each vertical division as the histogram reaches the top of
the grid. The histogram will appear to shrink then grow again as more data is accumulated, until another
rescaling of the values/div is required.

l LinConstMax keeps the histogram at near full scale when it reaches the top of the grid, but changes the
numbers on the vertical axis as more data is accumulated.
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Using Trends
The Trend math function plots a waveform composed of parameter measurements arranged in the order the
measurements were made. The vertical units are the source parameter values, and the horizontal unit is the
measurement number. The Trend contains a single value for each unique measurement, and therefore may not be
time synchronous with the source waveform, where the same measured value may occur successively over time.

Uses of Trends
Trends are especially useful for visualizing the history of a parameter over an extended period of time or over
multiple acquisitions. Think of Trend as a strip chart recorder for your instrument. Example applications of Trend
include:

l Data logging multiple circuit parameters

l Power line monitoring

l Measuring output regulation and ripple

l Characterizing the dynamic tracking response of PLL-based circuits

l Locating clock jitter anomalies

Plotting Trends
Although a Trend plots parameter values, it is created as a Math function on the Function (Fn) dialogs.

1. Open the parameter setup (Pn) dialog for the measurement you wish to trend. A quick way to do this is to
touch the Measure table cell.

2. Touch the Trend button at the bottom of the Pn dialog, then choose the function (Fn) in which to draw the
plot. The Trend opens in a new grid along with its function descriptor box.

3. Touch the new Trend descriptor box to display the Fn dialog, then open the Trend subdialog.

4. Choose a computation Mode of All (measurements per acquisition) or Average (one measurement per
acquisition).

5. Enter the number of measured Values to Trend.
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Using Tracks
A Track is a waveform composed of parameter measurements that are time synchronous with the source
waveform. The vertical units are those of the source parameter and the horizontal units are seconds. Due to the time
synchronization, the number of points in the Track function is identical to the number of samples in the source
waveform, and a Track is limited to the samples in a single acquisition. The Track may contain many redundant
values.

Uses of Tracks
In general, Track is the tool to use if you want to capture a continuous stream of data spaced closely together. It is
also useful in applications that require time synchronization, or for locating anomalous parameter values in a long
acquisition. Example applications of Track include:

l Modulation analysis of PWM signals

l Measuring phase error in PLLs

l Measuring settling time of waveforms with decaying amplitudes

l Radar measurements to characterize PRI stagger during walkoff

Plotting Tracks
Although a Track plots parameter values, it is created as a Math function and controlled on the Function (Fn) dialogs.

1. Open the parameter setup (Pn) dialog for the measurement you wish to track. A quick way to do this is to
touch the Measure table cell.

2. Touch the Track toolbar button at the bottom of the Pn dialog and choose the function (Fn) in which to draw
the plot.

3. Touch the new Track descriptor box to display the Fn dialog, then open the Track subdialog.

4. On the Track subdialog, choose a method to Connect the points in the track into a waveform: Interpolate
points between samples, or Extend the line directly point to point.
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Track vs. Trend
The table below summarizes the differences between Track and Trend.

Track
(Parameter value vs. time)

Trend
(Parameter value vs. event)

Cumulative? No, resets after every acquisition Cumulative over unlimited number of
acquisitions, up to two billion events

Time correlates to other data? Yes No

Monitors Frequency domain? Yes No, points are not evenly spaced in time and
therefore cannot be used for an FFT

Monitors parameters over
multiple acquisitions?

No, resets after every acquisition Yes

Preserves all measurement
data?

Yes, although maximum time period that can
be captured is limited by acquisition memory
and sampling rate

No, data can be missed during time
oscilloscope takes to re-arm between
acquisitions

EMC Pulse Parameter Software Package
The EMC option enhances the oscilloscope's Measure functionality with features designed to ignore undershoot,
overshoot, or tail perturbations while measuring rise time, fall time, or width characteristics according to specific
EMC/ESD standards.

At Level Parameters
For the parameters Rise@Level, Fall@Level, Width@Level, Time@Level, and dTime@level, in addition to setting the
crossing threshold level using the absolute voltage or percentage of amplitude based on the computed Top and
Base lines, you may set the level using:

l actual Peak to Peak

l 0V - Max

l 0V - Min

Once the option is activated, the new selections are added to the Level pop-up menu. Otherwise, parameters are
configured exactly the same as before.

EMC Parameters
Two parameters designed for EMC measurements are added to the IEC-EMC submenu of the Measure Selector:

l EMClvlPulse—EMC Level After Pulse enables you to measure the signal level following the specified pulse
transition, omitting earlier portions of the signal.

l EMCt2Val—EMC Time to Half Value computes time between interpolated time at 0% on rising edge and
crossing time at middle level on falling edge. The interpolated time at 0% is obtained by linear extrapolation
using the low crossing and high crossing thresholds.
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Math
Math function traces (Fn) display the result of applying a mathematical operation to a source trace. The output of a
math function is always another trace, whereas the output of a measurement parameter is a tabular readout of the
measurement.

Math can be applied to any channel (Cn), zoom (Zn), or memory (Mn) trace. It can even be applied to another math
trace, allowing you to chain operations (for example, trace F1 can show the average of C1, while trace F2 provides
the integral of F1).

On instruments equipped with CustomDSO (XDEV), custom scripts may be used to define a math function. Several
scripting "languages" are supported, depending on the application. You can find these options in the Custom
submenu of the Math Selector. Scripts may be imported or written in the instrument's Script Editor window and
saved for future use. See Using P Script for a description of the process.

In addition to the extensive math capabilities that are standard with every instrument, enhanced math analysis tools
customized for various industries and applications are offered through optional software packages. To learn about
math tools available in each optional package, see the product datasheets at teledynelecroy.com.

If you have installed software options, the new capabilities are usually accessed through the Analysis menu, rather
than the Math menu, although special math functions will be available when using the standard Math dialogs.

Math Function Set Up
Use the Function dialog to set up math function traces. Math functions take as input one or more channel, zoom,
memory or math traces and output a new math trace (Fn). Any additional settings required for the operator will
appear on a subdialog at the right of the screen.

Single functions perform one operation on one or two input sources.

Dual functions chain two operations to arrive at a single result. This saves you the effort of having to chain two
separate math functions. As with single functions, the number of sources required will vary based on the operation.
You may need only one source for Operator1, but two for Operator2 (the result of the first operation counts as one
source).

Note: On acquisitions >500 Mpts in length, math functions are calculated on only the center 500 Mpts of the
acquisition. See Navigating Long Acquisitions for information on positioning the region you want calculated
in this zone.

Setting Up New Functions

1. From the menu bar choose Math > Math Setup, then open one of the Fn tabs.

Tip: You can select Fn Setup right from the Math menu.

2. Choose a single f(x) or dual g(f(x) operator function.
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You can also choose Web Edit, in which case this function is added as a terminal to the processing web. See
the instructions for Using Wed Edit to set up the function.

3. In Operator1, choose the math operation to perform.

Note: On instruments with the Advanced Customization (XDEV) option, the Operator can be a
custom script written in one of several scripting "languages." Choose from the Custom submenu and
import or write the script in the Script Editor. See Using PScript for a description of the process.

4. The choice of operator drives the number of Source fields you will see displayed. Make a selection in each
field, or drag the source channel descriptor box to the field.

A Summary of the function you are building appears on the dialog. Refer to this to be sure your sources are in
the proper order to yield the function you want (e.g., C1-C2 vs. C2-C1).

5. If the operator you've selected has any other configurable settings, you'll see a subdialog of the same name
as the operator. Touch the tab to open the dialog and make any further settings. These are explained on the
dialog.

6. If you're creating a dual function, repeat the procedure for the second operator.

7. Check Trace On to display the new math trace.

Following acquisition, you should see a new math waveform appear on the oscilloscope display. Drag-and-drop the
Fn descriptor box to move it to the desired grid.

Note: If there is a processing error (e.g., overflow) when calculating a math function, a small letter "i" inside a
bubble will appear on the Fn descriptor box to indicate there is more information regarding the waveform
status. See Finding Waveform Status for instructions on finding the error.

Graphing
The Graph button on the Function (Fn) dialogs allows you to choose a parameter to plot as a histogram, track, or
trend.

Tip: The plots are the same as those created using the toolbar on the Parameter (Pn) dialog.

As with other math functions, configurable settings will appear on subdialogs after the plot is selected.

Adjusting Memory or Math Traces
Unlike channel traces, the scale of memory (Mn) or math function (Fn) traces can be adjusted directly without having
to create a separate zoom trace. The same set of zoom factor controls used for zoom traces appear on the Zoom
subdialog, but in this context they only rescale the active math or memory trace rather than create a new zoom. This
applies to any trace that is created as a math function (Fn) trace, including traces generated through analysis
options and graphs.

You can, if you wish, create a separate zoom trace from a memory or function trace the same as you would normally
create a zoom (draw a selection box, etc.). In this case, you choose one of the zoom locations (Zn) in which to draw
the trace, but the source trace remains at the original scale.
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Math Dialog
Once a math function has been created and saved on the Function (Fn) dialog, use the main Math dialog to quickly
enable/disable it. You can also use this dialog to quickly turn on/off zoom traces.

To open the Math dialogs, from the menu bar choose Math > Math Setup. Select the On checkbox next to each
function you wish to display.

To change the function, touch the Fn button.

To erase all functions from their locations, touch Reset All.

To restart the counter on cumulative functions (like Average), touch Clear Sweeps.

List of Standard Math Operators

Note: The installation of software options on the oscilloscope may add math operators to this list.

Standard Operators
Absolute - Calculates distance away from zero for every point in the waveform. For values greater than zero, this is
the same as the value. For values less than zero, the magnitude without regard to its sign is used.

Average - Calculates either a summed or continuous average of a selected number of sweeps. See Averaging
Waveforms. The maximum number of sweeps is determined by the oscilloscope model and memory.

Copy - Copies waveform in its unprocessed state to the first available memory location.

Correlation - Calculates a measure of similarity of two waveforms, or a waveform against itself, as a function of a
time-lag applied to one of them.

Derivative - Calculates the derivative of adjacent samples using the formula:
(next sample value – current sample value) / (horizontal sample interval)

Deskew - Shifts trace in time the amount of the deskew factor.

Difference - For every point in the waveform, subtracts the value of Source2 from the value of Source1. Source1 and
Source2 must have the same horizontal and vertical units and scale.

Envelope - Calculates highest and lowest vertical values of a waveform at each horizontal value for a specified
number of sweeps.

ERes - Applies a noise reduction and smoothing filter by adding a specified number of bits. See Enhanced
Resolution.

Exp - Calculates the antilog to the base e of the source; that is, e raised to the power equal to the source.

Exp10 - Same as Exp, using base 10.
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FFT - Computes a frequency spectrum with optional Rectangular, Von Hann, Flat Topp, Hamming, Blackman-Harris,
and Hanning windows. Allows FFT Averaging through use of a second math operator. See FFT.

Floor - Calculates the lowest vertical values of a waveform at each horizontal value for a specified number of
sweeps.

Histogram - Plots the number of data points that fall into statistically significant intervals or bins. Bar height relates
to the frequency at which data points fall into each interval/bin.

Integral - Calculates the linearly rescaled integral (with multiplier and adder) of a waveform input starting from the
left edge of the screen using the formula: (current sample value + next sample value) * (horizontal sample interval).
Each calculated area is summed with the previous sum of areas. The multiplier and adder are applied before the
integration function.

Interpolate - Inserts points between sampled points (upsamples) according to one of three algorithms: Linear
(straight line), Sinx/x (curved), and Cubic (spine). The Interpolation Factor determines the number of points in the
upsample.

Invert - For every point in the waveform, the inverse of that point is calculated.

Ln - Peforms a natural log of a waveform. Values less than or equal to zero are set to underflow.

Log10 - Performs a log base 10 of a waveform. Values less than or equal to zero are set to underflow.

Phistogram - Creates a histogram based on the displayed pixels of a persistence map falling within a user-defined
vertical and/or horizontal box (slice). The source trace must have Persistence turned "on."

Product - For every point in the waveform, the value of Source1 is multiplied by the value of Source 2. Source1 and
Source2 must have the same horizontal units and scale.

Ptrace mean - Plots the mean value of each sample point in a persistence map. The source trace must have
Persistence turned "on."

Ptrace range - Generates a waveform with a width derived from the population range of a persistence map. The
source trace must have Persistence turned "on."

Ptrace sigma - Generates a waveform with a width derived from the sigma (sum) of a persistence map. The source
trace must have Persistence turned "on."

Ratio - For every point in the waveform, divides the value of Source1 by the value of Source2. Source1 and Source2
must have the same horizontal units and scale.

Reciprocal - For every point in the waveform, calculates the inverse using the formula: 1 / (sample value).

Rescale - For every point in the waveform, multiplies the sample value by the specified Multiplier, then adds the
specified Additive Constant value. See Rescaling and Assigning Units.

Roof - Calculates the highest vertical value at each sample point for a specified number of sweeps.

Segment - Selects one segment [#] from a segmented waveform and copies it into the function, enabling it to be
rescaled independent of the source trace.

Sparse - “Thins" (decimates) an incoming acquisition by dropping sample points at regular intervals. Sparsing Factor
specifies the Nth sample point in sequence to retain (e.g., factor of 4 drops 3 points and retains the 4th). Sparsing
Offset specifies the point at which to begin the sparsing count (e.g., offset of 3 begins count on the 3rd sample
point).

Square - For every point in the waveform, calculates the square of the sample value.
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Square Root - For every point in the waveform, calculates the square root of the sample value.

Sum - For every point in the waveform, adds the value of Source1 to the value of Source 2. Source1 and Source2
must have the same horizontal and vertical units and scale.

Track - Generates a waveform composed of measurement parameter values that are time synchronous with the
source waveform. The vertical units are those of the source parameter value; the horizontal units are seconds.
Values are posted at the sampling rate.

Trend - Produces a waveform composed of a series of measurement parameter values in the order the
measurements were taken. The vertical units are those of the source parameter; the horizontal unit is measurement
number. The trend contains a single value for each unique measurement.

Zoom - Produces a magnified trace of a selected portion of the input waveform. See Zooming Traces.

Custom Math Operators
These "operators" enable you to insert a custom script into the oscilloscope process and view the resulting
waveform in real time.

Excel math - Custom math performed in Excel. The operator will transfer one or two waveforms (as a series of time-
value pairs) into an Excel spreadsheet and display the resulting waveform.

Fast Wave Port - Provides memory mapped C++ file access for custom math calculations. 

Math script - Visual Basic or Java script that produces a waveform from one or two input waveforms.

Mathcad math - Produces a waveform using a custom Mathcad function.

MATLAB math - Produces a waveform using a custom MATLAB function. You may write a MATLAB script on the
oscilloscope, or call a pre-existing MATLAB function into a script. MATLAB can run locally on the oscilloscope, or
remotely on a host that is accessible to the oscilloscope. See the MAUI Oscilloscopes Remote Control and
Automation Manual for instructions on connecting to MATLAB remotely.
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Average Function
The summed or continuous average of all data samples from multiple acquisitions can be displayed as a new
waveform trace using the Average function.

Setting Up Averaging
To apply Continuous or Summed Averaging as a Math function:

1. Follow the usual steps to set up a math fuction, selecting Average from the Basic Math submenu.

2. On the Average subdialog, choose Summed or Continuous.

3. Touch Sweeps and provide a value.

Tip: To quickly set up Continuous Averaging (only), access the channel setup dialog (Cn) and enter the
number of sweeps to average in Averaging.

Summed Averaging
Summed Averaging is the repeated addition, with equal weight, of successive source waveform records. If a stable
trigger is available, the resulting average has a random noise component lower than that of a single-shot record.
Whenever the maximum number of sweeps is reached, the averaging process stops. In Summed averaging, you
specify the number of acquisitions to be averaged. The averaged data is updated at regular intervals.

An even larger number of records can be accumulated simply by changing the number in the dialog. However, the
other parameters must be left unchanged or a new averaging calculation will be started. You can pause the
averaging by changing the trigger mode from Normal/Autoto Stop. The instrument resumes averaging when you
change the trigger mode back to Normal/Auto.

You can reset the accumulated average by pushing the Clear Sweeps button or by changing an acquisition
parameter such as input gain, offset, coupling, trigger condition, timebase, or bandwidth limit. The number of current
averaged waveforms of the function, or its zoom, is shown in the acquisition status dialog. When summed averaging
is performed, the display is updated at a reduced rate to increase the averaging speed (points and events per
second).

Continuous Averaging
Continuous Averaging, the default setting, is the repeated addition, with unequal weight, of successive source
waveforms. It is particularly useful for reducing noise on signals that drift very slowly in time or amplitude. The most
recently acquired waveform has more weight than all the previously acquired ones: the continuous average is
dominated by the statistical fluctuations of the most recently acquired waveform. The weight of ‘old' waveforms in
the continuous average tends to zero (following an exponential rule) at a rate that decreases as the weight
increases.

You determine the importance of new data vs. old data by assigning a weighting factor. The formula for continuous
averaging is:

new average = (new data + weight * old average)/(weight + 1)
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By setting a Sweeps value, you establish a fixed weight that is assigned to the old average once the number of
sweeps is reached. For example, for a sweeps (weight) value of 4:

Sweep New Average =

1 (no old average yet) (new data +0 * old average)/(0 + 1) = new data only
2 (new data + 1*old average)/(1 + 1) = 1/2 new data +1/2 old average
3 (new data + 2 * old average)/(2 + 1) = 1/3 new data + 2/3 old average
4 (new data + 3 * old average)/(3 + 1) = 1/4 new data + 3/4 old average
5 (new data + 4 * old average)/(4 + 1) = 1/5 new data + 4/5 old average
6 (new data + 4 * old average)/(4 + 1) = 1/5 new data + 4/5 old average
7 (new data + 4 * old average)/(4 + 1) = 1/5 new data + 4/5 old average

Note: The number of sweeps used to compute the average is displayed at the bottom of the trace descriptor
box.

Copy Function
The Copy math function saves a copy of your present waveform in its unprocessed state to the first available
memory location. The memory enables faster throughput, in some cases, by preserving the original data, while math
and measure processing continues on the original waveform. This benefit of faster throughput, however, comes at
the expense of memory usage.

Follow the ususal steps to set up a math function, selecting Copy from the Misc submenu.

On the Wform Copy subdialog, optionally Reset Count or Change BatchSize.
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ERes Function
ERes (Enhanced Resolution) filtering increases vertical resolution, allowing you to distinguish closely spaced voltage
levels. The instrument's ERes function is similar to smoothing the signal with a simple, moving-average filter, but is
more efficient concerning bandwidth and pass-band filtering. Use ERes:

l On single acquisitions or where the data is slowly repetitive (and you cannot use averaging).

l To reduce noise on noticeably noisy signals when you do not need to perform noise measurements.

l As a low-pass filter. The ERes filter rejects high-frequency components from the signal. The higher the bit
enhancement, the lower the resulting bandwidth.

l When performing high-precision voltage measurements (e.g., zooming with high vertical gain).

Setting Up ERes
To apply ERes as a Math function:

1. Follow the usual steps to set up a math function, selecting Eres from the Filter submenu.

2. Touch the Trace On checkbox.

3. On the Eres subdialog, select the number of bits of improvement from the pop-up menu.

How ERes Is Applied
The instrument's ERes feature improves vertical resolution by a fixed amount for each filter. This real increase in
resolution occurs whether or not the signal is noisy, or whether it is single-shot or repetitive. The signal-to-noise ratio
(SNR) improvement depends on the form of the noise in the original signal. ERes filtering decreases the bandwidth
of the signal, filtering out some of the noise.

The instrument's constant phase finite impulse response (FIR) filters provide fast computation, excellent step
response in 0.5 bit steps, and minimum bandwidth reduction for resolution improvements of between 0.5 and 3 bits.
Each step corresponds to a bandwidth reduction factor of two, allowing easy control of the bandwidth resolution
trade-off.

Resolution Increase -3 dB Bandwidth (x Nyquist) Filter Length (Samples)

0.5 0.5 2
1.0 0.241 5
1.5 0.121 10
2.0 0.058 24
2.5 0.029 51
3.0 0.016 117

With low-pass filters, the actual SNR increase obtained in any particular situation depends on the power spectral
density of the noise on the signal.

The improvement in SNR corresponds to the improvement in resolution if the noise in the signal is white (evenly
distributed across the frequency spectrum). If the noise power is biased towards high frequencies, the SNR
improvement will be better than the resolution improvement.

The opposite may be true if the noise is mostly at lower frequencies. SNR improvement due to the removal of
coherent noise signals—feed-through of clock signals, for example—is determined by the fall of the dominant
frequency components of the signal in the passband. This is easily ascertained using spectral analysis. The filters
have a precisely constant zero-phase response. This has two benefits. First, the filters do not distort the relative
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position of different events in the waveform, even if the events' frequency content is different. Second, because the
waveforms are stored, the delay normally associated with filtering (between the input and output waveforms) can be
exactly compensated during the computation of the filtered waveform.

The filters have been given exact unity gain at low frequency. ERes should therefore not cause overflow if the source
data is not overflowed. If part of the source trace were to overflow, filtering would be allowed, but the results in the
vicinity of the overflowed data—the filter impulse response length—would be incorrect. This is because in some
circumstances an overflow may be a spike of only one or two samples, and the energy in this spike may not be
enough to significantly affect the results. It would then be undesirable to disallow the whole trace.

Note: While ERes improves the resolution of a trace, it cannot improve the accuracy or linearity of the
original quantization. The pass-band causes signal attenuation for signals near the cut-off frequency. The
highest frequencies passed may be slightly attenuated. Perform the filtering on finite record lengths. Data is
lost at the start and end of the waveform and the trace ends up slightly shorter after filtering. The number of
samples lost is exactly equal to the length of the impulse response of the filter used: between 2 and 117
samples. Normally this loss (just 0.2 % of a 50,000 point trace) is not noticed. However, you might filter a
record so short that no data is output. In that case, however, the instrument would not allow you to use the
ERes feature.
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FFT Function
For a large class of signals, you can gain greater insight by looking at spectral representation rather than time
description. Signals encountered in the frequency response of amplifiers, oscillator phase noise and mechanical
vibration analysis, for example, are easier to observe in the frequency domain.

If sampling is done at a rate fast enough to faithfully approximate the original waveform (usually five times the
highest frequency component in the signal), the resulting discrete data series will uniquely describe the analog
signal. This is of particular value when dealing with transient signals, which conventional swept spectrum analyzers
cannot handle.

While FFT has become a popular analysis tool, some care must be taken with it. In most instances, incorrect
positioning of the signal within the display grid will significantly alter the spectrum, producing effects such as
leakage and aliasing that distort the spectrum. An effective way to reduce these effects is to maximize the
acquisition record length. Record length directly controls the effective sampling rate and therefore determines the
frequency resolution and span at which spectral analysis can be carried out.

Setting Up FFT

1. Follow the usual steps to set up a math function, selecting FFT from the Frequency Analysis submenu.

2. Open the FFT subdialog.

3. Choose an Output type.

4. If your Output Type is Power Density or Power Spectrum, also enter Line Impedence. By default, the FFT
function assumes a termination of 50 Ohms. If an external terminator is being used, this setting can be
changed to properly calculate the FFT based on the new termination value.

5. Optionally, choose a weighting Window (see below).

6. Check the Suppress DC box to make the DC bin go to zero. Otherwise, leave it unchecked.

Choosing a Window
If you think of an FFT as synthesizing a bank of parallel band-pass filters, weighting functions control the filter
response shape and affect noise bandwidth as well as side lobe levels. The window type defines the bandwidth and
shape of the equivalent filter to be used in the FFT processing.

The choice of window is dictated by the signal's characteristics. Rectangular windows provide the highest frequency
resolution and are useful for estimating the type of harmonics present in the signal. Because the rectangular window
decays as a (SinX)/X function in the spectral domain, slight attenuation will be induced. Functions with less
attenuation (Flat Top and Blackman-Harris) provide maximum amplitude at the expense of frequency resolution,
whereas Hamming and Von Hann are good for general purpose use with continuous waveforms.

Window Type Applications and Limitations

Rectangular Normally used when the signal is transient (completely contained in the time-domain window) or
known to have a fundamental frequency component that is an integer multiple of the fundamental
frequency of the window. Signals other than these types will show varying amounts of spectral leak-
age and scallop loss, which can be corrected by selecting another type of window.

Hanning (Von Hann) &
Hamming

Reduces leakage and improves amplitude accuracy. However, frequency resolution is also reduced.

Flat Top Provides excellent amplitude accuracy with moderate reduction of leakage, but with reduced fre-
quency resolution.

Blackman-Harris Reduces leakage to a minimum, but with reduced frequency resolution.
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FFT Window Filter Parameters

Window Type Highest Side Lobe
(dB) Scallop Loss (dB) ENBW (bins) Coherent Gain (dB)

Rectangular -13 3.92 1.0 0.0
Von Hann -32 1.42 1.5 -6.02
Hamming -43 1.78 1.37 -5.35
Flat Top -44 0.01 3.43 -11.05
Blackman-Harris -67 1.13 1.71 -7.53

Interpolate Function
The Interpolate operator enables you to generate a trace that interpolates data points into the source trace
according to your selected method and upsampling factor.

Linear interpolation, which inserts a straight line between sample points, is best used to reconstruct straight-edged
signals such as square waves. This is the default interpolation method used by the oscilloscope.

(SinX)/X interpolation, on the other hand, is suitable for reconstructing curved or irregular waveshapes, especially
when the sampling rate is 3 to 5 times the system bandwidth.

Cubic interpolation can be used to create a smooth, continuous function by applying a third-degree polynomial.

For each method, you can select an upsample factor of 2 to 50 points to insert between samples.

1. Follow the usual steps to set up a math function, selecting Interpolate from the Filter submenu.

2. Select an interpolation method.

3. Enter the Upsample by number of points.

Tip: You can use the Up and Down buttons to set this value. To make single increment changes,
deselect the "Only by 2, 5..." checkbox.

4. In Half Width enter the width in taps of the filter.

5. To use a weighting function rather than an upsample factor, select it from Weighting. See FFT for more
information about these functions. If using the Kaiser function, also enter the Beta value.
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Phistogram Function
The Phistogram Math function creates a histogram of the samples within a vertical or horizontal "slice" of a
persistence map to reveal the features that are only visible when several acquisitions have been superimposed on
one another. Vertically, each bin contains a class of similar amplitude levels; horizontally, each bin contains a class
of similar time values.

The source trace must have Persistence "on" to generate the persistence map. Eye diagrams, which are a type of
persistence map, are a an especially useful class of traces to which you can apply the Phistogram function.

1. Follow the usual steps to set up a math function, choosing a Single operator function using the Phistogram
operator.

2. On the Phistogram subdialog, choose the slice of the persistence map to histogram:

l Slice Direction determines whether the slice transverses an entire vertical level of the map across time
(horizontal), or a time on in the map across vertical values (vertical).

For a histogram of... Use...

A crossover point in time or amplitude on an eye dia-
gram *

Vertical and horizontal slice persistence histogram

Cumulative jitter on an eye diagram * Horizontal slice persistence histogram
Signal-to-noise ratio on an eye diagram * Vertical slice persistence histogram

* Requires optional software package capable of creating eye diagrams, such as SDAIII or Serial Decoder TDME software.

l Slice Center represents the center level or time of the slice.

l Slice Width represents the total amplitude or total time of the slice, half each side of the center. This
setting will deepen or widen the total area of the slice of values to be plotted on the histogram. If Help
Markers are on, you will see the change in the blue bar representing the slice.

Note: This selection does not affect Center and Width settings made on any existing
histograms.

3. Choose Center Cursor to place a measurement cursor at the center of the slice.
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Ptrace Functions
The Ptrace Mean, Ptrace Range, and Ptrace Sigma math functions (found in the Jitter Functions sub-menu of the
Math Operator selector) compute a vector trace based on a persistence map of underlying signal acquisitions
without destroying the underlying raw data. Signals sampled at or above 2 GS/s that have accumulated in the
persistence map can be traced at a resolution of 10 ps (100 GS/s equivalent sampling). Further measurements or
Pass/Fail testing can be performed on the resulting math traces.

The source trace must have Persistence "on" to generate the persistence map used by each of these functions.

Ptrace Mean
The Ptrace Mean trace helps to see edge detail in a fast signal, or to eliminate noise on a persistence map.

For each time slice of the persistence map, Ptrace Mean calculates and plots a trace corresponding to the mean
vertical value. The Ptrace Mean can be further analyzed using the instrument’s standard parameters, such as rise
time. Optionally, choose to limit the Num(ber of) Points plotted.

Ptrace Range
The Ptrace Range trace helps to assess typical noise on a persistence map.

For each time slice on the persistence map, Ptrace Range calculates and plots an envelope corresponding to the
range of vertical values.

Enter the % population range, the percentage of the population of the persistence map that forms the envelope,
enabling exclusion of infrequent events (artifacts). Optionally, choose to limit the Num(ber of) Points plotted.

Ptrace Sigma
The Ptrace Sigma trace helps to assess worst case noise on a persistence map. It can be used to create a tolerance
mask for Pass/Fail testing.

For each time slice on the persistence map, Ptrace Sigma calculates and plots an envelope corresponding to the
standard deviation of vertical values.

The envelope can be scaled to a specified sigma. Enter the Scale to standard deviations. This allows you to select a
sigma from 0.5 to 10.0 to define the envelope of values plotted. Optionally, choose to limit the Num(ber of) Points
plotted.
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Rescale Function
The Rescale function allows you to create a new function trace that rescales another trace by applying a
multiplication factor (a) and additive constant (b). You can also use it as a way to view the function source in a
different unit of measure.

Tip: Channel and sensor traces may be rescaled directly using the Cn and SEn dialogs.

Setting Up Rescaling

1. Follow the usual steps to set up a math function, selecting Rescale from the Functions submenu.

2. Touch the Rescale subdialog tab.

3. To modify the scale of output:

l Check the First multiply by: box and enter the number of units equal to 1 V (a, the multiplication factor).

l Touch then add: and enter b, the additive constant.

4. To change the output unit of measure from that of the source waveform:

l Check Override units.

l In Output enter the code for the new unit of measure.

You can combine units following these rules:

l For the quotient of two units, use the character "/"

l For the product of two units, use the character "."

l For exponents, append the digit to the unit without a space (e.g., "S2" for seconds squared)

Note: Some complex units are automatically converted to simple units. For example, V.A is W).

Units of Measure
Units are automatically rescaled up or down within the list of standard, SI prefixes based on the relative size of the
signal. For example a 1000 V reading is shown as 1 kV, while .1 V is shown as 100 mV. When the multiplication
factor is 1 V = 1 Pascal, a 10 millivolt (mV) reading is displayed as 10 mPa rather than .001 Pa or 100e-3 Pa.

Following are the supported SI units of measure and the mnemonics used to represent them on the Rescale dialog.

Note: These same mnemonics can be used in remote control programs and customization scripts. Specify
only the base unit in code, do not add prefixes.

Note: Time and dimensionless units are available only for certain measurements and for use in code where
relevant.

Category Unit Mnemonic

Mass gram G
slug SLUG

127



WaveMaster 8000HD Oscilloscopes Operator's Manual

Category Unit Mnemonic

Volume liter L
cubic meter M3
cubic inch IN3
cubic foot FT3
cubic yard YARD3

Angle radian RAD
arcdegree DEG
arcminute MNT
arcsecond SEC
cycle CYCLE
revolution REV
turn TURN

Force/Weight Newton N
grain GR
ounce OZ
pound LB

Velocity meters/second M/S
inches/second IN/S
feet/second FT/S
yards/second YARD/S
miles/second MILE/S

Acceleration meters/second2 M/S2
inches/second2 IN/S2
feet/second2 FT/S2
standard gravity GN

Pressure Pascal PAL
bar BAR
atmosphere, technical AT
atmosphere, standard ATM
Torr TORR
pounds/square inch PSI

Temperature degrees Kelvin K
degrees Celsius CEL
degrees Fahrenheit FAR

Energy Joule J
British Thermal Unit BTU
calorie CAL

Rotating Machine radians/second RADPS
frequency (Hertz) HZ
revolutions/second RPS
revolutions/minute RPM
torque N•m NM
torque in•oz INOZ
torque in•lb INLB
torque ft•lb FTLB
power, mechanical (Watt) W
horsepower HP
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Category Unit Mnemonic

Magnetic Weber WB
Tesla T
inductance (Henry) H
magnetic field strength A/M
permeability HENRYPM

Electrical Ampere A
Volt V
Watt W
power, apparent VA
power, reactive VAR
power factor PF
capacitance (Farad) F
Coulomb C
Ohm OHM
Siemen SIE
electrical field strength V/M
electrical displacement field CPM2
permittivity FARADPM
conductivity SIEPM

Time second S
minute MIN
hour HOUR
day DAY
week WEEK

Dimensionless percent PCT
percent min-max PCTMNMX
decibel DB
decibel milliwatt DBM
decibel Volt DBV
decibel millivolt DBMV
decibel microvolt DBUV
decibel microampere DBUA
decibel referred to carrier DBC
decade DECADE
unit interval UI
Q-scale Q
bit BIT
byte BYTE
baud BAUD
least significant bit LSB
poise POISE
parts per million PPM
pixel PIXEL
division DIV
event EVENT
sample SAMPLE
segment SEG
sweep SWEEP
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Sparse Function
The Sparse math function allows you to thin out an incoming waveform by skipping points at regular intervals, and
by starting acquisition at a particular offset (point). The Sparsing factor specifies the number of sample points to
reduce the input waveform by. A sparsing factor of 4, for example, says to retain only one out of every 4 samples. A
Sparsing offset of 3, on the other hand, says to begin on the third sample, then skip the number of samples specified
by the sparsing factor (4). In this way, the sample rate is effectively reduced.

For the sparsing factor (interval), you can set a value from 1 to 1,000,000 points. For the sparsing offset you can set
a value from 0 to 999,999.

1. Follow the usual steps to set up a math function, selecting Sparse from the Misc submenu.

2. Touch the Sparsing factor control and provide a Bandwidth Limit value.

3. Touch the Sparsing offset control and provide a value.
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Analysis Tools
Analysis tools complement the standard math/measurements to help you understand the behavior of waveforms.

Standard Tools
WaveScan searches single or multiple acquisitions for events that meet specific criteria.

Pass/Fail Testing shows whether waveforms or measurements meet a set of defined criteria.

CustomDSO (XDEV) enabes you to insert custom VBScript (VBS) or 3rd-party programs such as Excel™, Mathcad™,
and MATLAB™ into the oscilloscope processing stream. It is standard on many high-bandwidth oscilloscopes,
optional on others.

Optional Tools
Many optional software packages may be purchased for specialized uses, such as power analysis or serial message
trigger and decode. In most cases, these options are added to the Analysis menu.

Complete documentation for software options can be found at teledynelecroy.com/support/techlib under Manuals >
Software Options. In addition, context-sensitive Help for many options available on your platform can be found in the
MAUI Support site under the Analysis menu.
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WaveScan
The WaveScan® Search and Find tool enables you to search for unusual events in a single capture, or to scan for a
particular event in many acquisitions over a long period of time. Each Scan Mode is optimized to find a different type
of event. Results are time stamped, tabulated, and can be viewed individually. You customize the presentation by
choosing different WaveScan displays, called Scan Views.

Note: The instrument reverts to Real-time sampling mode when WaveScan is enabled.

WaveScan window with different scan "views" turned on.

Scan Modes
The Scan Mode determines the type of search to be performed. Select the Mode along with the Source trace to be
searched on the main WaveScan dialog. For each mode, different controls appear on the WaveScan dialog, providing
additional inputs to the search criteria. Make the appropriate entries in these fields before starting the search.

Edge Mode
Edge Mode is used for detecting the occurrence of edges. Events that meet the threshold level are captured and
tabulated. When the acquisition is stopped, scan filters can be applied to the edges to find specific characteristics.
Edge Mode settings are:

l Slope. Choose Pos, Neg, or Both.

l Level is (set in...). Choose Percent or Absolute.

l Percent/Absolute Level. Enter a threshold value as a percentage of Top to Base or voltage level.
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Non-monotonic Mode
Non-monotonic Mode looks for edges that cross a threshold more than once between high and low levels. All events
that meet the criteria of slope, hysteresis, and level are presented in a table and highlighted in the source trace. The
value displayed in the table is the difference of the max. and min. of the non-monotonicity. This can be confirmed
with cursors. The hysteresis value is used to eliminate noise. A non-monotonicity is detected only when its amplitude
is greater than the hysteresis. Therefore, when setting a hysteresis level, set a value that is greater than the
amplitude of the noise. Settings are:

l Slope. Choose Pos, Neg, or Both.

l Hysteresis is (set in...). Choose Division, Percent, Absolute.

l Division/Percent/Absolute. Enter hysteresis level in the selected unit.

l Levels are (set in...). Choose Percent, Absolute, or Pk-Pk%.

l High/Low Level. Enter top and bottom thresholds in the selected unit.

Runt Mode
Runt Mode looks for pulses that fail to cross a specified threshhold. You can search for positive-going or negative-
going runts, or both. An adjustable hysteresis band is provided to eliminate noise.

In the case of negative-going runt pulses, the value displayed in the table is the difference (delta) of the high level of
the signal and the runt amplitude (i.e., where the runt bottoms out). This can be confirmed by placing cursors on the
runt pulse and reading the delta Y value in the trace labels. In the case of positive-going runt pulses, the value
displayed in the table is the absolute value of the amplitude of the runt pulse. Runt Mode settings are:

l Runt Type. Choose Both, Pos, or Neg.

l Hysteresis. Enter the hysteresis level as a percentage or voltage.

l Low/High Threshold. Enter the levels as a percentage or voltage.

l Absolute Levels. Check this box to enter levels as absolute voltage instead of percentage.

Measurement Mode
Measurement Mode is used for applying filters to measurements to find those that meet your defined criteria,
helping to isolate particular events within many samples. Markers appear over the source trace to indicate the
location of measurement, while the table displays values for the selected parameter that meet the criteria.
Measurement Mode settings are:

l Measurement. Choose the measurement parameter you wish to search.

l Filter Method. Choose the operator that indicates the desired relationship to the Filter Limit. Only
measurements that meet this criteria are returned.

l Filter Limit. Enter the value that completes the filter criteria.

Alternatively, you can use the Filter Wizard to create the filter criteria.
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Serial Pattern Mode
Serial Pattern Mode is used for finding 2- to 64-bit patterns in serial data sequences or serial clocks. It is ideal for
bursted patterns where a PLL cannot lock. Serial Pattern Mode settings are:

Pattern Time
This is the bit pattern to find.

l Viewing. Choose to enter the pattern as Binary or Hex(adecimal).

l Binary/Hex. Enter the digital pattern to find in either binary or hexadecimal.

For binary patterns, enter the state the line should be in as 1=high, 0=low, X=don't care (not included in pattern),
starting from highest to lowest number line.

l Num. Patterns to detect. Enter a whole number of pattern locations to mark on the acquisition.

NRZ to Digital
These settings define the serial logic for the bus.

l Check Data is NRZ if the data is an NRZ signal.

l Enter the Base Frequency of the signal.

l In Level Type and Level, enter the threshold for logic determination as either a percent amplitude or an absolute
voltage.

l Choose the waveform Slope used for logic determination.

l Choose if the Signal Type being scanned is Data or Clock.

PLL

l If there is any PLL in use on the signal scanned, check Use PLL.

l Select the PLL Type in use.

l Enter the PLL Cutoff Divisor if you are using a Custom PLL. This field normally updates to the standard for the
PLL type selected.

Bus Pattern Mode
Bus Pattern Mode (only on Mixed Signal models) is used for finding 2- to 16-bit patterns across the digital lines
where PLL is not a concern. Bus Pattern Mode settings are:

l Viewing. Choose to enter the pattern as Binary or Hex(adecimal).

l Binary/Hex. Enter the digital pattern to find in binary or hexadecimal code.

For binary patterns, enter the state the line should be in as 1=high, 0=low, X=not included in pattern, starting
from highest to lowest number line. An 8-line bus is assumed. For example, to set the pattern D2=1, D1=0 and
D0=1 for 8-line bus D0-D7, you can just enter "101" on the keypad, and the software will complete the full
pattern XXXXX101. If you wish to set the pattern on D7, D6 and D5, enter 101XXXXX.

l Num. Patterns to detect. Enter a whole number of pattern locations to mark on the acquisition.
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Scan Views
Scan Views are different ways to view your WaveScan results. Just check the boxes at the bottom of the WaveScan
dialog for those views you wish to display simultaneously.

Note: The number of grids varies depending on which views are enabled. WaveScan handles this function
automatically, and you cannot move traces among grids as in normal operation.

Additional controls for Scan Overlay and Zoom views are on their respective dialogs. If you turn on these traces from
those dialogs, you must turn them off from there, too.

Source Trace
By default, the source trace is displayed in the top grid, with markers indicating points that meet the search criteria.

Table
Table view displays a table of measurements relevant to your chosen Search Mode next to the source trace. Times
view adds columns to the table showing Start and Stop Times for each event.

Scan Overlay
Scan Overlay view uses colored overlays to show the location of events meeting the scan criteria.

Zoom
Zoom view works exactly as it does elsewhere in the oscilloscope software, creating a new trace that is a magnified
section of the source trace. A WScanZn tab appears by default when you launch WaveScan.
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Setting Up WaveScan
Set up your source channel and triggers before setting up the scan.

1. Press the front panel Stop button to stop acquisition.

2. Choose Analysis > WaveScan and check Enable.

3. Choose the Source waveform.

4. Choose the Scan Mode and enter values for any additional settings that appear at the right of the dialog
based on your selection.

5. Select each Scan View in which you wish to display results by checking the box at the bottom of the dialog.
Each view selected is displayed simultaneously.

6. Optionally, choose a Trigger Action to take when an event is found that meets your scan criteria.

Tip: Despite the name, these actions occur only when the WaveScan criteria are met, not with every
acquisition trigger. Pulse AUX Output will send a pulse over the AUX Out connector. Print Screen will
execute whatever you have configured on the Print dialog. User Action will execute whatever action
you have configured for the User button.

7. Restart acquisition.

WaveScan Search
Search is used to find events in (usually) zoom (Zn) traces that match user-defined criteria. To search within
WaveScan:

1. Select the Zoom view.

2. After stopping the acquisition, open the Z1 dialog that appears behind the WaveScan dialog.

3. Use the Prev and Next buttons to move back or forward within the trace to the events that matched your Scan
Modes criteria.
Or
If you know the WaveScan table index (row) number of the event you wish to find, enter it in Idx.
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Scan Overlay

To apply monochromatic persistence to a Scan Overlay:

1. Select Scan Overlay when setting up the wave scan, then open the Scan Overlay dialog.

2. Check Persistence On.

3. Enter a Saturation level as a percentage. All samples above the saturation level are assigned the highest color
intensity.

4. Choose a Persistence Time. The higher the time, the more static the persistence display.

To adjust the scan overlay to "zoom" in or out: touch the In/Out buttons, or touch Scale and enter new values. Check
Var. to adjust scale in finer steps than the default 1, 2, 5.

Scan Histogram
Scan Histogram is an additional WaveScan "view" that generates a histogram to give you a statistical view of edges
that meet your search criteria. Set it up as you would any histogram:

1. Enter the total #Values in the histogram buffer.

2. Enter the #Bins (bars) in the histogram.

3. Enter the Center value and Width of each bin from center, or check Enable Auto Find and let the sofware Find
Center and Width.

4. Choose a Vertical Scale method:

l Linear allows the histogram to build vertically as data accumulates. When the histogram reaches the top
of the display it rescales the vertical axis to keep it on screen.

l LinConstMax keeps the histogram at near full scale and rescales the vertical axis as data is
accumulated.
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PASS/FAIL Testing
PASS/FAIL testing allows you to define a set of qualifying conditions that an acquisition may "PASS" or "FAIL" when
tested against, then take actions depending on the result.

l Mask testing compares sampled values to a pre-defined area of the grid (the "mask") to see if they fall within or
without.

l Parameter comparison compares a measurement result to a pre-defined value (Param compare) or to another
measurement (Dual param compare).

You can preconfigure multiple queries(Qn) using either method, which are then enabled by selecting them on the
Pass/Fail dialog and defining what results constitute a "PASS" on the Actions dialog.

Mask Testing
A mask defines an area of the grid against which a trace is compared. Test conditions define how the waveform is to
be compared to the masked area (e.g., some/all values fall within, some/all values fall outside), and a pass or fail
result is returned indicating the condition was found to be true or false.

Mask testing can be done using a pre-defined mask or a mask created from a waveform with user-defined vertical
and horizontal tolerances. Some industry standard masks used for compliance testing are included with the
oscilloscope software. The mask test can be confined to a region of the trace by the use of a measurement gate.

Access Mask Test Dialogs
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1. Choose Analysis > Pass/Fail Setup to display the Pass/Fail dialog.

2. Touch the Qn button where you want to set up the query.

3. Select Condition Mask test. Make mask settings on the right-hand dialogs.

Make Mask
Use this procedure to create a new mask based on a live waveform. The mask covers the area of the waveform plus
the boundaries you enter. It is best used for "all in" testing.

1. Open the Make Mask subdialog.

2. If desired, enter a new Destination File Name and path, or touch Browse and select a previous file to overwrite.
The file name should end with the .msk extension.

3. Touch the Ver Delta and Hor Delta fields and enter boundary values.

4. Touch Make from Trace.

Load Mask
Do this instead of Make Mask if you have a pre-defined mask file.

1. Open the Load Mask subdialog.

2. To use a saved .msk file, touch File and select the mask.

3. Check View Mask to display the mask over the trace.

Remove Masks from the Display
Touch the Delete All Masks button on the Pass/Fail dialog.

Set Gates
To limit the section of the waveform that is compared to the mask.

1. Open the Gate subdialog.

2. Enter the Start and Stop horizontal divisions that mark the section of the waveform to be tested. These can be
a whole division or a fraction of a division. Divisions are numbered 1-n left to right.

Tip: You can also drag the gate posts from the left and right edges of the grid to the desired position.

Define "True"

1. Open the Test subdialog.

2. Select one of the conditions that, when true (yes), results in a pass or fail.

3. Optionally, turn On markers to show where on the waveform mask violations have occurred.
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Param(eter) Compare
PASS/FAIL queries (Qn) can be configured to compare different parameter measurements (Pn) to each other, or to a
user-defined limit or statistical range. The Summary field shows the logic represented by the query. Check it to
ensure your selections are producing the test you want.

Comparing a Measurement to a Limit
This method compares the result of a selected parameter to a user-defined limit or statistical range.

1. Choose Analysis > Pass/Fail to display the Pass/Fail dialog.

2. Touch the Qn button where you want to set up a query.

3. From the pop-up menu, choose Param compare.

4. On the Qn dialog, touch Source1 and choose the parameter.

5. On the ParamCompare subdialog, touch Compare Values and select All (every value must be within limit to be
"true") or Any (any value can be within limit to be "true").

6. Touch Condition and select a Boolean operator, then touch Limit and enter the value that completes the
condition. The value entered acquires properties corresponding to the parameters being tested. For example,
if you are testing a time parameter, the unit is seconds.

7. If you chose to set a Delta limit, also enter the Absolute or % Delta value. You may choose instead to set Limit
and Delta using one of the buttons at the bottom of the dialog.

Comparing Parameter Measurements
This method compares one parameter to another, rather than a limit.

1. Choose Analysis > Pass/Fail to display the Pass/Fail dialog.

2. Touch the Qn button where you want to set up a query.

3. From the Pass/Fail Condition menu, choose Dual Param Compare.

4. On the left-hand Qn dialog, select the parameters to compare in Source1 and Source2.

5. On the ParamCompare subdialog, choose to Compare All (every value must meet condition to be "true") or
Any (any value can meet condition to be "true").

6. Touch Condition and select the Boolean operator that expresses the relationship between parameters (e.g.,
All P1 values must be less than P2).
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Defining PASS/FAIL Tests
The queries define the conditions that, if met, would result in "true" but don't in themselves determine the test result.
You must separately define what constitutes a "PASS" or a "FAIL" on the Actions dialog. Either result can be made to
produce various additional actions, such as sending a pulse to another device.

1. After setting up the PASS/FAIL test qualifiers, open the Actions tab.

2. Optionally, check Summary View to see a running summary of results.

3. Select the test Pass criteria in Pass If.

Apply Actions

1. Check Enable Actions to turn on actions.

2. Under If, choose to apply actions if the result is a Pass or a Fail.

3. Under Then, choose all the actions to take:

l Save Waveform file

l Stop the test

l Sound an Alarm

l Emit a Pulse from the AUX OUT connector. When taking this action, also go to Utilities > Utilities Setup >
Aux Output and choose to Use Auxilliary Output For Pass/Fail.

l User Action configured for the front panel User button.

l Create a LabNotebook Entry

Use the Clear All button to clear all the action checkboxes, or Force Actions Once to take action once regardless of
the test results.

Delay Test
You can delay the start of a test by entering the number of sweeps to wait in Start Testing After.

Touch Clear Sweeps at any time to reset the test counter.

Stop Test
To stop the test following a specified number of sweeps, rather than a PASS or FAIL result, check the Stop Test box,
then enter the desired number of sweeps in After.
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CustomDSO Setups/Controls
Custom setups, which can include proprietary math/measurements, are one of the most commonplace uses of
Advanced Customization. The CustomDSO Setup dialog, which is enabled with the XDEV option, provides a
convenient entry point for either:

l Linking Automation programs saved as .lss or .vbs files to eight Basic Action buttons

l Installing a Plug-in that adds a custom dialog and processors to the oscilloscope's MAUI interface

Note: You can only enable either the Plug-in or the Basic Actions at once, which determines which user
interface is displayed.

From the oscilloscope menu bar, choose Analysis > CustomDSO.

If you do not need to link your custom script to a GUI control, but just want to create a custom processor to be
applied as a math function (Fn) or measurement parameter (Pn), you can go directly to that part of the oscilloscope
interface to upload or begin scripting it.

Basic Actions
The Basic setup utilizes eight Action buttons, each of which can launch a different setup file written in VBScript. This
"menu" of custom Action buttons can be set to appear at the bottom of the oscilloscope touch screen at all times,
regardless of whatever dialogs are open, or even if the oscilloscope application is closed and the Windows desktop
or other application is open.

Template LeCroy System Setup (.lss) files named custom 1.lss through custom 8.lss are the defaults for each
button, ready to be modified in situ, or copied, edited and saved to new files for future use. These default scripts,
syntactically identical to VBScripts with a different file extension, are Microsoft COM Automation programs used to
apply complex setup instructions to the oscilloscope.

The scripts can program an entire oscilloscope setup, or just a portion of a total setup—such as to recall a waveform
file or memory, enable a particular math function, set a trigger and acquire, modify a display setting, etc. Scripts can
be run synchronously or asynchronously.

Installing Scripts
To assign scripts to buttons:

1. Select Basic, then select the Action button to host the script.

2. Check Enable Action to make the button active. If deselected, the program will remain associated with the
button, but the button will not function.

3. To allow scripts to run in a separate process from the oscilloscope application, check Execute Scripts
Asynchronously. This allows the oscilloscope application to perform another function while the script is being
executed.
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4. To keep the Action buttons visible on the oscilloscope at all times, check Present CustomDSO menu at
powerup and when menu closed.

5. Either touch Edit and modify the template script in the CustomDSO Editor (see below) , or touch Browse to
select a saved program you wish to launch with this button.

6. Optionally, open the Test Basic Mode dialog and test the new button.

Creating/Modifying Scripts
Since the setup files are VBScript (VBS) files, follow the programming rules and recommendations in Customization
Using VBScript when scripting.

1. Set up the oscilloscope exactly as you would wish it to be when the button is activated.

2. On the CustomDSO dialog, select the button and click Edit to open the CustomDSO Editor window.

3. To copy all current oscilloscope settings into the setup file, select Load from Current Setup.

To revert to the original template file, select Load from Example.

While not required, starting your script by loading the current setups can help ensure the presence of all
settings required for your Action, especially if you have already scripted and activated custom math or
measurements you wish to make part of this setup. They will be already embedded in the setup script.

4. Make any further modifications or additions to the script.

5. Optionally, click Test to execute the script.

6. When done editing, Save As a new file, or just Save these changes to the custom n.lss file associated with the
button. The original template remains unaffected.

Note: The file name is displayed on the button, as shown on the Test Basic Mode dialog, so choose a
name that is short and sufficiently descriptive of the action that users know what they are selecting.
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Plug-Ins
Any ActiveX (.ocx) or .NET (.dll) control can be inserted into the oscilloscope process by using the CustomDSO Plug-
In feature. This is especially useful for programs that are written in languages other than VBScript or designed to
interface with other applications, such as Excel or MATLAB.

Plug-ins are launched using whatever custom Windows controls you have included in your program; the plug-in
dialog replaces the Basic Action buttons. This is ideal for non-technical personnel using the oscilloscope for testing
and production: an entire workflow, including feedback controls, can be embedded in your custom dialog.

Programming Plug-Ins
Plug-ins are programmed as oscilloscope application subroutines that access the oscilloscope's COM Automation
interface through VBS processors. The basic structure is:

Private Sub control label_action
Dim app as Object
Set app = CreateObject("LeCroy.XStreamDSO.1")
custom code
End Sub

The control label is whatever you have named the UI control that will invoke the program, for example, SingleButton.

The action is the user action associated with the control, for example, Click( ).

Custom code refers to the Automation commands and processors that are invoked when the control is activated, for
example: app.Acquisition.TriggerMode = "Stopped" .

So, a very simple plug-in that presents a button to Stop acquisition on the CustomDSO dialog might be:

Private Sub SingleButton_Click()
Dim app as Object
Set app = CreateObject("LeCroy.XStreamDSO.1")
app.Acquisition.TriggerMode = "Stopped"
End Sub
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Using ActiveDSO
If your ActiveX plug-in is created with Visual Studio, C Compiler or similar, you will have to register the plug-in. If you
use ActiveDSO as the interface for the CustomeDSO plug-in, you can call the already registered C:\Program Files
(x86)\LeCroy\ActiveDSO\ActiveDSO.ocx as the CustomDSO plug-in. While not required, ActiveDSO is helpful for
creating ActiveX controls for Teledyne LeCroy instruments.

ActiveDSO is available free from the teledynelecroy.com software download page under Oscilloscope > Software
Utilities. See the ActiveDSO Developer's Guide for more information.

Using VB.NET
If you are using Microsoft's VB.NET framework to program your plug-in, see the instructions in our application note,
Plug-ins Using VB.NET.

Installing Plug-Ins
To install plug-ins:

1. On the CustomDSO dialog, select Plug-In.

2. Select the COM ProgID of Plug-In field and enter the program ID on the pop-up keyboard.

The default plug-in, LeCroy.CustomDSODemo.1, demonstrates plug-in functioning. Install it to see how the
custom dialog is inserted into the oscilloscope's GUI.

3. To keep the plug-in dialog visible on the oscilloscope at all times, check Present CustomDSO menu at
powerup and when menu closed.

4. Select Install.

5. Open the Plug-In n dialog to test your program. Whatever controls you have created for the GUI appear in the
PlugIn1 dialog.

To uninstall the plug-in, simply select Remove.

MAUI Browser
The MAUI Browser utility (formerly XStreamBrowser™) enables you to view, copy and modify the COM object
hierarchy of a Windows-based MAUI oscilloscope. It is essential for writing Automation programs, as it always
shows all the Automation objects on the instrument at the exact current configuration—including those objects
belonging to software options.

MAUI Browser is installed on all MAUI oscilloscopes for local browsing. It may also be installed with MAUI Studio on
remote PCs to view a connected oscilloscope's Automation hierarchy.

Caution: The legacy XStreamBrowser available for download on our website is a 32-bit version. Do not
install this on any 64-bit oscilloscopes or PCs. Use only the latest 64-bit MAUI installer to update the
oscilloscope MAUI Browser, or use MAUI Studio to install it on your PC.

Connecting to a Local Oscilloscope
To launch MAUI Browser on the oscilloscope:

1. Choose File->Minimize to display the Windows desktop.

2. Double-click the MAUI Browser icon.
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3. Select the connection icon.

Connecting to a Remote Oscilloscope

1. Be sure the oscilloscope is configured to allow a DCOM connection from the PC.

2. Launch MAUI Browser on the PC.

3. Select the connection icon.

4. Enter the network IP Addressof the oscilloscope, then click OK.

Note: If the oscilloscope application is not running, initiating the connection from the MAUI Browser will
start it; however, it will not power on a device that is powered off. Be sure the oscilloscope is turned on
before connecting.

When the connection to an instrument is established, the MAUI Browser window is populated with the oscilloscope
application object hierarchy.

Caution: While remote viewing is safe, it is not advisable to use MAUI Browser to change certain settings, in
particular remote control CVARs, over a remote connection. Make these changes locally on the
oscilloscope.

Refreshing the Display

If you change the state of the oscilloscope in any way while connected to MAUI Browser, select the icon to
refresh the object hierarchy. Settings changed on the oscilloscope must be "pulled" into the MAUI Browser display.

Disconnecting
Only one connection may be made at one time. To disconnect, choose File > Close Session.

Use the window closebox or choose File > Exit to close the MAUI Browser application.

Viewing MAUI Objects
The number of different objects in a complete oscilloscope setup is obviously large and changes with the installation
of new firmware and software options. MAUI Browser helps you quickly find the object path and valid values
corresponding to any instrument control.

The object hierarchy exposed by MAUI instruments is rooted at the Application object. This object is always named
LeCroy.XStreamDSO.

All major instrument subsystems are available from this object, and many of these subsystems themselves may be
broken down further. As new software options are activated on the oscilloscope, these subsystems are added to the
Application object hierarchy.

Anything exposed by the object hierarchy can be controlled or read back via Automation.
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Object Hierarchy
The left-hand pane of the MAUI Browser window contains an
expandable navigation "tree." The object hierarchy is tiered; for example,
the Acquisition subsystem is comprised of a variety of objects, each
with child objects.

The right-hand pane shows the Control Variables or Properties related
to the object selected from the navigation tree.

Control Variables
The majority of the items you will find as you expand the navigation tree are Control Variables, or CVARs for short.
These are shown as yellow folders in the MAUI Browser window.

CVARs provide an interface for accessing scope configurations and for executing methods and actions. When
viewed from MAUI Browser, many CVARs appear to be properties, but are actually objects with properties such as
Name, Value, and Type, to name a few.

CVAR properties shown in the right-hand pane of MAUI Browser window.

The Range/Helpstring column provides short form information about the possible values the variable can take.

The Flags/Status column contains coded information about the object.
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Flag/Status Indicates

R For CVARs: Read only.
For Properties: Readable.

W For CVARs: Wrapping, incrementing the value will "wrap around" from max. to min., or vice versa.
For Properties: Writable.

H Hidden: not visible on any GUI dialog or menu.
g Grey: appears "greyed out" on GUI indicating it is

disabled or not settable.
B Backwards: incrementing the CVAR value will decrease the value.
N Nonvolatile: value is saved in the application's "nonvolatile" settings file. These CVARs are typically user pref-

erences and are not affected by Recall Default Setup.
A AutoRepeat: the CVAR action should be repeated if a button on the GUI is held down.
M MultiLine: the CVAR value may be rendered on

multiple lines of the GUI.
L LateUpdate: the CVAR value may be updated when it is read/refreshed.

Actions and Methods
Besides the configuration CVARs, Automation also provides for Actions that may be applied at the application or
subsystem level.

For example, to clear sweeps for all subsystems, the Automation command would be:

app.ClearSweeps

Methods are similar to Actions but may take parameters from the caller and may possibly return a value, whereas,
Actions do not support any parameters or return values. An example of a Method is app.Acquisition.Acquire, which
takes both "timeout" and "force trigger" arguments.

Result Interfaces
The grey folders are Result Interfaces. Result Interfaces contain more than just the basic results of oscilloscope
operations, such as waveform data and measurement values; they include information about horizontal and vertical
resolution, event times, number of sweeps, histogram peaks, etc. The Type column of the MAUI Browser window
shows the result interface type.

Collections
Collections, which are shown as pink folders in MAUI Browser, contain sets of similar objects. For example, the
app.Acquisition.Channels collection contains input channel objects (C1, C2, etc.). Objects in Collections folders are
dynamically linked to those in the yellow folders; changing the value in either place changes it everywhere. Collection
subfolders are referenced by indexing the collection name with the subfolder name.
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Copying from MAUI Browser
When a variable is selected from the right-hand pane, the message bar at the bottom of the screen shows the full
object path in correct notation for sending as an Automation command:

Right-click and choose Copy Path. The text is automatically placed in the clipboard, from where it can be easily
copied into Automation programs.
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Memories
The instrument is equipped with internal memory slots (Mn) to which you can copy any waveform that is active on
the grid. This is a convenient way to store an acquisition for later viewing and analysis. Memories can be used as
source inputs for most oscilloscope math and measurements, allowing you to compare historical data to a live
acquisition or perform "what if" modeling on saved acquisitions.

Note: If there is a processing error (e.g., no data) when saving or recalling a memory, a small letter "i" inside
a bubble will appear on the Mn descriptor box to indicate there is more information regarding the waveform
status. See Finding Waveform Status for instructions on finding the error.

Saving Memories
Store memories on the Memory dialogs (Mn). Memories are created at the same scale as the source trace, but they
can be adjusted independently by using the zoom factor controls that appear next to the Mn dialogs.

Save Waveform to Memory

Tip: Try to choose an empty slot, as anything currently stored in that location will be overwritten. All
memories will state if they are empty or an acquisition is stored there.

On oscilloscopes with OneTouch, touch the Add New box and choose Memory. Drag the descriptor box of the trace
you wish to store onto the Mn descriptor box.
Or

1. Press the front panel Mem button or choose Math > Memory Setup.

2. Touch the Mn tab corresponding to the memory slot you wish to use.

3. In Copy from Waveform, choose the source trace to copy to memory.

4. Touch Copy Now.

5. Optionally, check Trace On to immediately display the memory.

Import External Waveform Files into Memory
Trace (.trc) files saved on other Teledyne LeCroy instruments can also be imported into internal memory using the
waveform recall feature. Choose File > Recall Waveform and to recall the file to an internal memory. Then, you can
use the Memories dialog to place them on the display.
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Restoring Memories
The Memories dialog is a convenient panel for restoring saved memories to the display.

Access the Memories dialog by pressing the front panel Mem button or choosing Math > Memory Setup.

Check On next to the memory trace you wish to display. A description of the memory showing the source channel
and creation time appears next to each Mn on the dialog.

Touch Clear All Memories to empty the memory banks.

Caution: Memories cannot be restored once they have been erased.
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Save/Recall Data (File Menu)
The File menu functions allow you to save and recall setups, waveform data, table data, screen captures,
LabNotebooks, and reports. You can use Print or E-mail to share these files.

Save
Oscilloscope setups (configurations), waveform data, tabular data, and the display can all be saved in multiple
formats.To save them all as a composite LabNotebook file, see Save LabNotebook.

Note: We strongly recommend that you stop acquisition before saving waveforms or LabNotebooks,
especially when running in Auto trigger mode. If you do not first stop, there is no guarantee that what you
are capturing is what you want to save.

Save Waveform
The Save Waveform function saves trace data either to internal memory (M1-Mn) or to a file in text or binary format.
The source waveform can be any type of trace; a channel, math function, zoom, or even another memory. Waveform
files can be recalled into an internal memory, from where they can be restored to the display.

Note: Only traces saved in Teledyne LeCroy proprietary formats can be recalled to the display directly. Use
the Binary format (.trc) for analog waveforms, or WaveML (.xml) for digital waveforms. Other waveform
types must be recalled into memory before being displayed.

Save Waveform To Memory

1. From the menu bar, choose File > Save Waveform.

2. Choose to Save To Memory.

3. Choose the Source trace you are saving.

4. Optionally, select Show On Save to display the memory trace with its source as soon as it is saved.

5. Touch the Save button directly to the left of the selected Destination memory slot. The date/time stamp of
the saved memory will appear at that location.
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Save Waveform To File

1. From the menu bar, choose File > Save Waveform.

2. Choose to Save To File.

3. Choose the Source waveform. To quickly save all displayed waveforms separate trace files, touch the All
Displayed button.

4. Select a file Format. Binary is Teledyne LeCroy's .trc file format. Binary results in the smallest possible file
size. Binary files can be converted to ASCII using Teledye LeCroy utilities such as WaveStudio. WaveML is a
proprietary .xml format used to save persistence maps, eye diagrams, histograms, and digital traces. This
option is only active if the source is compatible.

5. If your Format is ASCII, touch Delimiter and select a character from the pop-up menu.

6. Depending on your Format selection, you may also need to specify a SubFormat:

l Word (Binary) represents samples using 16 bits. Always use this unless Byte mode is "pre."

l Byte (Binary) represents samples using 8 bits. This option can result in a loss of resolution.

l Auto (Binary) looks at the data and automatically selects either Word or Byte subformat.

l Amplitude only (Text) includes amplitude data for each sample, but not time data.

l Time and Amplitude (Text) includes both types of data for each sample.

l With Header (Text) includes a file header with scaling information.

7. The system will auto name the file <Source>-Trace-<Counter>. To change the file name or Selected Folder,
enter the full path and name in File, or use the File Browser. By default, trace files are saved to D:\Waveforms
on the instrument hard drive.

8. If you do not want to use the Source prefix or Counter number, deselect them.

9. Touch Save Now.
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Save Setup
You can quickly save oscilloscope configurations to one of the internal setup panels or to a LeCroy System Setup
(.lss) file, a text-based Automation program. Setups can be easily recalled to restore the oscilloscope to the saved
state.

Save Setup to Memory

1. From the menu bar, choose File > Save Setup.

2. Choose to Save To Memory.

3. If desired, touch one of the Setup slots and enter a name for the memory. The default name will be Paneln.
Try to select an empty slot, as anything currently in it will be overwritten.

4. Touch the Save button directly to the left of the selected Setup slot. The save date/time is displayed above
the Setup field.

Save Setup to File

1. From the menu bar, choose File > Save Setup.

2. Choose to Save To File.

3. To change the file name or Selected Folder, enter the full path and name in File, or use the File Browser. By
default, setup files are saved to D:\Setups on the instrument hard drive.

4. If you do not want to use the Counter number, deselect it.

5. Touch Save Now.
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Save Table
The Save Table function saves tabular measurement data displayed on screen to an Excel or ASCII file.

1. From the menu bar, choose File > Save, then choose Table.

2. To save only one of the tables displayed, touch Source and navigate to the selection.

By default, data from all visible tables are saved to separate files. To quickly restore this selection, touch the
All Displayed button.

3. Choose a format of ASCII (.txt) or Excel (.csv). If you selected ASCII format, also touch Delimiter and choose a
character.

4. The system will auto name the file "<source>-Table-<counter>". To change the file name or Selected Folder,
enter the full path and name in File, or use the File Browser. By default, table files are saved to D:\Tables on
the instrument hard drive.

5. If you do not want to use the Source or Counter number, deselect them.

6. Touch Save Now.
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Save Screen Image
The full touch screen display or selected portions of it can be captured, saved to an image file, and marked with
custom annotations.

1. From the menu bar, choose File > Save, then choose Screen Image.

2. Choose a File Format of .JPEG, .PNG, .TIF, or .BMP.

3. To mark up the screen image using the drawing tools, select Annotate Screen Image Before Saving.

4. Select the Screen Area captured:

l Grid Area Only includes any visible waveform grids, tables, and descriptor boxes.

l DSO Window includes the above plus any open dialogs, menu bar, and message bar.

l Full Screen is the full Windows display, including other visible applications and desktop.

5. Choose the Colors used in the capture:

l Standard uses the screen colors on a black background as it appears on the instrument.

l Print (default) uses your print color palette (set in Preferences) on a white background to save ink.

l Black & White captures the image in grayscale.

6. To change the file name or Selected Folder, enter the full path and name in File, or use the File Browser. By
default, image files are saved to D:\Hardcopy on the instrument hard drive.

7. Touch Save Now.

8. If you've turned on annotations, use the Drawing toolbar to mark up the screen image. Click Done when
finished.
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Auto Save
Data that appears on the oscilloscope display, such as waveforms, measurement readouts and decoder data, can be
very dynamic and difficult to read from the oscilloscope unless you stop the acquisition.

Auto Save enables you to automatically store waveform and table data to file with each new trigger. The file can later
be recalled to the oscilloscope or saved permanently to external storage.

1. Choose File > Save and open the Auto Save dialog.

2. Select to save Waveforms and/or Tables.

3. Select the Source from which to save. The All Displayed selection will create a separate file for each trace or
table displayed.

4. By default, waveform files are stored in D:\Waveforms and tables are stored in D:\Tables on the instrument
hard drive. Optionally:

l Enter a different root path and name in File.

l Touch Browse to open the File Browser and add or remove the source prefix and counter suffix.

5. Choose one of the Auto Save options: Wrap (old files overwritten when buffer filled) or Fill (no files
overwritten, excess is truncated).

Tip: If you have frequent triggers, it is possible you will eventually run out of storage space. Choose
Wrap only if you're not concerned about files persisting on the instrument. If you choose Fill, plan to
periodically delete or move files off the instrument, or you will lose new data.

6. To confirm these selections, choose Configure Auto Save from the pop-up dialog that appears.

7. As soon as there is a trigger, files will begin to be saved. Choose Disable Auto Save from the pop-up to stop
saving files while the acquisition is in process.

You can also choose Off on the Auto Save dialog to disable this feature in between acquisitions.
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Waveform File Format
By default, the oscilloscope saves waveform data as binary files (.trc). The properties of the trace file are shown by
the waveform descriptor block, which appears immediately after the file header. The waveform descriptor is the key
to understanding the data that follows.

There are two waveform file formats and waveform descriptors currently in use:

l WAVEDESC1 defines the waveform file format that has been used since the introduction of 64-bit LeCroy
DSOs. This describes all waveform files that are ≤2 GB in length.

l WAVEDESC2 defines the extended trace file format that was introduced with the long memory HD
oscilloscopes. This descriptor appears only in >2 GB waveform files in a second section of the file following the
variables described by WAVEDESC1.

When an acquisition is >2 GB, the TRIGTIME_2, DATA_ARRAY_3 and DATA_ARRAY_4 blocks (all defined in
WAVEDESC2) contain the balance of the waveform data that does not fit into the legacy format. To export the
complete waveform to other programs, the data in these blocks should be appended to the data in TRIGTIME,
DATA_ARRAY_1 and DATA_ARRAY_2, according to the properties that will appear in the WAVEDESC1 and
WAVEDESC2.

Waveform File Format

Section Block ID Type Size Description

1: Legacy file format

Only this section is used
when the waveform size
is
≤ 2 GB.

If the waveform size is >
2 GB, this section of the
file contains all data up
to 2 GB.

The WAVEDESC1 block
describes the properties
of this part of the
waveform.

#Nnnnnnnnnnn Header 11-17 The special character '#' ; then one Hexadecimal
digit N (0-9, A-F); then N decimal digits that denote
the positive integer size of this section. The number
of digits 'nnnnnnnnnn' is equal to N, representing
the block size of Section 1.

WAVEDESC1 Block 344 Waveform descriptor of primary section. See table
below for a definition of its components.

USERTEXT Block variable User defined text.
TRIGTIME Trigger

Time Array
variable The total size is defined in

WAVEDESC1 > TRIGTIME_ARRAY.
Each trigger time element is defined as:
{double TRIGGER_TIME;
double TRIGGER_OFFSET}

RISTIME Double
Array

variable The total size is defined in
WAVEDESC1 > RIS_TIME_ARRAY.
The type of each element is double.

DATA_ARRAY_1 Array variable The total size is defined in
WAVEDESC1 > WAVE_ARRAY_1.
The data format is defined in
WAVEDESC1 > COMM_TYPE.

DATA_ARRAY_2 Array variable The total size is defined in
WAVEDESC1 > WAVE_ARRAY_2.
The data format is defined in
WAVEDESC1 > COMM_TYPE.

158



Save/Recall Data (File Menu)

Section Block ID Type Size Description

2: Extended file format

If the waveform size is >
2 GB, this section of the
file contains all data > 2
GB.

The WAVEDESC2 block
describes the properties
of this part of the
waveform.

#Nnnnnnnnnnn Header 11-17 The special character '#' ; then one Hexadecimal
digit N (0-9, A-F); then N decimal digits that denote
the positive integer size of this section. The number
of digits 'nnnnnnnnnn' is equal to N, representing
the block size of Section 2.

WAVEDESC2 Block 672 Waveform descriptor of extended section. Note:
Parts of this block replace equivalent parts of
WAVEDESC1; see WAVEDESC2 below.

USERTEXT Block variable User defined text.
TRIGTIME_2 Trigger

Time Array
variable The total size is defined in

WAVEDESC2 > TRIGTIME_ARRAY.
Each trigger time element is defined as:
{double TRIGGER_TIME;
double TRIGGER_OFFSET}

RISTIME Double
Array

variable The total size is defined in
WAVEDESC2 > RIS_TIME_ARRAY.
The type of each element is double.

DATA_ARRAY_3 Array variable The data in this block follows DATA_ARRAY_1. To
get the full waveform, DATA_ARRAY_1 and DATA_
ARRAY_3 must be combined.
The total size is defined in
WAVEDESC1 > WAVE_ARRAY_3.
The data format is defined in
WAVEDESC1 > COMM_TYPE.

DATA_ARRAY_4 Array variable The data in this block follows DATA_ARRAY_2. To
get the full waveform, DATA_ARRAY_2 and DATA_
ARRAY_4 must be combined.
The total size is defined in
WAVEDESC2 > WAVE_ARRAY_4.
The data format is defined in
WAVEDESC2 > COMM_TYPE.

WAVEDESC1

Offset
(bytes) Size (Bytes) Type Variable Name Description

0 16 string DESCRIPTOR_NAME Will contain "WAVEDESC"
16 16 string TEMPLATE_NAME Name of the template
32 2 short COMM_TYPE Data format: 0 = byte; 1 = word
34 2 short COMM_ORDER Data order: 0 = Hi First; 1 = Lo First

The following variables specify the lengths of all blocks of which the entire waveform (as it is currently being read) is composed.
If a block length is zero, that block is (currently) not present. Blocks and arrays that are present will be found in the same order
as shown below.

36 4 long WAVE_DESC_LENGTH Length in bytes of WAVEDESC1 block
40 4 long USER_TEXT_LENGTH Length in bytes of USERTEXT block
44 4 long RES_DESC1 Reserved
48 4 long TRIG_TIME_ARRAY Length in bytes of TRIGTIME array
52 4 long RIS_TIME_ARRAY Length in bytes of RISTIME array
56 4 long RES_ARRAY_1 Reserved
60 4 long WAVE_ARRAY_1 Length in bytes of first simple data array
64 4 long WAVE_ARRAY_2 Length in bytes of second simple data array
68 4 long RES_ARRAY_2 Reserved
72 4 long RES_ARRAY_3 Reserved

The following variables identify the instrument.
76 16 string INSTRUMENT_NAME
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Offset
(bytes) Size (Bytes) Type Variable Name Description

92 4 ULONG INSTRUMENT_NUMBER
96 16 string TRACE_LABEL Waveform identifier

112 4 long RESERVED_DATA_COUNT Reserved
The following variables describe the waveform type and the time at which the waveform was generated.

116 4 long WAVE_ARRAY_COUNT Number of data points in a data array. If there are
two arrays (e.g., FFT or Extrema waveform), this num-
ber applies to each array separately.

120 4 long POINTS_PER_SCREEN Nominal number of data points on the screen
124 4 long FIRST_VALID Number of points to skip before first good point.

FIRST_VALID_POINT=0 for normal waveforms.
128 4 long LAST_VALID Index of last good data point in record before pad-

ding (blanking) was started. LAST_VALID_POINT =
WAVE_ARRAY_COUNT -1 except for aborted
Sequence and Roll Mode acquisitions.

132 4 long FIRST_POINT Indicates the data offset relative to the beginning of
the trace buffer

136 4 long SPARSING_FACTOR Indicates the sparsing into data block
140 4 long SEGMENT_NO For Sequence waveforms, index of the segment
144 4 long SUBARRAY_COUNT For Sequence waveforms, acquired segment count,

between 0 and NOM_SUBARRAY_COUNT
148 4 long SWEEPS _PER_ACQ For Average or Extrema waveforms, number of

sweeps accumulated, else 1
152 2 short POINTS_PER_PAIR For Peak Dectect waveforms (which always include

data points in DATA_ARRAY_1 and min/max pairs in
DATA_ARRAY_2), the number of data points for each
min/max pair

154 2 short PAIR_OFFSET For Peak Dectect waveforms, the number of data
points by which the first min/max pair in DATA_
ARRAY_2 is offset relative to the first data value in
DATA_ARRAY_1

156 4 float VERTICAL_GAIN Total gain of waveform, units per lsb
160 4 float VERTICAL_OFFSET Total vertical offset of waveform. To get floating val-

ues from raw data:
VERTICAL_GAIN * data - VERTICAL_OFFSET

164 4 float MAX_VALUE Maximum allowed value; corresponds to the upper
edge of the grid

168 4 float MIN_VALUE Minimum allowed value; corresponds to the lower
edge of the grid

172 2 short NOMINAL_BITS Intrinsic precision of the observation
174 2 short NOM_SUBARRAY_COUNT For Sequence waveforms, nominal segment count,

else 1
176 4 float HORIZONTAL_INTERVAL Sampling interval, the nominal time between suc-

cessive points in the data
180 8 double HORIZONTAL_OFFSET Trigger offset in time domain for zero'th sweep of trig-

ger, measured as seconds from trigger to zero'th
data point (i.e., actual trigger delay)

188 8 double PIXEL_OFFSET Time from trigger to zero'th pixel of display segment
in time domain, measured in seconds (i.e., nominal
trigger delay)

196 48 string VERTUNIT Vertical axis unit
244 48 string HORUNIT Horizontal axis unit
292 4 float HORIZ_UNCERTAINTY Uncertainty from one acquisition to the next, of the

horizontal offset in seconds
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Offset
(bytes) Size (Bytes) Type Variable Name Description

296 16 structure TRIGGER_TIME Time of the trigger, listed in the structure: double
seconds; char minutes; char hours; char days; char
months; short year; short dummy

312 4 float ACQ_DURATION Duration of the acquisition (in sec) for multi-trigger
waveforms (e.g., Sequence, RIS and Average)

316 2 short CA_RECORD_TYPE Type of waveform
318 2 short PROCESSING_DONE Indication of any processing done. 0 = no processing;

1 = fir filter; 2 = interpolated; 3 = sparsed; 4 = auto-
scaled; 5 = no result; 6 = rolling; 7 = cumulative.

320 2 short RESERVEDS
322 2 short RIS_SWEEPS For RIS acquisitions, number of sweeps from which

waveform is calculated, else 1
**The information below is based on the legacy enumeration list. It may not be valid for newer oscilloscope models.

324 2 short TIME_BASE Enumerated time/div **
326 2 short VERTICAL_COUPLING Enumerated channel coupling value
328 4 float PROBE_ATTENUATION Probe attenuation value
332 2 short FIXED_VERTICAL_GAIN Enumerated vertical gain **
334 2 short BAND_WIDTH_LIMIT
336 4 float VERTICAL_VERNIER
340 4 float ACQ_VERTICAL_OFFSET
344 2 short WAVE_SOURCE Waveform source input

WAVEDESC2

Offset
(bytes) Size (Bytes) Type Variable Name Description

0 16 string DESCRIPTOR_NAME Will contain "BLOCK2"
16 16 string TEMPLATE_NAME Name of the template
32 16 string VERSION

The following variables specify the lengths of all blocks of which the entire waveform (as it is currently being read) is composed.
If a block length is zero, that block is (currently) not present. Blocks and arrays that are present will be found in the same order
as shown below.

48 8 int64 WAVE_DESC_LENGTH_2 Length in bytes of WAVEDESC2 block
56 8 int64 TRIG_TIME_ARRAY Length in bytes of TRIGTIME_2 array
64 8 int64 WAVE_ARRAY_3 Length in bytes of data array 3
72 8 int64 WAVE_ARRAY_4 Length in bytes of data array 4
80 8 int64 WAVE_ARRAY_COUNT Number of data points in each data array. If there are

two data arrays (e.g., FFT or Extrema), this number
applies to each array separately.

96 8 int64 FIRST_VALID Number of points to skip before first good point.
FIRST_VALID_POINT = 0 for normal waveforms.

104 8 int64 LAST_VALID Index of last good data point in record before pad-
ding (blanking) was started. LAST_VALID_POINT =
WAVE_ARRAY_COUNT -1 except for aborted
Sequence and Roll Mode acquisitions.

The following variables describe waveform properties of all data in file sections 1 and 2. These values replace equivalents in
WAVEDESC1.

88 8 int64 POINTS_PER_SCREEN Nominal number of data points on the screen
112 8 int64 FIRST_POINT Indicates the data offset relative to the beginning of

the trace buffer
120 8 int64 SPARSING_FACTOR Indicates the sparsing into data block
128 8 int64 SEGMENT_NO For Sequence waveforms, index of the segment
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Offset
(bytes) Size (Bytes) Type Variable Name Description

136 4 int SUBARRAY_COUNT For Sequence waveforms, acquired segment count,
between 0 and NOM_SUBARRAY_COUNT

140 8 int64 SWEEPS _PER_ACQ For Average or Extrema waveforms, number of
sweeps accumulated, else 1

148 4 int NOM_SUBARRAY_COUNT For Sequence waveforms, nominal segment count,
else 1

152 8 double HORIZONTAL_OFFSET Trigger offset in time domain for zero'th sweep of trig-
ger, measured as seconds from trigger to zero'th
data point (i.e., actual trigger delay)

160 512 bytes[512] RESERVED Reserved for future use

Recall
Setups saved to internal memory or to .LSS file can be recalled to restore the oscilloscope to the saved state.

Waveform data stored in Teledyne LeCroy binary (.trc) or WaveML (.xml) format can be recalled directly to the
display. Waveform data stored in other binary or ASCII file formats can be recalled into a memory and from there
displayed.

To recall and modify saved LabNotebook files, see Recall LabNotebook.

Recall Waveform

Note: Only files saved in Teledyne LeCroy binary (.trc) or WaveML (.xml) format can be recalled directly to
the display.

1. Choose File > Recall Waveform from the menu bar to open the Recall dialog.

2. Touch Browse and navigate to the file.

If the file is in the Selected Folder, you can use the Up /Down Arrows to cycle through the available files until
the desired file is selected.

Optionally, touch Show Only Files to filter the list by file type. 

3. Select a Destination memory slot into which to recall the file.

4. Mark Show on Recall to display the trace on the grid.

5. Touch Recall Now.
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Recall Setup
Choose File > Recall Setup... from the menu bar.

Recall Setup from Memory

1. On the Recall dialog, select Setup.

2. Choose to Recall From Memory.

3. Select one of the six Recall buttons under Recall From Internal Setup....

Note: If a setup has been stored to a location, it is labeled with the save date/time. Otherwise, the slot is
labeled Empty.

Recall Setup from File

1. On the Recall dialog, select Setup.

2. Choose to Recall From File.

3. Enter the path to the File, or touch Browse and navigate to the desired file.

If the file is in the Selected Folder, you can use the Up /Down Arrows to cycle through the available files until
the desired file is selected.

4. Under Recall File, touch Recall Now.

Recall Default Setup
The front panel Default Setup button restores all the volatile setups to the factory default state.

You can also restore default settings via the touch screen. Choose File > Recall Setup from the menu bar and under
Recall Default select Recall Now.
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LabNotebook
LabNotebook is Teledyne LeCroy's proprietary tool for capturing a composite file containing waveform data,
oscilloscope setups and display, which can be output to a preformatted report.

The LabNotebook feature allows you to create and save composite files containing a screen capture of all displayed
waveforms, as well as all waveform and setup data at the time of capture. The Flashback feature instantly recalls the
setups and waveforms stored with LabNotebook Entries, enabling you to restore the exact state of the instrument at
a later date to perform additional analysis.

LabNotebooks saved on oscilloscopes running MAUI firmware v.9.5.x.x. and later will also support enhanced
LabNotebook features, recalling the source oscilloscope's model type and software options when recalled in MAUI
Studio Pro.

LabNotebooks can be output to a preformatted .PDF, .RTF, or .HTML report.

Save LabNotebook
All LabNotebook files (.LNB) are composed of a screen image (.PNG), a setup file (LSS), and a waveform file (.TRC)
for each waveform displayed. When creating LabNotebooks, you choose how to handle the screen image
component, which is the basis for the Report Generator output, and to which you can add a description and other
hand-drawn annotations.

Note: We strongly recommend that you stop acquisition before saving LabNotebooks, especially when
running in Auto trigger mode. If you do not first stop, there is no guarantee that what you are capturing is
what you want to save.

1. Choose File > Save LabNotebook from the menu bar.

2. Optionally, enter a Description. This text appears whenever the file is recalled and on reports.

3. To mark up the image using the drawing tools, select Annotate Screen Image Before Saving.

To skip this step, deselect the checkbox. You can recall the LabNotebook later to add a description and
annotations.

4. To change the area of the screen captured and the colors used, touch Area/Color Preferences and make your
selections on the pop-up. Touch Close to save your changes.

l Use Print Colors (default) uses your print color palette (set in Preferences) on a white background to
save ink. Deselect this to capture the display using a black background as it appears on the instrument.

l Grid Area Only includes any visible waveform grids, tables, and descriptor boxes.

l DSO Window includes the above plus any open dialogs, menu bar, and message bar.

l Full Screen is the full Windows display, including other visible applications and wallpaper.
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5. The system will auto name the file "MyLabNotebook" followed by a counter number. To change this to
something more descriptive, enter the name in LabNotebook Entry, or touch Browse and use the File Browser.

Note: Changing the file path, name or format resets the counter to the next number in that sequence.

6. If you do not want to use autonumbering to identify files, deselect Counter.

7. Touch Save Now.

8. If annotating, use the Drawing toolbar to mark up the screen image. Click Done when finished.

LabNotebook Drawing Toolbar
The basic LabNotebook is a screen capture of the display as it was at the time of entry, along with the setup and
waveform data. If you have selected to Annotate Screen Image Before Saving, the capture is immediately displayed
in the Drawing window. You can later add Annotations by recalling the LabNotebook into the Preview window and
choosing to Annotate Screen Image.

Markup tools are available from the toolbar along the top of the window.

To use any tool, touch the icon, then touch on the image where you wish to draw or add text. From left to right, the
tools are:

Tool Function

Pencil Draw in freehand. Maintain contact with the screen to make a continuous mark. Once you release, you
can touch-and-drag the object to any point on the image.

Circle Draw a circle around a waveform feature that you want to emphasize. Touch-and-drag across the dia-
meter of the circle. When you release, the circle is placed. You can drag the circle to any location on the
image.

Arrow Draw lines with arrowheads for placing callouts. You can rotate these lines through 360 degrees or
drag them to any location on the image.

Text Open a textbox for placing labels/annotations on the image. Touch the point on the image to place the
label, then enter the text in the pop-up dialog. Once placed, you can resize the textbox or drag it to any
location on the image.

RGB Selectors Quickly change the line color. Just touch the color icon, then choose the next drawing tool.
More Activates a Custom line color field. The default color is Yellow. To choose another, touch the color

swatch, then select from the Color dialog. You can enter RGB values, or choose from the spectrum.
After saving, the new color appears in the Custom field. This remains the markup color until you
choose another.

Erase / Erase All Remove selected drawing objects. Erase All will also undo any Custom color selection.
Undo Cancel the last action. Use it to restore any objects you inadvertently erased.
Move Undock the drawing toolbar so you can move it anywhere on the display. This helps to keep tools

handy when working on a particular area of a waveform. Touch the button again to restore the toolbar
to the top of the Drawing window.

Done Save the annotations with the image and close the Drawing window.
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Recall LabNotebook
Once a LabNotebook Entry is saved, you can either:

l Recall the screen image to view and modify descriptive information, or manage attachments and component
files.

l Flashback to restore the oscilloscope application to the state saved in the LabNotebook file. If you are using
MAUI Studio Pro, this will change the configuration to that of the oscilloscope on which the LabNotebook file
was saved, including all its installed software options.

Choose File > Recall LabNotebook from the menu bar. The last selected file will open in the Preview window.

Edit Description
You can modify the description and annotations saved with the LabNotebook Entry. Setups and waveform data
originally saved with the LabNotebook cannot be changed.

1. Browse to and select the LabNotebook Entry.

2. Select View On/Off to preview the file.

3. From the top of the preview window, choose Edit Description.

4. Touch the pop-up description to open the virtual keyboard and edit the text.

5. Touch OK twice to save changes.

Annotate Screen Image

1. Browse to and select the LabNotebook Entry.

2. Select View On/Off to preview the file.

3. From the top of the preview window, choose Annotate Screen Image and use the drawing tools.

4. Click Done when finished to close the Drawing window and return to the preview.
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Manage Attachments
To append external files to the LabNotebook composite (such as images of the DUT, mask files, test scripts, or
anything relevant to the entry):

1. Browse to and select the LabNotebook Entry.

2. Select View On/Off to preview the file.

3. From the top of the preview window, choose Manage Attachments and select the files to attach. The file list
will build in the lower part of the File Attachments browser.

4. Click Update Attachments to finish.

To later remove appended files, click Manage Attachments and deselect the files from the list. Update Attachments
again to refresh the list.

Convert File Format
Individual entries in legacy .ZIP format Notebooks can be converted to the new LabNotebook file format.

1. In the LabNotebook Entry field, Browse to and select the legacy .zip file from the File Browser.

Note: Be sure to select the .zip file from the left side navigation pane so that its sub-entries appear in
the right pane, the Save buttons are active, and the file name appears in Current Path.

2. To batch convert all into separate LabNotebooks, on the file browser choose Save All As LNB Files.

To convert a single entry, select it from the Name list (right side), then choose Save As LNB File.

New LabNotebooks of the same name as the original entries are created in the D:\XPort folder. These can be
selected the same as any other .LNB files for Flashback, editing, reports, or extraction.

Extract Files
The component files that make up the LabNotebook composite (.PNG, .LSS, and .TRC) and any appended files can
be extracted into separate files.

1. Enter the path to the LabNotebook Entry, or Browse to the file.

2. To extract all files, under Content Management, choose Extract Files.

To extract only the attachments, choose Extract Attachments.

3. Navigate to the folder where you want the files extracted, and choose Extract Now.

A folder of the same name as the original LabNotebook containing the separate files will be created at that
location.

Flashback
Flashback restores the waveforms and setups saved with the LabNotebook Entry, so you can later analyze the
inputs that resulted in that capture.

1. Choose File > Recall LabNotebook, then enter the path to the LabNotebook Entry, or touch Browse and
navigate to the file.

2. Select the Flashback button.

3. To exit the Flashback, select the Undo button at the far right of the menu bar.
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Some result data not included in the Flashback are:

l Persistence data, although it is saved with the .LNB file and appears on reports.

l Histogram data over 16-bits.

l Floating point waveforms resulting from certain math operations that have much higher resolution than 16-
bits. This extra resolution is not preserved when traces are recalled using Flashback.

l Cumulative Measurements in process when Flashback is entered. When Flashback is used, they lose their
history and show instead only the results from the stored waveforms, not including any data taken from interim
acquisitions.

Report Generator
The Report Generator feature allows you to output a preformatted report consisting of an annotated screen image
and a summary of the setups in place when it was captured. The report can be sourced from an existing
LabNotebook, or it can be newly generated from the current state of the oscilloscope.

The logo and template used to create the report can be changed on the Email & Report Settings dialog.

Generate from LabNotebook
This procedure outputs an existing source as is. If you want to further annotate or change the description of a
LabNotebook file, first recall the LabNotebook.

1. Choose File > Report Generator from the menu bar.

2. Browse to and select the LabNotebook Entry. If it is in the Selected Folder, just use the Up/Down Arrow keys
to select it.

3. Optionally, use View On/Off to preview the selected file.
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4. Choose a Save Format of HTML, .RTF, or .PDF.

Note: Only HTML reports can later be saved to .RTF or .PDF format. The .RTF and .PDF reports can
only be combined into another report of the same format.

5. By default, the system will auto name the file "Report" followed by a counter number. To change the file name
or the Selected Folder, enter the full path and name in Save Report File, or touch Browse and use the File
Browser. By default, report files are saved to the D:\Xport folder on the instrument hard drive.

Note: Changing the file path, name or format will reset the counter to the next number in sequence.

6. If you do not want to use autonumbering, deselect Counter.

7. To save the report, choose Save Now.

Generate from Current State
If you are creating a report from the current state of the instrument, you will also be able to enter a new Description,
Annotate Screen Image, and select your capture Area/Color Preferences as when first creating a LabNotebook. See
Save LabNotebook.

However, when generating from Current State, you will not have saved a composite .LNB file that can later be
recalled or extracted into its component files. You will only have the preformatted report file.
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Print
For oscilloscopes that do not have a front panel Print button, these selections apply wherever you have a Print
Screen option on a dialog.
Print captures an image of the touch screen display, but there are several options as to what it does next with the
image:

l Send it to a Printer as formatted here.
l Copy it to the Windows Clipboard
l Save it to an image File using your current Screen Image Preferences
l Email an image file using your current Screen Image Preferences and Email Preferences
l Create a new LabNotebook file using your current LabNotebook Preferences

The Print Now button at the far right of the dialog can also be used to execute your current Print selection.

Printer Settings
1. Touch Select Destination and choose a printer.

2. Touch Properties to change any of the printer properties.

3. Choose a paper orientation of Portrait or Landscape.

4. Select Annotate Before Saving to mark up captures before they print. Each time you press Print, the capture
will open in the Drawing Tools window. When you are Done drawing, the image prints.

Capture Settings
1. Select a Screen Area:

l Grid Area Only includes any visible waveform grids, tables, and descriptor boxes.
l DSO Window includes the above plus any open dialogs, menu bar, and message bar.
l Full Screen is the full Windows display, including other visible applications and wallpaper.

2. Choose the Colors used in the capture:
l Standard uses a black background as it appears on the instrument.
l Print uses your print color palette (set in Utilities > Preference Setup) on a white background
l Black & White captures the image in grayscale.
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File Sharing Dialog (send email)
Use the File Sharing dialog to email files from the instrument. Set up email on the instrument from the Email &
Report Settings dialog.

1. Choose File > File Sharing from the menu bar.

2. Use the File Browser to select all the files to be emailed. Use CTRL + Click to select multiple files.

3. Optionally, change the email Recipient(s). This field defaults to whatever is in your email settings.

4. Enter a Subject line and Message Body, then Share Now.

Email & Report Settings
Configure oscilloscope email settings and report output on the Email & Report Settings dialog.

Email Settings

1. Select to use MAPI or SMTP.

2. If you chose SMTP, touch SMTP Server and enter the network address of your mail server.

3. Touch Originator Address (From:) and enter the instrument's e-mail address.

4. Touch Default Recipient Address (To:) and enter the recipient's e-mail address.

5. Optionally, select to always Attach Setup & Waveforms associated with image files selected for email.

6. Use Send Test Mail to send a confirmation message to ensure proper e-mail configuration.

Report Settings
The default report template uses our logo as a placeholder. You can replace this with your logo. Logo files should be
in bitmap (.bmp) format and not exceed 100 pixels high by 180 pixels wide. Place the file in the oscilloscope's
D:\Xport folder.

You can also use your own report template. Templates must be saved as .xsl or .xslt files and placed in the D:\Xport
folder.

Deselect Use Defualt next to each item you want changed, then Browse to and select the new files.
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Using the File Browser
Selecting Browse on any of the File menu dialogs opens a File Browser that enables you to perform basic disk utility
functions, as well as making file path/name and format selections.

Disk Utilities
New Folder, Delete Folder, Delete File, and Delete All Files can be used to change your file system prior to saving new
files. Be sure to first select the folder from the navigator (left) and file from the file list (right).

The buttons immediately above the file list let you change how items appear in the browser: icons only, details, etc.

File Path and Name
Use the navigator pane to the right to browse directories on the internal hard drive or USB drive. To select an existing
file to copy, move, change name, etc, use the file list to the right of the navigator. When an editable file is selected, the
Current Path and File Name are shown immediately below the navigator pane.

If you do not see the file you seek, try using the drop-down next to File name to change the file type to "All files (*.*)".

Auto Naming Selections
The checkboxes to turn on/off the Source prefix and the Counter number suffix used to autogenerate file names will
appear on the File Browser when saving files. These selections are linked to those on the underlying dialog, and
changing the value in either place causes it to change everywhere.

Note: If you change any part of the file path/name or format on the File Browser or the dialog, the Counter
number will reset to the last number in the sequence associated with that value.
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Example: Changing "Decode1-Table-0002" to "Decode1-CANFDTable-..." will reset the counter to "Decode1-
CANFDTable-0000" if there is no prior file named "Decode1-CANFDTable-..." .

Actions
The Close button accepts the selections you made on the File Browser and closes the browser window. If you do not
need to make further entries on the dialog to complete your task, you can choose to Save, Recall, Flashback, Email,
etc. right from the File Browser.

173



WaveMaster 8000HD Oscilloscopes Operator's Manual

Utilities & Preferences
The settings in this group allow you to customize the appearance and performance of the oscilloscope.

There are also multi-instrument functions that augment the oscilloscope capabilities.

Utilities
Utilities settings primarily control the instrument's interaction with other devices and systems.

To access the Utilities dialogs, choose Utilities > Utilities Setup... from the menu bar.

Utilities Dialog

Hardcopy (Print) Setup, Date/Time Setup and System Status buttons open their corresponding setup dialogs.

Show Windows Desktop minimizes the oscilloscope application window. Maximize the application by touching the
display icon located at the lower-right of the desktop.

Touch-Screen Calibration launches a sequence of display calibration screens. You will be prompted through a series
of actions to improve the precision and accuracy of the touch screen.

The Service button to the far right of the dialog launches a section of the application reserved for qualified Teledyne
LeCroy service personnel. An access code is required to enter this section.

Status
The Utilities Status dialog displays information about your instrument including model number, serial number,
firmware version, and installed hardware and software options.

Choose Utilities > Utilities Setup from the menu bar, then touch the Status tab.
Or
Choose Support > About from the menu bar.
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Remote Control
The Remote dialog contains settings to configure remote control of the instrument and also network access.
Supported remote control protocols are:

l TCPIP (Ethernet). Choose this if you wish to connect to the oscilloscope remotely from MAUI Studio Pro. The
instrument uses Dynamic Host Configuration Protocol (DHCP) as its default addressing protocol. You can
assign a static IP address using the standard Windows network setup menus.

l LXI (Ethernet). To use this option on Windows 10 oscilloscopes, you must supply the administrative user
password, SCOPEADMIN.

l GPIB. This selection is active if you are using the USB2-GPIB adapter. Connect the adapter from any USB port
on the oscilloscope to the GPIB port on the controller.

Note: See the MAUI Oscilloscopes Remote Control and Automation Manual for full instructions on making
the remote connection and sending remote commands, particularly if you wish to do so using fully
automated remote control/automation programs, instead of MAUI Studio Pro. A commented copy of the
Waveform Template (.tpl ) file is installed on the oscilloscope in C:\Program Files\LeCroy\XStream. Open
this ASCII file using any text editor to better understand the MAUI architecture for transferring waveform
data to and from the oscilloscope.

Set Up Remote Control

1. From the menu bar, choose Utilities > Utilities Setup, then touch the Remote tab.

2. On the Remote dialog, make a Control From selection.

3. If using TCPIP and wish to restrict control to specific network clients, choose Yes under Security. Enter the IP
addresses or DNS names of the authorized controllers in a comma-delimited list.

Remote Control Assistant Event Log
The Remote Control Assistant monitors communication between the controller and instrument. You can log all
transfers or errors only, and the log can be output to an ASCII file.

1. From the menu bar, choose Utilities > Utilities Setup, then touch the Remote tab.

2. Under Remote Control Assistant, touch Log Mode and choose Off, Errors Only, or Full Dialog.

3. To always clear the log at startup, check Reset to Errors Only and clear at startup.

Export Contents of the Event Log

1. From the menu bar, choose Utilities > Utilities Setup, then touch the Remote tab.

2. Touch the Show Remote Control Log button. The Event Logs pop-up is shown.

3. Enter a log file name in DestFilename, or touch Browse and navigate to an existing file.
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Note: New contents will overwrite the existing content; it is not appended.

4. Touch Export to Text File.

Auxiliary Output
Use the Aux Output dialog to configure the output of the Aux Out port and Cal Out port.

The Aux Out port outputs a 3.3 V CMOS into high impedance pulse following the selected event:

l Trigger Enabled sends a pulse when the trigger is ready (Ready indicator lit), but not necessarily triggered. It can
be used as a gating function to trigger another instrument. Enter the desired pulse Amplitude.

l Trigger Out sends a pulse upon a trigger (TRIG'D Indicator lit). If available, enter the desired Pulse Duration.

l Pass/Fail sends a pulse when Pass/Fail test conditions are met. Enter the desired Pulse Duration. Be sure to
also select Pulse Aux Out on the Pass/Fail Actions dialog.

Aux Out can also be used for the following signals :

l Square wave. Enter the desired Frequency.

l Reference DC Level. Enter the desired Amplitude.

l Fast Edge, which can be used to deskew channels.

l OscilloSYNC communication between Remote and Main oscilloscopes. This "button" is informative only,
alerting you that the oscilloscope is in a connected state. You cannot use Aux Out for any other type of output
during an OscilloSYNC connection.

Off disables output.

Calibration Output
On models equipped with a Cal Out hook on the front of the instrument, use these settings to configure the output
signal :

l For a Square wave signal, enter the wave Frequency and Amplitude into 1 MΩ, or choose to Set to 1 kHz, 1 V
Square Wave.

l For a reference DC Level, enter an Amplitude into 1 MΩ.

Off disables output.
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Date/Time
Date/Time settings control the instrument's timestamp. These numbers appear in the message bar and on
tables/records internal to the oscilloscope application, such as History Mode and WaveScan.

Note: On Windows 10 oscilloscopes, first switch to the Admin User LCRYADMIN to change the Date/Time
settings.

To access the Date/Time dialog, choose Utilities > Utilities Setup from the menu bar, then touch the Date/Time tab.

Manual Method
Enter the Hour, Minute, Second, Day, Month, and Year, then touch the Validate Changes button.

Internet Method
This method uses the Simple Network Time Protocol (SNTP) to read the time from time-a.nist.gov. The instrument
must be connected to an internet access device through a LAN (Ethernet) port.

If your connection is active, touch the Set from Internet button.

Options
Many optional software packages are available to extend the Analysis functions of the instrument. When you
purchase an option, you will receive a key code by email that activates the new functionality. Use the Options dialog
to activate software options by installing the key code. This dialog also displays the ScopeID and Serial #.

To install a key:

1. From the menu bar, choose Utillities > Utilities Setup, then open the Options tab.

2. Touch Add Key. The Virtual Keyboard appears onscreen.

3. Use the Virtual Keyboard to type the Key Code in the Enter Option Key field, then touch OK to enter the
information.

The Key Code is added to the list of Installed Option Keys. You can use the Up/Down buttons to scroll the list.
The software option that each key activates is displayed below the list.

4. Choose Yes to restart the oscilloscope application.
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Preferences
Preference settings have mostly to do with the appearance and performance of the instrument itself, rather than its
interaction with other devices/systems. These settings are called "non-volatile," because they are not lost when the
oscilloscope is restarted and do not change when a setup panel is recalled.

Access the Preferences dialogs by choosing Utilities > Preference Setup... from the menu bar.

Preferences Dialog

On the main Preferences dialog:

Power on AC will turn on the oscilloscope and launch the software as soon as you connect to AC power, without
having to first press the Power button.

Audible Feedback controls the instrument's audio output. Select this box to hear a beep each time you touch a
screen or front panel control.

Language sets the language used on the touch screen display.
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Calibration
Calibration ensures that the output from the analog-to-digital converters (ADCs) accurately represents the input. The
oscilloscope is calibrated at the factory at 23 °C (± 2 °C) prior to shipment. So that it maintains specified
performance, it is factory set to perform an automatic calibration routine upon power up.

Note: Warm the oscilloscope for at least 35-40 min. after power on to ensure it reaches a stable operating
temperature and completes the calibration routine. A message on the Calibration dialog alerts you when the
oscilloscope is warming-up. Specifications are not guaranteed during warm up.

High Definition oscilloscopes utilize Temperature Dependent Calibration to maintain gain accuracy. Within ±3 °C of
the last temperature that was calibrated for the vertical and horizontal settings in use, the oscilloscope should meet
all specifications once warmed up.

After warm up, within ~18-35 °C ambient temperature, the instrument will used cached calibrations to meet all
specifications, avoiding dynamic calibration to minimize disruptions.

If the internal temperature of the oscilloscope drifts outside the 18-35 °C temperature range, dynamic recalibration
will occur as long as (the default) Automatic Calibration remains enabled on the Preferences dialog. If the
temperature varies by ±3 °C of the last calibration temperature, the instrument will dynamically recalibrate again.

It is also possible to manually re-calibrate the oscilloscope for maximum accuracy. We recommend manually re-
calibrating when:

l You are using the oscilloscope in an environment more than ±3 °C from the last known calibration temperature.

l It has been over six months since the previous manual calibration.

From the menu bar, choose Utilities > Calibration. The Status section of the Calibration dialog will tell you if
"Calibration is recommended" for the current acquisition settings and environmental conditions.

There are two manual calibration routines available for selection:

l Calibrate All calibrates all possible combinations of vertical and horizontal settings. This calibration is valid for
the current temperature ±3 °C and may take over an hour. To maintain good performance, we recommend that
you Calibrate All about every six months. Calibrate All will remove any calibration that is over six months old,
with the exception of the original, factory calibration.

l Calibrate Current Setting calibrates the current vertical and horizontal settings. This calibration is valid for these
settings only at the current temperature ±3 °C and takes about 10 seconds.

Caution: Remove all inputs prior to calibrating the oscilloscope.

The Calibration dialog will inform you when the calibration is complete and valid.
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Acquisition
The Acquisition preference settings determine how traces behave as Vertical Offset changes. Choose Utilities >
Preference Setup to open the Acquisition dialog.

Offset Setting constant in:

l Volts keeps the amount of Offset in the amount of Volts specified, regardless of the V/div setting. As the Offset
is adjusted, the trace will appear to move up or down relative to the zero level.

l Div(isions) keeps the Vertical Offset level indicator stationary. The waveform remains on the grid as you
change V/div, but your Offset value will change.

Note: Horizontal scaling behavior is determined by the Navigation Reference setting on the Timebase
dialog.

Trigger Counter Setting is selected by default. It clears the trigger counter each time a new acquisition command is
sent. It is only made active for deselection when trigger Holdoff is set.

Color
Color dialog settings assign the colors used for channel, math, and memory traces. All dialogs, tables, and trace
descriptor boxes will match the color of the trace assigned here. You can choose different colors to be used on the
instrument and in print.

Note: Print colors are used only when the Colors control is set to Print on any of the File menu dialogs (Save
Screen Image, Print, etc.). Otherwise, the Screen colors are used for print output as well as on screen.

To make any setting, just touch the color swatch for either Screen or Print next to the trace number, and make a
selection from the Color pop-up menu.

For convenience, you can Preview print colors to see how the settings will appear in print output.

Touch Factory default colors to recall the original color settings for your instrument.
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Miscellaneous
These other Preference settings are located on the Miscellaneous dialog.

To add the Teledyne LeCroy logo to print output, check Print Teledyne LeCroy Logo When Printing Grid Area Only.
This identifies the instrument as the source of the image.

Dimming darkens/shades those areas of the source waveform that are not part of the Zoom trace.

Control Sensitivity adjusts the sensitivity of the front panel knobs. Optimized applies an acceleration algorithm to the
knobs. Legacy detects rotation of the front panel knobs in a manner similar to our legacy oscilloscopes.

Serial Decode Annotation Position: If you have Serial Trigger or Decode options installed on your instrument, this
control determines the placement of annotation labels relative to the trace line. It does not appear if there are no
installed options.

l On Trace places the label close to the line.

l On Noisy Trace sets the label further away to accommodate potential noise spikes in the trace.

Check Enable HTTP Screen Capture to enable remote capture of the touch screen display over a netowrk. This
setting is required to use the instrument with the WaveStudio software.

181



WaveMaster 8000HD Oscilloscopes Operator's Manual

Disk Utilities
Use the Disk Utilities dialog to manage files and folders on your instrument's hard drive. Disk Space information is
shown at the far right of the dialog for convenience.

Note: These tasks can also be accomplished using the standard Microsoft Windows file management tools.
Choose File > Minimize to access the Windows desktop and task bar.

Access the Disk Utilities dialog by selecting Utilities > Disk Utilities from the menu bar.

Delete a Single File
1. Touch the Delete button.

2. Browse to the current folder containing the file.

3. Browse to the file to be deleted, or use the Up and Down arrow buttons to scroll through the files in the folder.

4. With the desired file selected, touch Delete File.

Delete All Files in a Folder
1. Touch the Delete button.

2. Browse to the current folder containing the file.

3. With the desired folder selected, touch Empty Folder.

Create a New Folder
1. Touch Create.

2. Touch Current folder and provide the full path to the new folder, including the folder name.

3. Touch Create Folder.
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Maintenance
Topics in this section describe procedures for keeping the instrument in optimal working condition.

Restart/Reboot Instrument
To restart the oscilloscope application, choose File > Exit from the menu bar, then touch the Start DSO desktop
shortcut.

To reboot the instrument, which includes restarting the Windows OS:

1. From within the oscilloscope application, choose File > Shutdown.

2. Wait 10 seconds after the oscilloscope has fully shut down, then press the Standby Power button on the front
of the instrument.

Note: There is no File > Shutdown option on WaveRunner 8000-R oscilloscopes. Use the Standby Power
button.

Restore Default Setup
The front panel Default Setup button restores all the volatile setups to the factory default state.

You can also restore default settings via the touch screen:

1. Choose File > Recall Setup from the menu bar.

2. Choose to Recall From File.

3. Under Recall Default touch Recall Now.

Changing Screen Settings
On instruments running Windows 10, MAUI software font size and other screen settings are now changed using the
standard Windows 10 controls, rather than through the MAUI application. The text font is set to display at 125% by
default.

1. Swipe the touch screen from the right to display the Action Center.

2. Touch the All Settings icon .

3. Choose System settings.

4. Make your selections from the Settings dialog.

Tip: If prompted, enter password SCOPEADMIN to permit changes.

5. Swipe from the right again to return to MAUI.

6. Choose File > Shutdown, then press the Power button to reboot.
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Touch Screen Calibration
Periodically calibrate the touch screen to maintain its accuracy and responsiveness. We recommend that you use a
stylus rather than your finger for this procedure.

1. From the menu bar, choose Utilities > Utilities Setup.

2. On the Utilities main dialog, touch Touch-Screen Calibration.

3. Following the prompts, touch as close as possible to the center of each cross that appears on the screen until
the calibration sequence is complete.

Switching Windows Users
To maintain the highest security profile, the oscilloscope is shipped to run as the Standard user, LeCroyUser. If you
need to run as an Administrator, do the following to switch to LCRYADMIN. This will put the oscilloscope into a
"legacy" mode where it will run most like it did on Windows 7.

1. Choose File > Exit to exit the oscilloscope application.

2. Open the Windows Start menu .

3. Hover over the Teledyne LeCroy logo and select user LCRYADMIN.

4. Enter the password SCOPEADMIN (all uppercase).

To return to the default LeCroyUser account, repeat this procedure selecting LeCroyUser and entering the password
lecroyservice (all lowercase).

You may create as many other new user accounts on the oscilloscope as you wish, provided you are logged in as
LCRYADMIN when doing so.

Note: As long as there are any Standard (non-administrative) users, the oscilloscope will reboot into the last
active Standard user, regardless of whether you've switched to an administrative user. The only way to
change this is to make LeCroyUser (and any other new users you create) an Administrator.

Windows 10 External Display Setup
The Windows 10 default is to treat any external monitor connected to a Windows 10 PC as the primary touch screen.
On Windows 10 oscilloscopes with an external monitor attached, you will have to manually change the display
settings so that the oscilloscope is recognized as a touch screen.

If the external monitor is touch screen enabled and you wish to use it along with the oscilloscope to control the
oscilloscope application, you will need to repeat this procedure to also identify it as a touch screen.

1. Follow manufacturer's instructions to connect your monitor to the oscilloscope.

2. Choose File > Minimize to display the Windows Desktop.

3. Choose Start and enter the Search term "Tablet PC Setup." You should see the Tablet PC Settings
dialog.

184



Maintenance

If the monitor is not touch screen enabled, the Display selection will be 1|2 Multiple Monitors. This is OK.

If the monitor is touch screen enabled, be sure Display 1 (the oscilloscope) is selected.

4. Touch the Setup button.

5. When prompted for permissions, enter the password SCOPEADMIN and touch Yes.

The oscilloscope display will turn white, with the text "Touch this screen to identify it as the touch screen. If
this is not the Tablet PC screen, press Enter to move to the next screen."

6. Touch the oscilloscope display. You will see the instruction: "Press Enter to proceed to the next step to
complete your configuration."

7. Press Enter.
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8. If you wish to also configure the external display as a touch screen, repeat this procedure selecting the
external monitor name from the Display field on the Tablet PC Setup dialog.

Software and File Management
Due to the increased security of Windows 10, many more operations require Administrator permissions than did
with previous versions of Windows. When doing any of the following from the default LeCroyUser account on
Windows 10 oscilloscopes, you will be asked to supply the administrative password SCOPEADMIN (all uppercase).

l Installing software, both third-party applications and MAUI updates

l Accessing third-party applications or running an application as an administrator

l Admitting third-party applications to make changes to the MAUI application

l Using Device Manager and making changes within it (such as installing new device drivers)

l Moving, deleting, or copying certain files

l Changing global settings, such as Date/Time

Note: Certain QualiPHY compliance packages require you to run as an Administrator. See the product
documentation for an indication of when this is required.
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MAUI Firmware Update
The MAUI Software Setup Wizard can be used to install Teledyne LeCroy desktop software or oscilloscope firmware,
including the MAUI application, required DLLs, device drivers and low-level microcode for integrated circuits. Follow
these instructions for an oscilloscope firmware update.

The update does not modify or delete any saved panel setups, waveforms, screen captures, calibration constants, or
other data stored on the D: drive.

Caution: Do not install any firmware version prior to 8.6.1.8 on Windows 10 oscilloscopes. Doing so will
disrupt the normal behavior of the software, unless you run the recovery procedure. To install firmware on
Windows 10 machines, you must be logged on as an Administrator or supply the password SCOPEADMIN.
The installation may take several minutes. Do not power down at any point during the process.

Download Instructions

Tip: If the oscilloscope has an internet connection, choose File > Exit to close MAUI and use the
oscilloscope browser to download the installer directly.

1. Visit the firmware download page.

2. Select your series and model number.

3. Enter your registration login information, or create a new account. You cannot proceed without an account.

4. Click the download link, and choose to Save the installer to the oscilloscope Desktop or to a USB storage
device for transfer to the instrument.

Installation Instructions
1. From the oscilloscope menu bar, choose File > Exit to close MAUI.

2. Browse to MAUI Installer64_<version>.exe and double-click it to launch the setup wizard.

3. On Windows 10 instruments running as a Standard user (the default state), enter the Password
SCOPEADMIN (all uppercase).

4. Click Next to begin installation.

5. Review and accept the license agreement. Click Next.

6. At the Choose Components dialog, select the checkboxes for:
l MAUI Oscilloscopes, including DSO Device Drivers and Upgrade DSO Microcode
l MAUI Browsers
l Optionally, select SPARQ or WavePulser if you wish to drive that instrument from the oscilloscope.

Do not install MAUI Studio on an oscilloscope.
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7. Click Install.

8. If you receive Windows security warnings, trust and Install the file.

9. If you see the Hardware Programmers screen, accept all code installations, then click the closebox after you
see that programming has completed to return to the setup wizard.

10. When installation is complete, choose Reboot now and click Finish.

Note to QualiPHY Users
MAUI and QualiPHY software versions must match to a point-release to function properly. If you are upgrading your
oscilloscope firmware, upgrade your version of QualiPHY as soon as possible.
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Technical Support

Live Support
Registered users can contact their local Teledyne LeCroy service center at the number listed on our website.

You can also submit Technical Support requests via the website at:

teledynelecroy.com/support/techhelp

Resources
Teledyne LeCroy publishes a free Technical Library on its website. Manuals, tutorials, application notes, white
papers, and videos are available to help you get the most out of your Teledyne LeCroy products. Visit:

teledynelecroy.com/support/techlib

The Datasheet published on the product page contains the detailed product specifications.

Service Centers
For a complete list of offices by country, including our sales & distribution partners, visit:

teledynelecroy.com/support/contact

Teledyne LeCroy
700 Chestnut Ridge Road
Chestnut Ridge, NY, 10977, USA
teledynelecroy.com

Sales and Service:
Ph: 800-553-2769 / 845-425-2000
FAX: 845-578-5985
contact.corp@teledynelecroy.com

Support:
Ph: 800-553-2769
customersupport@teledynelecroy.com
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Returning a Product for Service
Contact your local Teledyne LeCroy service center for calibration or other service. If the product cannot be serviced
on location, the service center will give you a Return Material Authorization (RMA) code and instruct you where to
ship the product. All products returned to the factory must have an RMA.

Return shipments must be prepaid. Teledyne LeCroy cannot accept COD or Collect shipments. We recommend air-
freighting. Insure the item you’re returning for at least the replacement cost.

1. Remove all accessories from the instrument.

2. Label the instrument with:
l The RMA
l Name and address of the owner
l Description of failure or requisite service

3. Pack the instrument in its original shipping box, or an equivalent carton with adequate padding to avoid
damage in transit. Do not include the manual.

4. Mark the outside of the box with the shipping address given to you by Teledyne LeCroy. Be sure to add the
following:

l ATTN: <RMA code assigned by Teledyne LeCroy>
l FRAGILE

5. If returning a product to a different country: contact Teledyne LeCroy Service for instructions on completing
your import/export documents.

Extended warranty, calibration, and upgrade plans are available for purchase. Contact your Teledyne LeCroy sales
representative to purchase a service plan.

For a complete list of Teledyne LeCroy offices by country, including our sales and distribution partners, visit:
teledynelecroy.com/support/contact

Teledyne LeCroy
700 Chestnut Ridge Road
Chestnut Ridge, NY, 10977, USA

Sales and Service:

Ph: 800-553-2769 / 845-425-2000
FAX: 845-578-5985
contact.corp@teledynelecroy.com

Support:

Ph: 800-553-2769
customersupport@teledynelecroy.com
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Certifications
Teledyne LeCroy certifies compliance to the following standards as of the time of publication.

European Council
The instrument bears this mark to indicate it conforms to all applicable European Council standards.
Please see the EC Declaration of Conformity document shipped with your product for current
certifications.

EMC DIRECTIVE
The instrument meets the intent of EC Directive 2014/30/EU for Electromagnetic Compatibility. Compliance was
demonstrated to the following specifications as listed in the Official Journal of the European Communities:

EN IEC 61326-1:2021 EMC requirements for electrical equipment for measurement, control and laboratory use

EN IEC 61326-2-1:2021 Particular requirements for sensitive test and measurement equipment for EMC unprotected
applications 1, 2, 3

1 To ensure compliance with all applicable EMC standards, use high-quality shielded interface cables.

2 Emissions which exceed the levels required by this standard may occur when the instrument is connected to a test object.

3 This product is intended for use in nonresidential areas only. Use in residential areas may cause electromagnetic interference.

LOW VOLTAGE DIRECTIVE
The instrument meets intent of EC Directive 2014/35/EU for Product Safety. Compliance was demonstrated to the
following specifications as listed in the Official Journal of the European Communities:

EN 61010-1:2010+A1:2019 Safety requirements for electrical equipment for measurement, control and laboratory
use–Part 1: General requirements

EN 61010-2:030:2021 Safety requirements for electrical equipment for measurement, control, and laboratory use–
Part 2-030: Particular requirements for testing and measuring circuits

The design of the instrument has been verified to conform to the following limits:

Mains Supply Connector: Overvoltage Category II, instrument intended to be supplied from the building wiring at
utilization points (socket outlets and similar)

Measuring Circuit Terminals: No rated measurement category. Terminals not intended to be connected directly to
the mains supply.

Unit: Pollution Degree 2, operating environment where normally only dry, non-conductive pollution occurs.
Temporary conductivity caused by condensation should be expected.

END-OF-LIFE HANDLING / WEEE
The instrument bears this mark to indicate that it complies with the applicable European Union
requirements to Directives 2012/19/EU and 2013/56/EU on Waste Electrical and Electronic Equipment
(WEEE) and Batteries.

The instrument is subject to disposal and recycling regulations that vary by country and region. Many
countries prohibit the disposal of waste electronic equipment in standard waste receptacles. For more

information about proper disposal of your Teledyne LeCroy product, visit teledynelecroy.com/recycle.
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RESTRICTION OF HAZARDOUS SUBSTANCES (RoHS)
Unless otherwise specified, all materials and processes are compliant with RoHS Directive 2011/65/EU in its
entirety, inclusive of any further amendments or modifications of said Directive.

European Contact:*

Teledyne GmbH, European Division
Im Breitspiel 11c
D-69126 Heidelberg, Germany
Tel: + 49 6221 8270

United Kingdom
The instrument bears this mark to indicate conformity with health, safety, and environmental protection
standards for products sold within Great Britain (England, Wales and Scotland).The design of the product
has been verified to conform to the applicable harmonized standards and technical specifications, and
with the relevant Union harmonization legislation.

Australia and New Zealand
The instrument bears this mark to indicate it complies with the EMC provision of the Australian
Communication and Media Authority (ACMA) Radio Communications Act:

AS/NZS CISPR 11:2015, Radiated and Conducted Emissions, Group 1, Class A.

AUSTRALIA / NEW ZEALAND CONTACTS:*

RS Components Pty Ltd.
Suite 326 The Parade West
Kent Town, South Australia 5067

RS Components Ltd.
Unit 30 & 31 Warehouse World
761 Great South Road
Penrose, Auckland, New Zealand

* Visit teledynelecroy.com/support/contact for the latest contact information.

United States and Canada
The oscilloscope has been certified by Underwriters Laboratories (UL) to conform to the following safety
standards and bears the UL/cUL Listing Mark:

UL 61010-1 Third Edition – Safety standard for electrical measuring and test equipment.

UL 61010-2-030 Ed. 2-2018 – Particular requirements for equipment having testing or measuring circuits.

CAN/CSA-C22.2 No. 61010-1-12 – Safety requirements for electrical equipment for measurement, control and
laboratory use.

CAN/CSA-C22.2 No. 61010-2-030:18 – Particular requirements for equipment having testing or measuring circuits

China
Unless otherwise specified, all materials and processes are compliant with the latest requirements of
China RoHS 2.
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ISO Certification
Manufactured under an ISO 9000 Registered Quality Management System.

Intellectual Property
All patents pertaining to the WaveMaster 8000HD can be found on our website at:

teledynelecroy.com/patents/
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Index
1
1.85 mm interface 11

A
acquisition

pre-processing 20, 37

sampling mode 50

settings 180

action toolbar 22

activating traces 24

altitude 2

analog

inputs 12

persistence 73

at level measurements 88

attenuation 9, 38

auto naming 172

auto save 157

auto zero 41

AUX connectors 16, 176

averaging 20, 37, 119, 121

B
bandwidth

limiting 20, 36

barrel adapters 11

BNC connectors 9

C
cable de-embedding 37

calibration 14, 176, 179, 190

channel 35

descriptor box 20

frequency 13

setup 36

cleaning 2

clock

external 56

reference 56

sample 56

color 180

persistence 73

compliance 191

cooling 2

copy function 120

coupling 9, 20, 36

cursor 80

controls 83

readout 21

custom measurements 88

D
date and time 177

DBI 11, 36, 50

de-embedding 13, 37

default setup 163, 183

degauss 41

delay 50

post-trigger 50

pre-trigger 50

derated voltage 2

descriptor box 18, 20, 24

deskew 20, 37

dialogs 21

display 15, 71, 183

controls 71, 181
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extended 15

grid 18, 71

persistence 73

E
EC compliance 191

email 170-171

enhanced resolution 20, 37, 121

enhanced sample rate 20, 37

Ethernet 16

extended display 15

external monitor 15, 184

external trigger 12

F
FFT 123

file browser 172

file structure 172, 182, 186

filtering 20

bandwidth 36

LabNotebook entries 172

measurements 94

noise 37, 121

firmware 15, 17, 186

update 187

version 174

Flashback Recall 164, 166

foreground trace 24

frequency 121

response 13, 38, 123

front panel 181

G
gain 36, 54, 180

gating measurements 86

GPIB 175

grid 18, 60

auto grid 71

indicators 19

intensity 19, 72

style 71

group delay 38

H
hard drive 182

histograms 108, 125

WaveScan 137

holdoff 66

horizontal

controls 50

humidity 2

I
impedance 9, 11

import

.trc files 162

setup panels 163

input impedance 9, 11

inputs

analog 12

intensity

grid 72

interfaces 12

1.85 mm 11

ProBus 9

ProLink 9

interleaving 11, 50-51, 54

interpolation 37, 124

inversion 20, 37
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IP address 15, 175

L
labelling traces 26, 165

LabNotebook 18, 164-165

recall 166

save 164, 170

language selection 22

LEMO connectors 11

logs

remote control event 175

LXI 175

M
markers 87

mask testing 138

math 114, 116

descriptor box 20

function setup 114

graphing 115

on parameters 103

operators 114

measurements 84

cursors 80

custom 88

filtering 94

gating 86

graphing 108, 111-112

level 88

markers 87

pass/fail testing 138, 140

processing web 105

readout 102

statistics 85

measurements; status 102

measuring terminals 2

memory 150-152, 154

descriptor box 20

memory length 51, 54

multi-grid display 18

multi-stage triggers 65

multi-zoom 75, 78

N
noise 20

O
offset 180

operating environment 2

options 15, 17, 177

P
parameter compare 138, 140

parameter math 103

pass/fail testing 138, 140-141

passwords 184, 186

pattern trigger 48

persistence 73

histogram 125

trace styles 73

WaveScan 137

position

cursors 8

trace 77

post-trigger delay 50

power

ratings 3

standby 14

pre-processing 20
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pre-trigger delay 50

preferences 178

printing 15, 170, 181

probes 13

settings 41

tip selection 41

ProBus interface 9

processing web editor 105

ProLink interface 9

Q
qualified measurements 94

qualified trigger 65

R
real-time sampling mode 52

recall

LabNotebooks 166

reference clock 56

remote control 16, 175, 181

reports 164, 168
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